X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Kubuntu 16.04 here. Firefox updated to 55.01 and now no sound when browsing. Pulseaudio is latest version, but Firefox says I need to install Pulseaudio.

Veröffentlicht

Audio is fine with Chrome and Opera. I have purged Alsa. What do I need to do?

Audio is fine with Chrome and Opera. I have purged Alsa. What do I need to do?

Ausgewählte Lösung

Thank you for taking time to answer my question. By viewing the system logs, I was able to find the problem. First of all, after spending a lot of time troubleshooting, I figured out the pulseaudio does not run as a service, but runs at a user level. I figured this out by trying to start pulseaudio with root access and it returned this message:

W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).

When I lowered my access to user level and type the same command this shows in the system log:

pulseaudio[15545]: [pulseaudio] core-util.c: Home directory not accessible: Permission denied

Not sure why a program that is started at a user level is denied permission to my home directory but for sure this seemed to be a permission problem.

I decided to try reseting permissions on my home folder just to see what happened, after all its my home folder. It made no sense to me that I could not run an application that used it.

Since my name is Rich, my home folder is /home/rich

I changed permissions with this command:

chown -R rich:rich /home/rich

Gusto! Firefox plays perfect audio now.

Not sure how you can use th is to help others, but this change to Pulse Audio is going to be a real pain for a lot users.

Hope this helps.

Rich

Diese Antwort im Kontext lesen 3

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 26.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4259 Lösungen 59631 Antworten
Veröffentlicht

rpease said

Pulseaudio is latest version

This may be your problem,

Firefox v52+ disables all plugins except for Flash Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? {web link}

''rpease [[#question-1171580|said]]'' <blockquote> Pulseaudio is latest version </blockquote> This may be your problem, Firefox v52+ disables all plugins except for Flash [https://support.mozilla.org/en-US/kb/npapi-plugins Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work?] {web link}
FredMcD
  • Top 10 Contributor
4259 Lösungen 59631 Antworten
Veröffentlicht

Also, v55 is giving many users problems. Downgrade to v54.

https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release https://www.mozilla.org/en-US/firefox/organizations/

https://www.mozilla.org/en-US/firefox/organizations/notes/

https://www.mozilla.org/en-US/firefox/organizations/system-requirements/

Also, v55 is giving many users problems. Downgrade to v54. https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out Firefox; Extended Support Release https://www.mozilla.org/en-US/firefox/organizations/ https://www.mozilla.org/en-US/firefox/organizations/notes/ https://www.mozilla.org/en-US/firefox/organizations/system-requirements/
Veröffentlicht

Ausgewählte Lösung

Thank you for taking time to answer my question. By viewing the system logs, I was able to find the problem. First of all, after spending a lot of time troubleshooting, I figured out the pulseaudio does not run as a service, but runs at a user level. I figured this out by trying to start pulseaudio with root access and it returned this message:

W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).

When I lowered my access to user level and type the same command this shows in the system log:

pulseaudio[15545]: [pulseaudio] core-util.c: Home directory not accessible: Permission denied

Not sure why a program that is started at a user level is denied permission to my home directory but for sure this seemed to be a permission problem.

I decided to try reseting permissions on my home folder just to see what happened, after all its my home folder. It made no sense to me that I could not run an application that used it.

Since my name is Rich, my home folder is /home/rich

I changed permissions with this command:

chown -R rich:rich /home/rich

Gusto! Firefox plays perfect audio now.

Not sure how you can use th is to help others, but this change to Pulse Audio is going to be a real pain for a lot users.

Hope this helps.

Rich

Thank you for taking time to answer my question. By viewing the system logs, I was able to find the problem. First of all, after spending a lot of time troubleshooting, I figured out the pulseaudio does not run as a service, but runs at a user level. I figured this out by trying to start pulseaudio with root access and it returned this message: W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified). When I lowered my access to user level and type the same command this shows in the system log: pulseaudio[15545]: [pulseaudio] core-util.c: Home directory not accessible: Permission denied Not sure why a program that is started at a user level is denied permission to my home directory but for sure this seemed to be a permission problem. I decided to try reseting permissions on my home folder just to see what happened, after all its my home folder. It made no sense to me that I could not run an application that used it. Since my name is Rich, my home folder is /home/rich I changed permissions with this command: chown -R rich:rich /home/rich Gusto! Firefox plays perfect audio now. Not sure how you can use th is to help others, but this change to Pulse Audio is going to be a real pain for a lot users. Hope this helps. Rich
FredMcD
  • Top 10 Contributor
4259 Lösungen 59631 Antworten
Veröffentlicht

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.
James
  • Top 25 Contributor
  • Moderator
1598 Lösungen 11289 Antworten
Veröffentlicht

FredMcD said

rpease said
Pulseaudio is latest version

This may be your problem,

Firefox v52+ disables all plugins except for Flash Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? {web link}

This is on Linux and not Windows as you only have used. The PulseAudio is not a Plugin but a sound server. https://en.wikipedia.org/wiki/PulseAudio

Firefox releases for Linux since Fx 52.0 and later Releases now uses PulseAudio to play sound instead of ALSA. https://www.mozilla.org/firefox/52.0/releasenotes/

''FredMcD [[#answer-997267|said]]'' <blockquote> ''rpease [[#question-1171580|said]]'' <blockquote> Pulseaudio is latest version </blockquote> This may be your problem, Firefox v52+ disables all plugins except for Flash [https://support.mozilla.org/en-US/kb/npapi-plugins Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work?] {web link} </blockquote> This is on Linux and not Windows as you only have used. The PulseAudio is not a Plugin but a sound server. https://en.wikipedia.org/wiki/PulseAudio Firefox releases for Linux since Fx 52.0 and later Releases now uses PulseAudio to play sound instead of ALSA. https://www.mozilla.org/firefox/52.0/releasenotes/

Geändert am von James