X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Hilfeforum

Drop-down lists are double spaced in FF 52.2. They were fine in V45.9. Can this be fixed? I can send a screen capture if thay will help.

Veröffentlicht

Has anyone else run into a problem with drop-downs after moving to ESR 52.2? We had no problems on the previous version 45.9. After the update to 52.2 the lists in our drop-downs are now double spaced. The same drop-down is also fine in Internet Explorer and Chrome. We believe this is also causing issues when doing Print to PDF on some other forms.

Has anyone else run into a problem with drop-downs after moving to ESR 52.2? We had no problems on the previous version 45.9. After the update to 52.2 the lists in our drop-downs are now double spaced. The same drop-down is also fine in Internet Explorer and Chrome. We believe this is also causing issues when doing Print to PDF on some other forms.
Angefügte Screenshots

Ausgewählte Lösung

Try to set dom.forms.select.customstyling to false.

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; .NET CLR 1.1.4322; rv:11.0) like Gecko

Weitere Informationen

Shadow110 1072 Lösungen 14836 Antworten
Veröffentlicht

Try updating browser to latest release Ver 54 From Menu Bar : Help then About or which ever way you do so. If problem persists please come back and update. If solves your problem please come back and close this as solved.

Try updating browser to latest release Ver 54 From Menu Bar : Help then About or which ever way you do so. If problem persists please come back and update. If solves your problem please come back and close this as solved.

Fragesteller

Our department is running on the ESR update channel. The "About Mozilla Firefox" form says Firefox is up to date. I need a fix that works with the latest version of the ESR.

Our department is running on the ESR update channel. The "About Mozilla Firefox" form says Firefox is up to date. I need a fix that works with the latest version of the ESR.
cor-el
  • Top 10 Contributor
  • Moderator
17846 Lösungen 161524 Antworten
Veröffentlicht

This issue could be theme related, either a Firefox theme or a Windows theme.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

This issue could be theme related, either a Firefox theme or a Windows theme. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Fragesteller

The steps above did not help. If I do "Refresh Firefox" the 1st time I open FF the problems go away (the drop down lists are single spaced and I can successfully do Print to PDF). But, once I close and reopen FF the problems return. The problem with Print to PDF is that there is no text in PDF created. I think it may be a font issue but I don't know for sure.

The steps above did not help. If I do "Refresh Firefox" the 1st time I open FF the problems go away (the drop down lists are single spaced and I can successfully do Print to PDF). But, once I close and reopen FF the problems return. The problem with Print to PDF is that there is no text in PDF created. I think it may be a font issue but I don't know for sure.

Fragesteller

We found that for some reason going into about:config and changing the value of this preference name to false fixes both issues. Any ideas? Do we need to tell all our users to go into about:config to make this change and hope they don't mess anything up?

browser.tabs.remote.autostart.2;false

We found that for some reason going into about:config and changing the value of this preference name to false fixes both issues. Any ideas? Do we need to tell all our users to go into about:config to make this change and hope they don't mess anything up? browser.tabs.remote.autostart.2;false
jscher2000
  • Top 10 Contributor
8950 Lösungen 73359 Antworten
Veröffentlicht

zajlzoo said

We found that for some reason going into about:config and changing the value of this preference name to false fixes both issues. Any ideas? Do we need to tell all our users to go into about:config to make this change and hope they don't mess anything up?

browser.tabs.remote.autostart.2;false

Yes. Websites often specify style rules for the <option> elements of <select> controls. In Firefox 49-53, with multiprocess enabled, most of those style rules are ignored. Old thread from the Firefox 49 days: dropdown.

There is work in process to fix that, and some of the fix may have landed in Firefox 54, but users are still mentioning issues with font sizes/weights in Firefox 54. Hopefully in Firefox 55?

''zajlzoo [[#answer-979678|said]]'' <blockquote> We found that for some reason going into about:config and changing the value of this preference name to false fixes both issues. Any ideas? Do we need to tell all our users to go into about:config to make this change and hope they don't mess anything up? <br><br> browser.tabs.remote.autostart.2;false </blockquote> Yes. Websites often specify style rules for the &lt;option> elements of &lt;select> controls. In Firefox 49-53, with multiprocess enabled, most of those style rules are ignored. Old thread from the Firefox 49 days: [https://support.mozilla.org/questions/1146251 dropdown]. There is work in process to fix that, and some of the fix may have landed in Firefox 54, but users are still mentioning issues with font sizes/weights in Firefox 54. Hopefully in Firefox 55?
cor-el
  • Top 10 Contributor
  • Moderator
17846 Lösungen 161524 Antworten
Veröffentlicht

Ausgewählte Lösung

Try to set dom.forms.select.customstyling to false.

Try to set dom.forms.select.customstyling to false.