X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Latest version of firefox crashes (firefox:10271): Gtk-CRITICAL **: gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

Veröffentlicht

The weird thing is, it starts if I'm running my working older version at the same time. However, both copies show the version as the older one. So now I don't know what it's doing

Here is how I run it: Under linux Download the latest version, unpack it go to the firefox directory ./firefox-bin

The weird thing is, it starts if I'm running my working older version at the same time. However, both copies show the version as the older one. So now I don't know what it's doing Here is how I run it: Under linux Download the latest version, unpack it go to the firefox directory ./firefox-bin

Mehr Details zum System

Installierte Plugins

  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • Shockwave Flash 11.2 r202

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:34.0) Gecko/20100101 Firefox/34.0

Weitere Informationen

James
  • Moderator
1603 Lösungen 11348 Antworten
Veröffentlicht

You cannot run two instances of Firefox on the same Profile as to why it is just opening a new windows of the version currently running.

Also try to use the firefox script and not the firefox-bin so in terminal ./firefox

Also as of Firefox 46.0 and newer you need GTK 3.4 (three.four) or preferably newer (which is easy if using a current Linux distro that is not a LTS) in order for Firefox to run. As a result you also need GTK3 theme or Firefox will look unthemed.

You cannot run two instances of Firefox on the same Profile as to why it is just opening a new windows of the version currently running. Also try to use the firefox script and not the firefox-bin so in terminal '''./firefox''' Also as of Firefox 46.0 and newer you need GTK 3.4 (three.four) or preferably newer (which is easy if using a current Linux distro that is not a LTS) in order for Firefox to run. As a result you also need GTK3 theme or Firefox will look unthemed.
Veröffentlicht

Fragesteller

How do I get GTK 3.4?

I am running ubuntu 12.10

How do I get GTK 3.4? I am running ubuntu 12.10
James
  • Moderator
1603 Lösungen 11348 Antworten
Veröffentlicht

Even the rather old Ubuntu 12.10 from Oct 2012 should have GTK 3.6.0 at minimum available in package manager.

Even the rather old Ubuntu 12.10 from Oct 2012 should have GTK 3.6.0 at minimum available in package manager.
Veröffentlicht

Fragesteller

Synaptic thinks I have libgtk-3-0 version 3.6.0-0ubuntu3.3, I don't know if there's another way to tell.

Is 'that the gtk I should have?

Synaptic thinks I have libgtk-3-0 version 3.6.0-0ubuntu3.3, I don't know if there's another way to tell. Is 'that the gtk I should have?