Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Videos and GIFs play at first but after Firefox has been running for a while, they won't play anymore and I have to restart Firefox.

  • 12 Antworten
  • 1 hat dieses Problem
  • 10 Aufrufe
  • Letzte Antwort von FredMcD

more options

When I first start Firefox, videos and GIFs on sites like Facebook and Youtube, etc. will play with no problems but, after Firefox has been running for a while, they won't play anymore. The only way I can get them to play again, is to close Firefox then start it up again. Running the 64 bit version in Windows 10.

Alle Antworten (12)

more options

How long is awhile?

Youtube currently uses the HTML5 player.

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

more options

A while as in anything from 5 to 10 minutes and, sorry but nothing in that link helps me. I've already gone through everything there. The problems there are for videos that won't play at all. As I mentioned in my question, Videos in any website: Youtube, Facebook, Vimeo, etc. all play just fine when I start Firefox but, after a while - anything from 5 to 10 minutes, they won't play. I just get the loading symbol/icon which just goes round and round and the video or GIF doesn't load and play.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

No luck with that.

Tried Firefox in safe mode. Everything was fine for 8 minutes, then videos wouldn't load.

Started the PC in safe mode - same thing, 5 minutes in.

I don't know what you mean by "safe websites" though.

Cheers

more options
more options

I have the latest nvidia drivers. I always keep them up to date. I have tried with hardware acceleration on and off, neither one makes a difference.

I should point out that the problem doesn't occure in Microsoft Edge or Chrome but, to be honest, I hate those browsers and don't want to use them.

I've just downloaded the 32 bit version of Firefox. So, I'm going to uninstall this one, clear out any leftover files from the hard drive, then install 32 bit. I'll see how that goes and then update this later on.

more options

Update: No change. Everything still just won't play after 5-10 minutes

more options

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste async and pause while the list is filtered (3) Double-click the dom.ipc.plugins.asyncdrawing.enabled preference to switch the value from true to false

This might not take effect until the next time you exit Firefox and start it up again.


One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, so it would be helpful to know whether you have this feature turned on. To check that, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for Multiprocess Windows and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

more options

dom.ipc.plugins.asyncdrawing.enabled is already false. So on to the next one.

I have browser.tabs.remote.autostart AND browser.tabs.remote.autostart.2. The first was 'false' and the second was 'true'. So, I changed it to 'false' and I'll update again once I've had Firefox running for a while

Thanks

more options

Update: Just when I thought "This might have worked. Videos are still playing. GIFs are still playing...."

But, then..... problem is still there.... :(

more options

Another update: I've rolled back to Firefox 39.0 and everything appears to be working fine. So, sometime after version 39.0 there's either been a change in code or something in my hardware/installed software is conflicting with later versions of Firefox.

Either way. It's working now and I'll just stick with the earlier version.

more options

I called for more help.