Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox keeps asking about my addons at startup

  • 5 Antworten
  • 3 haben dieses Problem
  • 810 Aufrufe
  • Letzte Antwort von FredMcD

more options

Hi, like I said in the title Firefox is constantly asking me to confirm addons installation over dans over. I'm currently on windows 10 and transferred my Firefox data from a mac if this helps. So I read a lot of topics about people having the same problem and here are the things I tried.

- deleting "extension.ini" and "extension.json" in the profile directory - uninstall and reinstall Firefox (including deleting the existing profile to install a "fresh" version of Firefox) - "Refreshing" Firefox twice (previous and new install). - creating a new profile with the Firefox profile manager - Disabling the Firefox checkbox in Firefox sync and installing them manually several times.

Thank you in advance

Ausgewählte Lösung

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Then do this again. Delete all extensions*.* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (5)

more options

It is possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":


You will have to approve the updating one last time.

more options

Thanks you for your answer. However, I already tried deleting those files. I retried once again and it still didn't solve the problem. I noticed that the file "extensions.sqlite" never appered in my profile folder. Is that normal ? May it be the cause of my issue?

more options

Ausgewählte Lösung

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Then do this again. Delete all extensions*.* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

more options

Didn't have this type of softwares but deleting the "compatiblity.ini" file solved the issue. Thank you very much for your help !

more options

Glad to help. Safe Surfing.