Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox very slow except after running msconfig and restarting

  • 7 Antworten
  • 7 haben dieses Problem
  • 715 Aufrufe
  • Letzte Antwort von kilp20

more options

For a few weeks I have been trying to fix an extremely slow Firefox, with slow respose to keys and to mouse, and some websites have taked a minute or more to connect (also trying to move the window with the mouse is jerky). It's unusable and I've had to resort to Internet Explorer, which has kept up to speed, as has everything else on the computer.

I've tried many supposed remedies found by internet search and on the Firefox support pages, including malware scans (all clean, apparently), safe mode, creating a new profile, etc.. And done a registry clean. I did find that after a System Restore it ran fast, but the next day (i.e. on restarting the computer) it ran slow again. Anyway, system restore is not a practical solution.

Finally I think the best situation to report is this. - if I run msconfig and tick Normal Startup, and then restart (without switching off), then firefox runs fast and everything is as it should be; this is true also with restored bookmarks and passwords, and all the add-ons and plug-ins allowed. - but if I restart after machine switchoff (and today just a menu restart without doing the msconfig thing), then Firefox reverts to slow again.

I can't make head or tail of why this is so. Can you advise? John Kilpatrick - Windows 10, HP desktop, Trend Micro Internet Security.

Ausgewählte Lösung

Well, I've tried everything, but always ended up running msconfig and doing something-or-other about services, before Firefox would run at speed. Today, however, it was fine when the computer started up. So may as well call it a day with respect to this issue. Ta.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (7)

more options

Hello kilp20,

I am sorry that your FireFox is running slow. I will do my best to support you and get your FireFox running fast again! Sound's good right? Let's start with a few simple steps.

  1. Make sure your FireFox is up to date. (Yours looks like it is however to check please click New Fx Menu then click on Help-29 then click on "About FireFox" it will prompt you to download an update if one is available).
  2. Run a malware scan on your computer.
  3. If FireFox someetimes freezes then please refer to this article about FireFox hangs or is not responding - how to fix (click here)
  4. Refer to these two articles if FireFox uses a lot of CPU and RAM. (CPU article - RAM article )

Please let me know if those work.

more options

Version 47.0.1 - newly loaded (see below). I've done numerous different malware scans - nothing found. When it's slow it shows CPU usage up to 25% even when "doing nothing". When it's OK it's just a low number (like 1% now). I've followed all the tips except the one about contents-prefs - but a couple of days ago I deleted Firefox completely, including profile (having made backup), and reloaded. No improvement, even without copying any files from the profile backup. However, I've just deleted contents-prefs and restarted windows and firefox, and right now everything is at full speed. I'm switching PC off now, and tomorrow morning I'll see how things are when I fire up again.

more options

This morning's tests. 1. Start PC, sign in, click firefox as soon as icon available; runs SLOW 2. Windows restart, wait 5-10 min before signing in, 5-10 min before clicking firefox; runs SLOW 3. Close firefox and shift-click it to start in safe mode; runs SLOW 4. Run msconfig, tick "Normal startup" box, do Windows restart, start firefox; runs FAST 5. Run msconfig, tick "Normal startup" box again*, Shut down and reboot PC; firefox runs SLOW (25-27% CPU, and it took 3 minutes for Astronomy picture of the day archive not to load, had to End Task in task manager) 6. Run msconfig, tick "Normal startup" box, Windows restart; firefox runs FAST (e.g. takes 3 seconds for the Astronomy page to load).

 * the ticked "Normal startup" box in msconfig won't persist - it always reverts to "Selective startup" - there's chat about this on the internet, but no solution that works that I can find.

So it seems I'm doomed to do the msconfig/restart trick every time I switch on. I think the problem must lie somewhere in Windows Services, but I despair of ever finding it. Why on earth is Firefox the only program affected (e.g. Thunderbird works OK)?

Back later today. John

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Firefox in safe mode doesn't solve problem. I've failed to start PC in safe mode with networking, but ....

But all OK today. Yesterday in msconfig Services, I ticked Disable All then Enable All. Maybe some needed service has come to life as a result.

I'd like to put this query into abeyance for a day or two, then if all is OK I'll close it.

Thanks, John

more options

Ausgewählte Lösung

Well, I've tried everything, but always ended up running msconfig and doing something-or-other about services, before Firefox would run at speed. Today, however, it was fine when the computer started up. So may as well call it a day with respect to this issue. Ta.