Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Why does Firefox for Android not sync with own Sync-1.5 server?

  • 1 Antwort
  • 3 haben dieses Problem
  • 37 Aufrufe
  • Letzte Antwort von traxer

more options

1. I installed the CA certificate that was used to sign the certificate of my own Sync-1.5 server.

2. I verified that Firefox can connect to my own Sync-1.5 server without refusing the SSL certificate.

3. I used about:config to set identity.sync.tokenserver.uri to the address of my own Sync-1.5 server as described in https://docs.services.mozilla.com/howtos/run-sync-1.5.html

4. I signed in to my Firefox Account using Firefox->Settings->General->Sign in.

5. I navigated to Firefox->Settings->General an clicked on my account. Firefox tells me that I am logged in, but never synced

6. I click Sync now. Firefox still tells me that it never synced. Android->Settings->Accounts->Firefox tells me that it synced.

This was all done on a fresh installation of Firefox.

The logs of my webserver show no connection attempt from my device. Syncing my desktop Firefox (FF 45, Linux) using the same account and Sync-1.5 server works fine.

Firefox 46.0.1. Android 5.1, Samsung Galaxy Note 10.1 GT-N8020

Angefügte Screenshots

Geändert am von traxer

Ausgewählte Lösung

Using

   adb logcat | grep FxAccounts

as suggested on http://www.ncalexander.net/blog/2014/07/05/how-to-connect-firefox-for-android-to-self-hosted-services/, I found

   E/FxAccounts(11682): javax.net.ssl.SSLException: hostname in certificate didn't match: <my-sync-15.example.com> != <www.example.com>

I changed the webserver configuration such that the certificate for my-sync-15.example.com is served by default. This solved the problem.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (1)

more options

Ausgewählte Lösung

Using

   adb logcat | grep FxAccounts

as suggested on http://www.ncalexander.net/blog/2014/07/05/how-to-connect-firefox-for-android-to-self-hosted-services/, I found

   E/FxAccounts(11682): javax.net.ssl.SSLException: hostname in certificate didn't match: <my-sync-15.example.com> != <www.example.com>

I changed the webserver configuration such that the certificate for my-sync-15.example.com is served by default. This solved the problem.