X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Ubuntu 16 Thunderbird will not start

Veröffentlicht

Upgraded to Ubuntu 16 LTS. Thunderbird will not start. Tried uninstalling and reinstalling Thunderbird. Same result. When asked to start, the icon appears in the taskbar, flashes for say 30-45 seconds and disappears. I checked /var/log and could not find any Thunderbird log so have no idea what the problem might be. Any help would be deeply appreciated.

A couple of things. This is an effort at a first start for Thunderbird after the install so it has no accounts configured. Second- is there any way to start Thunderbird in safe mode from the command line?


Regards and many thanks

Expat

Upgraded to Ubuntu 16 LTS. Thunderbird will not start. Tried uninstalling and reinstalling Thunderbird. Same result. When asked to start, the icon appears in the taskbar, flashes for say 30-45 seconds and disappears. I checked /var/log and could not find any Thunderbird log so have no idea what the problem might be. Any help would be deeply appreciated. A couple of things. This is an effort at a first start for Thunderbird after the install so it has no accounts configured. Second- is there any way to start Thunderbird in safe mode from the command line? Regards and many thanks Expat

Ausgewählte Lösung

Two safe mode options.

Hold shift while starting or use the command line option -safe-mode See https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/49.0.2623.108 Chrome/49.0.2623.108 Safari/537.36

Weitere Informationen

amanchesterman 189 Lösungen 994 Antworten
Veröffentlicht

Hilfreiche Antwort

Even if there are no accounts configured, Thunderbird should start: it should present you with the 'new account wizard' when it begins. The most likely problem is a missing dependency. Where did you install it from? Personally I would use Synaptic or the Software Centre. If you are good with the command line (which I'm not!) I'd advise that you thoroughly remove (purge?) the current installation before you try again. To answer your second question, yes you can start in safe mode from the Terminal: https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options

Even if there are no accounts configured, Thunderbird should start: it should present you with the 'new account wizard' when it begins. The most likely problem is a missing dependency. Where did you install it from? Personally I would use Synaptic or the Software Centre. If you are good with the command line (which I'm not!) I'd advise that you thoroughly remove (purge?) the current installation before you try again. To answer your second question, yes you can start in safe mode from the Terminal: https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options

Fragesteller

amanchesterman

Many kind thanks for the suggestions and especially for the guide for CLI. Originally Thunderbird comes included in the distro (16.1 LTS). So when it refused to start I was surprised. I uninstalled it using the Ubuntu software store and reinstalled it from there. I have not tried a purge from CLI but thats an excellent idea.

What bothers me is in the past one could always look at /var/log and find problems. So far I have been unable to do this with this instance of Thunderbird.

Again many thanks for your time and explanation

Expat

amanchesterman Many kind thanks for the suggestions and especially for the guide for CLI. Originally Thunderbird comes included in the distro (16.1 LTS). So when it refused to start I was surprised. I uninstalled it using the Ubuntu software store and reinstalled it from there. I have not tried a purge from CLI but thats an excellent idea. What bothers me is in the past one could always look at /var/log and find problems. So far I have been unable to do this with this instance of Thunderbird. Again many thanks for your time and explanation Expat

Fragesteller

sudo apt-get purged and reinstalled Thunderbird. Still would not start from the icon. Would not start from CLI as user. sudo thunderbird got me to the setup wizard. In the terminal window were various errors as posted here. Any help or suggestions would be appreciated.

All-Series:~$ sudo thunderbird

(process:4139): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(thunderbird:4139): Gtk-CRITICAL **: IA__gtk_clipboard_set_with_data: assertion 'targets != NULL' failed

-- Exception object -- + _message (string) + stack (string) 343 chars + code (number) 0 + uri (string) 'http://autoconfig.gmail.com/mail/config-v1.1.xml' + constructor (function) 6 lines + message (string) + toString (function) 4 lines

-- Stack Trace -- Exception@chrome://messenger/content/accountcreation/util.js:132:5 ServerException@chrome://messenger/content/accountcreation/fetchhttp.js:262:3 FetchHTTP.prototype._response@chrome://messenger/content/accountcreation/fetchhttp.js:190:19 FetchHTTP.prototype.start/request.onerror@chrome://messenger/content/accountcreation/fetchhttp.js:117:36 1461338265851 addons.update-checker WARN Update manifest for messagingmenu@mozilla.com did not contain an updates property 1461338266001 addons.update-checker WARN Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property 1461338266158 addons.update-checker WARN Update manifest for thunderbird-hotfix@mozilla.org did not contain an updates property


Thanks Expat

sudo apt-get purged and reinstalled Thunderbird. Still would not start from the icon. Would not start from CLI as user. sudo thunderbird got me to the setup wizard. In the terminal window were various errors as posted here. Any help or suggestions would be appreciated. All-Series:~$ sudo thunderbird (process:4139): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed (thunderbird:4139): Gtk-CRITICAL **: IA__gtk_clipboard_set_with_data: assertion 'targets != NULL' failed -- Exception object -- + _message (string) '' + stack (string) 343 chars + code (number) 0 + uri (string) 'http://autoconfig.gmail.com/mail/config-v1.1.xml' + constructor (function) 6 lines + message (string) '' + toString (function) 4 lines * -- Stack Trace -- Exception@chrome://messenger/content/accountcreation/util.js:132:5 ServerException@chrome://messenger/content/accountcreation/fetchhttp.js:262:3 FetchHTTP.prototype._response@chrome://messenger/content/accountcreation/fetchhttp.js:190:19 FetchHTTP.prototype.start/request.onerror@chrome://messenger/content/accountcreation/fetchhttp.js:117:36 1461338265851 addons.update-checker WARN Update manifest for messagingmenu@mozilla.com did not contain an updates property 1461338266001 addons.update-checker WARN Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property 1461338266158 addons.update-checker WARN Update manifest for thunderbird-hotfix@mozilla.org did not contain an updates property ----------------------------------- Thanks Expat
Matt
  • Top 10 Contributor
  • Moderator
3361 Lösungen 23289 Antworten
Veröffentlicht

Ausgewählte Lösung

Two safe mode options.

Hold shift while starting or use the command line option -safe-mode See https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options

Two safe mode options. Hold shift while starting or use the command line option -safe-mode See https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options

Fragesteller

Hi Matt

Many kind thanks for the helpful CLI options.

What I ended up having to do was chown the /home/user/.thunderbird directory. Something about this install of Ubuntu 16 LTS fragged the ownership of .thunderbird. After a lot of messing about tried this and it now works.

Again many kind thanks for your interest and suggestions

expat

Hi Matt Many kind thanks for the helpful CLI options. What I ended up having to do was chown the /home/user/.thunderbird directory. Something about this install of Ubuntu 16 LTS fragged the ownership of .thunderbird. After a lot of messing about tried this and it now works. Again many kind thanks for your interest and suggestions expat