Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Intel application auto launch won't start Firefox with my profile

  • 16 Antworten
  • 1 hat dieses Problem
  • 16 Aufrufe
  • Letzte Antwort von Toa_Of_Justice

more options

I was referred here by Intel tech support. My original thread is at: https://communities.intel.com/message/389686

My Intel wireless network settings lets me automatically launch an application whenever I connect to a certain wireless network ("Enable Intel connection settings" in Control Panel\Network and Internet\Manage Wireless Networks). However, when I choose to launch Firefox, it launches without my profile.

I located the profile folder according to the directions in the topic "How can I determine which profile Firefox 3 is currently using?". I was greeted with the attached error message upon trying to open the profile folder from the "profile-less" instance of Firefox. When I launch Firefox after closing the "profile-less" instance, my profile is loaded normally.

I tried to set my auto launch application path using a command line argument, but that resulted in a message indicating that my program path was invalid.

I tried creating a batch file that started Firefox, then setting my auto launch application path to that batch file. The text of my batch file is (including quotes):

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

Unfortunately, that didn't work either. I would like to know why Firefox can't load my profile using the auto launch feature, but it can load my profile when I launch it from my taskbar.

Angefügte Screenshots

Alle Antworten (16)

more options

Are you allowed to specify a .lnk shortcut in the dialog? If so, you could try this to "follow" your pinned taskbar shortcut:

"C:\Users\username\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\Mozilla Firefox.lnk"

Does that work any better?

If not, I think you might need to use the -profile command-line switch with the .exe:


I've never tried that myself.

Geändert am von jscher2000

more options

You can paste this code on the command line in the Browser Console to see what profile Firefox is using. Press the Enter key to evaluate the JavaScript code.

Cc["@mozilla.org/file/directory_service;1"].getService(Ci.nsIProperties).get("ProfD", Ci.nsIFile).path;

You need to set devtools.chrome.enabled to true on the about:config page to enable the command line in the Browser Console.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

@jscher2000: I am allowed to specify a .lnk shortcut in the dialog, but it didn't launch. I get a "invalid path" message if I try the command line switch in the dialog itself. But if I try the command line switch in the batch file, that seems to work. Thank you for your help.

@cor-el: I tried your suggestion, but I got "ReferenceError: Cc is not defined".

EDIT: The batch file isn't quite working as much as I thought. The auto launch feature didn't launch it at all. Only when I flipped the auto launch switch on and off did it work. (Each time, the network disconnected and reconnected with the new settings.) I'll hand this one back to Intel.

Geändert am von Toa_Of_Justice

more options
var {classes:Cc,interfaces:Ci,utils:Cu} = Components;
Cc["@mozilla.org/file/directory_service;1"].getService(Ci.nsIProperties).get("ProfD", Ci.nsIFile).path;
more options

cor-el said

var {classes:Cc,interfaces:Ci,utils:Cu} = Components;
Cc["@mozilla.org/file/directory_service;1"].getService(Ci.nsIProperties).get("ProfD", Ci.nsIFile).path;

I got the following messages after running that command: TypeError: Cc is undefined The Components object is deprecated. It will soon be removed.

more options

I'm not seeing this error with any Firefox version including the current Nightly build with the above posted code. I just noticed that the code also works in the Web Console ("3-bar" menu button or Tools > Web Developer). I wasn't aware that code like this could be run in the Web Console ("3-bar" menu button or Tools > Web Developer).

more options

Now I know where my error was: I was trying to use the Web Console this whole time, but since I only had Firefox 45.0.2 at the time I posted this question (when I went to check my version in Help > About Firefox, I was updated to Firefox 46), I didn't have (and still don't have) the ability to run that code in the Web Console. Once I found the Browser Console, I was able to run the original code.

Here is my result from the auto-launched Firefox:


Here is my result from the manually-launched Firefox:

more options

What profile is set in the profiles.ini as Default=1?

That should be the profile that is used when you start with the last used profile. It is usually best to make sure that that profile is selected in profiles.ini and use a specific desktop shortcut to launch Firefox with a specific profile other then the default.

Geändert am von cor-el

more options

z7cko4o8.default is set as Default=1.

more options

The normal location for a profile would be in ""C:\Users\<user>\AppData\Roaming\"

I don't know why there would be a profile in the C:\Windows\System32\ location.

  • "C:\Windows\System32\config\systemprofile\AppData\Roaming\

Did you create that profile yourself in that location? Is it listed in the profiles.ini file?

I wouldn't recommend to create a profile in the "Windows\System32\" location and best would be to remove this profile manually in Windows Explorer (best is not to use the Profile Manager).

more options

I didn't create the profile, nor is it listed in profiles.ini. The Mozilla folder containing the profile has disappeared by itself from the "Windows\System32\" location.

more options

Do you still get that error message?

You can try to search the Windows Registry for that specific path to 2zleri1d.default to see if anything comes up.

more options

I think this is a problem with the Intel software, that it imposes its own root folder in place of the standard one.

Could you update us on the workaround of using auto-launch to call a batch file that has a full Firefox command line include the profile folder? Is that working consistently?

more options

@cor-el: I couldn't find 2zleri1d in the registry. Hoewever, I did find two 2zleri1d.default default folders on my hard drive after auto-launching Firefox without the batch file:

C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\Mozilla\Firefox\Profiles\2zleri1d.default C:\Windows\SysWOW64\config\systemprofile\AppData\Local\Mozilla\Firefox\Profiles\2zleri1d.default

After getting rid of both of these folders, I auto-launched Firefox without the batch file again, and I was greeted with an "Import Settings and Data" wizard. I chose not to import anything, and Firefox started with a fresh profile. The browser console claimed it was in "C:\Windows\System32\config\systemprofile\AppData\Roaming\Mozilla\Firefox\Profiles\k8ybneo3.default", but I only found these folders:

C:\Windows\SysWOW64\config\systemprofile\AppData\Local\Mozilla\Firefox\Profiles\k8ybneo3.default C:\Windows\SysWOW64\config\systemprofile\AppData\Local\Mozilla\Firefox\Profiles\k8ybneo3.default

@jscher2000: I went back to using the batch file, and that launched Firefox with my profile as expected. But when I rebooted, the batch file didn't launch.

more options

Ausgewählte Lösung

more options

cor-el said


I read some of those search results, and they inspired me to create symbolic links in the systemprofile folders to my personal Mozilla folders. Here are the commands I ran to make those links:

mklink /d "C:\Windows\SysWOW64\config\systemprofile\AppData\Local\Mozilla" "C:\Users\Steven\AppData\Local\Mozilla"
mklink /d "C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\Mozilla" "C:\Users\Steven\AppData\Roaming\Mozilla"

Now Firefox auto-launches with my profile.

Thank you, jscher2000 and cor-el, for your help! :)