Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Frequent updates to latest version, non-beta, require enabling all add-ons. Help me keep my Firefox browser!

  • 4 Antworten
  • 1 hat dieses Problem
  • 43 Aufrufe
  • Letzte Antwort von FredMcD

more options

Every day, multiple times a day, every time I open Firefox (latest updated version 45., non-Beta), multiple tabs open for every single one of my add-ons, prompting me to manually update them. For each update, I must go through a two- or three-step process, pushing a button twice if no restart is required, three times if it is. To say the least, this is driving me up the wall. Sadly, I have yet to find a solution on the support forum. I am a long-time Mozilla devotee. I believe in Mozilla and Firefox, and prefer this non-profit, community-driven product to any commercially-driven alternative -- hands-down. But this constant updating of add-ons is making my Firefox browsing life simply untenable. I cannot continue to do this. Can anyone give me guidance on a way out? I would so love to NOT have to switch to a different browser. Many thanks in advance to this amazing global community.

Ausgewählte Lösung

It is possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":


You will have to approve the updating one last time.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (4)

more options

Ausgewählte Lösung

It is possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":


You will have to approve the updating one last time.

more options

You might be able to save some time by not restarting until after completing all the other clicks you have to complete to enable your extensions. If you accidentally close all tabs that mention having to restart, there will be links above the relevant extensions on the Add-ons page, and any one of them will do. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions.


If Fred's suggestion doesn't help, have you noticed any other settings problems? Sometimes after Windows updates, Firefox doesn't get full permissions and all sorts of settings problems can arise. Shutting down and restarting Windows usually cures that if it is the problem.

more options

Thank you to both FredMcD and jscher2000 for the suggestions. It took me a while to implement and test. I can safely say that, since implementing FredMcD's suggestions above for deleting and then updating the corrupted extension files, things have been updating without multiple tabs opening for update confirmation for about two weeks now. jscher2000's suggestions and the keyboard shortcut were very helpful for getting through it all.

Thank you once again to this wonderful community!

Geändert am von tltb

more options

Glad to help. Safe Surfing.