X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Can I get Tbird to save only the most recent draft?

Veröffentlicht

I press Ctrl+S every time I lean back to think. I press it a lot, to keep from losing work.

But every time I do, I have yet another copy of the message in my drafts folder. That isn't necessarily a bad thing, if they get cleaned up when I send the message. But they don't. So:

  1. . Can Tbird be set to automatically delete drafts of sent messages?
  2. . Is there a setting that tells it save only the most recent draft?
  3. . Or maybe a setting that tells it how many drafts to save (say, 3)
I press Ctrl+S every time I lean back to think. I press it a lot, to keep from losing work. But every time I do, I have yet another copy of the message in my drafts folder. That isn't necessarily a bad thing, if they get cleaned up when I send the message. But they don't. So: #. Can Tbird be set to automatically delete drafts of sent messages? #. Is there a setting that tells it save only the most recent draft? #. Or maybe a setting that tells it how many drafts to save (say, 3)

Geändert am von Matt

Ausgewählte Lösung

Are you hosting your own mail server? is it hosted by Google?

But more importantly are you using those drafts on multiple devices or like me just sitting in front to a desktop.

If having the drafts available on say your phone is not important, the same workaround used for gmail will work for you. Change the drafts folder to be local folder in account setting instead of using the IMAP server to store them.

Diese Antwort im Kontext lesen 1

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.109 Safari/537.36

Weitere Informationen

Matt
  • Top 10 Contributor
  • Moderator
3215 Lösungen 22007 Antworten
Veröffentlicht

as just about everyone else has exactly what you seek, only a process of diagnosis is going to work out what is wrong. To diagnose problems with Thunderbird, try the following:

  • Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender.
  • Restart the operating system in safe mode with Networking. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: Windows 8, Windows 7, Windows Vista, Windows XP, OSX
If safe mode for the operating system fixes the issue, there's other software in your computer that's causing problems. Possibilities include but not limited to: AV scanning, virus/malware, background downloads such as program updates.
as just about everyone else has exactly what you seek, only a process of diagnosis is going to work out what is wrong. To diagnose problems with Thunderbird, try the following: *Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender. *Restart the operating system in '''[http://en.wikipedia.org/wiki/Safe_mode safe mode with Networking]'''. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: [http://windows.microsoft.com/en-us/windows-8/windows-startup-settings-safe-mode Windows 8], [http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-7 Windows 7], [http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-vista Windows Vista], [http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx?mfr=true" Windows XP], [http://support.apple.com/kb/ht1564 OSX] ; If safe mode for the operating system fixes the issue, there's other software in your computer that's causing problems. Possibilities include but not limited to: AV scanning, virus/malware, background downloads such as program updates.

Fragesteller

Running Tbird in safe mode did not solve the problem. For what it is worth, if I double click an entry in the drafts folder, and send that, then that entry goes away. (But the other entries remain.)

Will now restart the entire computer in networking-safe mode, to see if that solves the Tbird problem...

Running Tbird in safe mode did not solve the problem. For what it is worth, if I double click an entry in the drafts folder, and send that, then that entry goes away. (But the other entries remain.) Will now restart the entire computer in networking-safe mode, to see if that solves the Tbird problem...

Fragesteller

Restarted the computer in safe mode with networking:

  1. Start Menu > Settings > Update and Security > Recovery
  2. Advanced Startup > [Restart Now]
      ...
 3. Troubleshoot > Advanced Options > Startup Settings > Restart
      ...
 4. Choose option 5 or press F5 to start in safe mode with networking.

The change had no effect. When saving a draft, a second copy is created. After sending, neither is deleted.

Will try reinstalling Tbird next.

Restarted the computer in safe mode with networking: 1. Start Menu > Settings > Update and Security > Recovery 2. Advanced Startup > [Restart Now] ... 3. Troubleshoot > Advanced Options > Startup Settings > Restart ... 4. Choose option 5 or press F5 to start in safe mode with networking. The change had no effect. When saving a draft, a second copy is created. After sending, neither is deleted. Will try reinstalling Tbird next.

Hilfreiche Antwort

Reinstalling 38.6.0 didn't help.

Let me check what is supposed to happen: 1. If I save a draft a second time, it should replace the first, right? 2. If I change the subject or the addressee, is it still the same draft? 3. After sending, the draft message should disappear, right?

Apparently my system is very unique...

Reinstalling 38.6.0 didn't help. Let me check what is supposed to happen: 1. If I save a draft a second time, it should replace the first, right? 2. If I change the subject or the addressee, is it still the same draft? 3. After sending, the draft message should disappear, right? Apparently my system is very unique...
Matt
  • Top 10 Contributor
  • Moderator
3215 Lösungen 22007 Antworten
Veröffentlicht

A reinstall does not change any settings in Thunderbird, nor does it affect any mail data or storeage. All it does is refresh the program files, this can help if they are corrupt. But in this case I doubt it will do anything at all.

What mail provider are you using? Is the account IMAP?

A reinstall does not change any settings in Thunderbird, nor does it affect any mail data or storeage. All it does is refresh the program files, this can help if they are corrupt. But in this case I doubt it will do anything at all. What mail provider are you using? Is the account IMAP?
Matt
  • Top 10 Contributor
  • Moderator
3215 Lösungen 22007 Antworten
Veröffentlicht

EricArmstrong said

Reinstalling 38.6.0 didn't help. Let me check what is supposed to happen: 1. If I save a draft a second time, it should replace the first, right? 2. If I change the subject or the addressee, is it still the same draft? 3. After sending, the draft message should disappear, right? Apparently my system is very unique...

That is exactly how it works for well everyone really. But I have a niggling though about a bug from somewhere.. I will see if I can find anything.

''EricArmstrong [[#answer-845132|said]]'' <blockquote> Reinstalling 38.6.0 didn't help. Let me check what is supposed to happen: 1. If I save a draft a second time, it should replace the first, right? 2. If I change the subject or the addressee, is it still the same draft? 3. After sending, the draft message should disappear, right? Apparently my system is very unique... </blockquote> That is exactly how it works for well everyone really. But I have a niggling though about a bug from somewhere.. I will see if I can find anything.

Fragesteller

I hope that little tickle in your brain leads to some good discovery! As for the server: It's an IMAP account hosted at Earthlink.

I hope that little tickle in your brain leads to some good discovery! As for the server: It's an IMAP account hosted at Earthlink.
Matt
  • Top 10 Contributor
  • Moderator
3215 Lösungen 22007 Antworten
Veröffentlicht

Yep found some things.

Bug 482836 - Multiple (iterations) copies of draft messages are saved in the DRAFTS folder (local Drafts folder, not IMAP). Obsolete drafts should be deleted

This bug apparently occurs if you have an IMAP account and set the deletions to simply mark, instead of move to trash.

Bug 618553 and Bug 402132

Both cover the Gmail case. There pears to be only a workaround for this peculiar Gmail activity. That is change the location of the drafts. Right click the account in the folder pane, select settings. In the copies and folders, change the drafts from Gmail to local folders.

Yep found some things. [https://bugzilla.mozilla.org/show_bug.cgi?id=482836 Bug 482836] - Multiple (iterations) copies of draft messages are saved in the DRAFTS folder (local Drafts folder, not IMAP). Obsolete drafts should be deleted This bug apparently occurs if you have an IMAP account and set the deletions to simply mark, instead of move to trash. [https://bugzilla.mozilla.org/show_bug.cgi?id=618553 Bug 618553] and [https://bugzilla.mozilla.org/show_bug.cgi?id=402132 Bug 402132] Both cover the Gmail case. There pears to be only a workaround for this peculiar Gmail activity. That is change the location of the drafts. Right click the account in the folder pane, select settings. In the copies and folders, change the drafts from Gmail to local folders.

Fragesteller

Interesting bug re: IMAP. Thanks for digging up. (I'm not using Gmail, so that doesn't apply.)

One addition for the IMAP-related bug: I don't mark messages for deletion. I move them to the trash folder. I'll try removing immediately, and see if that helps.

Alas... Made no difference. The problem remains, despite that setting. But no else sees it. Tres weird.

Interesting bug re: IMAP. Thanks for digging up. (I'm not using Gmail, so that doesn't apply.) One addition for the IMAP-related bug: I don't mark messages for deletion. I move them to the trash folder. I'll try removing immediately, and see if that helps. Alas... Made no difference. The problem remains, despite that setting. But no else sees it. Tres weird.
Matt
  • Top 10 Contributor
  • Moderator
3215 Lösungen 22007 Antworten
Veröffentlicht

Ausgewählte Lösung

Are you hosting your own mail server? is it hosted by Google?

But more importantly are you using those drafts on multiple devices or like me just sitting in front to a desktop.

If having the drafts available on say your phone is not important, the same workaround used for gmail will work for you. Change the drafts folder to be local folder in account setting instead of using the IMAP server to store them.

Are you hosting your own mail server? is it hosted by Google? But more importantly are you using those drafts on multiple devices or like me just sitting in front to a desktop. If having the drafts available on say your phone is not important, the same workaround used for gmail will work for you. Change the drafts folder to be local folder in account setting instead of using the IMAP server to store them.

Hilfreiche Antwort

Brilliant! Thanks for hanging in there with me, and pointing out the solution.

All I had to do was 1. Go to Tools > Account Settings > Copies and Folders 2. Under Drafts and Templates change setting from

       "Drafts" folder on: <my email address>
   to 
        "Drafts" folder on: Local Folders

Voila! Problem solved. Only most recent draft is saved, and it is expunged when the message is sent.

Thanks a ton. eric

Brilliant! Thanks for hanging in there with me, and pointing out the solution. All I had to do was 1. Go to Tools > Account Settings > Copies and Folders 2. Under Drafts and Templates change setting from "Drafts" folder on: <my email address> to "Drafts" folder on: Local Folders Voila! Problem solved. Only most recent draft is saved, and it is expunged when the message is sent. Thanks a ton. eric
Matt
  • Top 10 Contributor
  • Moderator
3215 Lösungen 22007 Antworten
Veröffentlicht

It would be nice to know more about that particular server. Such as hosting by google so the email is actually provided by gmaii. Could you give me the server name so I can do some tests to see if I can fit this into one of the know issues?

If I can not I think we should be filling a bg for this as well.

It would be nice to know more about that particular server. Such as hosting by google so the email is actually provided by gmaii. Could you give me the server name so I can do some tests to see if I can fit this into one of the know issues? If I can not I think we should be filling a bg for this as well.

Fragesteller

It's an Earthlink server. But they seem to have problems. McAfee considers my site "unsafe"--apparently a lingering result of some point at which the site was hacked. I have a custom URL to access it, but that is undoubtedly a redirect to some common server. It could be gmail. No telling what they're doing. Probably time to move that site over to BlueHost. They seem like a knowledgeable bunch of folks...)

It's an Earthlink server. But they seem to have problems. McAfee considers my site "unsafe"--apparently a lingering result of some point at which the site was hacked. I have a custom URL to access it, but that is undoubtedly a redirect to some common server. It could be gmail. No telling what they're doing. Probably time to move that site over to BlueHost. They seem like a knowledgeable bunch of folks...)

Fragesteller

Ok. Just spent time with Earthlink support. They tell me they are using Apache server to host the website, and that the email server is a "hybrid" server. But that is all that support knows. Is that enough for you to run with? I can press to get you a contact, if need be...

Ok. Just spent time with Earthlink support. They tell me they are using Apache server to host the website, and that the email server is a "hybrid" server. But that is all that support knows. Is that enough for you to run with? I can press to get you a contact, if need be...

Fragesteller

Matt: As an alternative, perhaps I can pass on your contact info to the folks at Earthlink? The support folks are only allowed to know so much, apparently. If you want, email me; eric [at] treelight [dot] com

Matt: As an alternative, perhaps I can pass on your contact info to the folks at Earthlink? The support folks are only allowed to know so much, apparently. If you want, email me; eric [at] treelight [dot] com
rrayner 0 Lösungen 2 Antworten
Veröffentlicht

Matt said

Yep found some things. Bug 482836 - Multiple (iterations) copies of draft messages are saved in the DRAFTS folder (local Drafts folder, not IMAP). Obsolete drafts should be deleted This bug apparently occurs if you have an IMAP account and set the deletions to simply mark, instead of move to trash. Bug 618553 and Bug 402132 Both cover the Gmail case. There pears to be only a workaround for this peculiar Gmail activity. That is change the location of the drafts. Right click the account in the folder pane, select settings. In the copies and folders, change the drafts from Gmail to local folders.

I have this problem too. I am running TB 45.1.1 on Windows 10. I don't have a record of what level I was on before moving to a Windows 10 PC, but I always try to stay current. This problem was not occurring on my Windows 7 PC, and I had never seen this problem before. I am using the POP server on Comcast, not IMAP. We are not using gmail. My wife is a frequent Ctrl+S user, as she has been burned in the past, so we are accumulating MANY drafts. I've searched through Tools > Options and can find no setting to clear this situation. Any help?

''Matt [[#answer-845141|said]]'' <blockquote> Yep found some things. [https://bugzilla.mozilla.org/show_bug.cgi?id=482836 Bug 482836] - Multiple (iterations) copies of draft messages are saved in the DRAFTS folder (local Drafts folder, not IMAP). Obsolete drafts should be deleted This bug apparently occurs if you have an IMAP account and set the deletions to simply mark, instead of move to trash. [https://bugzilla.mozilla.org/show_bug.cgi?id=618553 Bug 618553] and [https://bugzilla.mozilla.org/show_bug.cgi?id=402132 Bug 402132] Both cover the Gmail case. There pears to be only a workaround for this peculiar Gmail activity. That is change the location of the drafts. Right click the account in the folder pane, select settings. In the copies and folders, change the drafts from Gmail to local folders. </blockquote> I have this problem too. I am running TB 45.1.1 on Windows 10. I don't have a record of what level I was on before moving to a Windows 10 PC, but I always try to stay current. This problem was not occurring on my Windows 7 PC, and I had never seen this problem before. I am using the POP server on Comcast, not IMAP. We are not using gmail. My wife is a frequent Ctrl+S user, as she has been burned in the past, so we are accumulating MANY drafts. I've searched through Tools > Options and can find no setting to clear this situation. Any help?
Matt
  • Top 10 Contributor
  • Moderator
3215 Lösungen 22007 Antworten
Veröffentlicht

I suggest you ask on your own question. IF your using POP mail that these two issues are about as related as a stock car and a F1 car. Both cars, but that is about it.

I suggest you ask on your own question. IF your using POP mail that these two issues are about as related as a stock car and a F1 car. Both cars, but that is about it.
rrayner 0 Lösungen 2 Antworten
Veröffentlicht

Matt said

I suggest you ask on your own question. IF your using POP mail that these two issues are about as related as a stock car and a F1 car. Both cars, but that is about it.

Thanks, Matt. I will do that.

''Matt [[#answer-889629|said]]'' <blockquote> I suggest you ask on your own question. IF your using POP mail that these two issues are about as related as a stock car and a F1 car. Both cars, but that is about it. </blockquote> Thanks, Matt. I will do that.