X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

I get redirected to centurylink page when I put a search word in the url bar

Veröffentlicht

I get redirected to centurylink page instead of google search results when I put a search word in the url bar. I put in the word smiths. Some words will work by having google search for the word and gives me results. The following link is what comes up. I've tried all option on this site with no luck. I have Firefox 43.0.4 windows 10

Also, "disable this service" doesn't work. Nothing in the uninstall program list. I also tried to reinstall firefox.

http://webhelper.centurylink.com/index.php?origURL=http%3A//smiths/&r=&bc=

Also, how to I get rid of "do you mean to go to...,yes take me there no thanks"?

I get redirected to centurylink page instead of google search results when I put a search word in the url bar. I put in the word smiths. Some words will work by having google search for the word and gives me results. The following link is what comes up. I've tried all option on this site with no luck. I have Firefox 43.0.4 windows 10 Also, "disable this service" doesn't work. Nothing in the uninstall program list. I also tried to reinstall firefox. http://webhelper.centurylink.com/index.php?origURL=http%3A//smiths/&r=&bc= Also, how to I get rid of "do you mean to go to...,yes take me there no thanks"?

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 20.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4305 Lösungen 60420 Antworten
Veröffentlicht

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.


Type about:preferences#search<enter> in the address bar. Check the settings.

You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up. ------------ Type '''about:preferences#search'''<enter> in the address bar. Check the settings.
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 Lösungen 40417 Antworten
Veröffentlicht

Century Link DNS "WebHelper" is redirecting your searches.

http://internethelp.centurylink.com/internethelp/centurylink-webhelper-dns-redirect.html

See - How do I turn off (opt out of) the 'CenturyLink WebHelper'?

Load http://webhelper.centurylink.com/ and click on Why am I here? at the top of that page, to the right of center.

Century Link DNS "WebHelper" is redirecting your searches. http://internethelp.centurylink.com/internethelp/centurylink-webhelper-dns-redirect.html See - '''How do I turn off (opt out of) the 'CenturyLink WebHelper'?''' Load '''http://webhelper.centurylink.com/''' and click on '''''Why am I here?''''' at the top of that page, to the right of center.
cor-el
  • Top 10 Contributor
  • Moderator
17671 Lösungen 159854 Antworten
Veröffentlicht

You may have an ISP that automatically redirects you to a search page if a DNS look up fails. This takes the control from Firefox to do a search. You can contact your ISP and ask for a DNS server to opt-out of that feature. You can check if there is a link on the search results page to go to your ISP and opt-out.

You can try alternative DNS servers like Google Public DNS (8.8.8.8 and 8.8.4.4) http://kb.mozillazine.org/Error_loading_websites#DNS https://developers.google.com/speed/public-dns/?csw=1

You may have an ISP that automatically redirects you to a search page if a DNS look up fails. This takes the control from Firefox to do a search. You can contact your ISP and ask for a DNS server to opt-out of that feature. You can check if there is a link on the search results page to go to your ISP and opt-out. You can try alternative DNS servers like Google Public DNS (8.8.8.8 and 8.8.4.4) http://kb.mozillazine.org/Error_loading_websites#DNS https://developers.google.com/speed/public-dns/?csw=1

Fragesteller

First solution: Didn't work I have already tried all options on this link "Troubleshoot Firefox issues caused by malware" Also, I have CCleaner and Norton that doesn't get rid of the malware.

Second solution: didn't work As stated in my original post this doesn't work. "Load http://webhelper.centurylink.com/ and click on Why am I here? at the top of that page, to the right of center." It reverts back to Enable for when I click disable for CenturyLink Web Helper. It appears they give you the option but, some reason it doesn't save even though it says it does.

cor-el... Option Three: confused. I am by no means able to firgure out your option as it is way above my head.

I should mention This has happened for some time, I'm just now getting around to fixing it. I currently have centrylink internet but, it also happened on Comcast/X-finity internet.

First solution: Didn't work I have already tried all options on this link "Troubleshoot Firefox issues caused by malware" Also, I have CCleaner and Norton that doesn't get rid of the malware. Second solution: didn't work As stated in my original post this doesn't work. "Load http://webhelper.centurylink.com/ and click on Why am I here? at the top of that page, to the right of center." It reverts back to Enable for when I click disable for CenturyLink Web Helper. It appears they give you the option but, some reason it doesn't save even though it says it does. cor-el... Option Three: confused. I am by no means able to firgure out your option as it is way above my head. I should mention This has happened for some time, I'm just now getting around to fixing it. I currently have centrylink internet but, it also happened on Comcast/X-finity internet.
FredMcD
  • Top 10 Contributor
4305 Lösungen 60420 Antworten
Veröffentlicht

Did you try all of the scanners?

Did you try all of the scanners?
cor-el
  • Top 10 Contributor
  • Moderator
17671 Lösungen 159854 Antworten
Veröffentlicht

Do you run Firefox in Private Browsing mode?

Does it help to enable third-party cookies (temporarily)?

See also:

Do you run Firefox in Private Browsing mode? Does it help to enable third-party cookies (temporarily)? See also: *http://webhelper.centurylink.com/prefs.php

Geändert am von cor-el

Fragesteller

FredMcd: Yes tried all of them, no luck

Cor-el: Just tried browsing mode, didn't work. I enabled third party cookies but, didn't work either...:(

FredMcd: Yes tried all of them, no luck Cor-el: Just tried browsing mode, didn't work. I enabled third party cookies but, didn't work either...:(
cor-el
  • Top 10 Contributor
  • Moderator
17671 Lösungen 159854 Antworten
Veröffentlicht

Does this search engine show in "Options/Preferences > Search"?

Does anything comes up if you search the about:config page for centurylink ?

Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

You can use this button to go to the current Firefox profile folder:

Firefox will rebuild the search.json file from the default built-in search engines that come with Firefox and the searchplugins folder in the Firefox profile folder.

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Does this search engine show in "Options/Preferences > Search"? Does anything comes up if you search the about:config page for centurylink ? *http://kb.mozillazine.org/about:config Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox will rebuild the search.json file from the default built-in search engines that come with Firefox and the searchplugins folder in the Firefox profile folder. Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Fragesteller

cor-el...

The following didn't work: A. centurylink didn't come up on a search in about:config. B. I deleted search.json, search-metadata.json, and search.sqlit

But, Finally what did work was creating a new profile. YAY. Then, copied all files from my original profile to the new one, one file at a time. Yes time consuming. The two files that where contaminated places.sqlite and prefs.java.

Thanks you so much. I didn't think I would ever be able to solve this problem.

Now, How do I get rid of the "do you mean... " message on top of Firefox when I put in a random word in the URL. ?? Thanks everybody

cor-el... The following didn't work: A. centurylink didn't come up on a search in about:config. B. I deleted search.json, search-metadata.json, and search.sqlit But, Finally what did work was creating a new profile. YAY. Then, copied all files from my original profile to the new one, one file at a time. Yes time consuming. The two files that where contaminated places.sqlite and prefs.java. Thanks you so much. I didn't think I would ever be able to solve this problem. Now, How do I get rid of the "do you mean... " message on top of Firefox when I put in a random word in the URL. ?? Thanks everybody

Fragesteller

I tried the two options on this page:

https://support.mozilla.org/en-US/questions/944544

I tried the two options on this page: https://support.mozilla.org/en-US/questions/944544

Fragesteller

To be clear if I type a random word in like "chains" in the url location bar I get a drop down bar that says "do you mean to go to chains" then it has a choice of "yes take me there" and "no thanks".

I clicked on take me there and it took me to the centurylink web site again. I had to create another new profile to stop the centurylink web site to come up. I'm thinking they are linked in some way. This also on a brand new profile with copying anything over.

To be clear if I type a random word in like "chains" in the url location bar I get a drop down bar that says "do you mean to go to chains" then it has a choice of "yes take me there" and "no thanks". I clicked on take me there and it took me to the centurylink web site again. I had to create another new profile to stop the centurylink web site to come up. I'm thinking they are linked in some way. This also on a brand new profile with copying anything over.
cor-el
  • Top 10 Contributor
  • Moderator
17671 Lösungen 159854 Antworten
Veröffentlicht

You can set browser.urlbar.unifiedcomplete to false to remove the Visit page suggestion from the location bar drop down list.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can set <b>browser.urlbar.unifiedcomplete</b> to false to remove the Visit page suggestion from the location bar drop down list. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Fragesteller

Cor-el...

I tired several things in about:config with no success. I don't remember all of them but this one didn't work for me.

The following didn't work: browser.urlbar.unifiedcomplete to false keyword.enabled preference to toggle it from true to false.

Any other ideas??

Cor-el... I tired several things in about:config with no success. I don't remember all of them but this one didn't work for me. The following didn't work: browser.urlbar.unifiedcomplete to false keyword.enabled preference to toggle it from true to false. Any other ideas??
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 Lösungen 40417 Antworten
Veröffentlicht

https://support.mozilla.org/en-US/questions/944544 is a 3 year old thread; Firefox has changed a bit in that 3 years.

When you "Opt Out" at CenturyLink that setting is probably saved as a cookie in your Firefox installation. Are you clearing cookies when Firefox closes or clearing cookies manually?

That's how Comcast / Xfiniity handled their "Opt Out" from their DNS "helper service" in the past, but they changed how they handled that "feature" a few years ago - I haven't had to deal with it since (like) 2014. iirc, I changed it once by logging into my "master" account with Xfinity and "Opt Out" was automatically set for all my web browsers and all my PC's for my Xfinity internet connection.

https://support.mozilla.org/en-US/questions/944544 is a 3 year old thread; Firefox has changed ''a bit'' in that 3 years. When you "Opt Out" at CenturyLink that setting is probably saved as a cookie in your Firefox installation. Are you clearing cookies when Firefox closes or clearing cookies manually? That's how Comcast / Xfiniity handled their "Opt Out" from their DNS "helper service" in the past, but they changed how they handled that "feature" a few years ago - I haven't had to deal with it since (like) 2014. iirc, I changed it once by logging into my "master" account with Xfinity and "Opt Out" was automatically set for all my web browsers and all my PC's for my Xfinity internet connection.

Geändert am von the-edmeister

Fragesteller

I set firefox to delete all cookie upon exiting. But, was still didn't work. I then sent and email to centrylink but, haven't heard anything yet

I set firefox to delete all cookie upon exiting. But, was still didn't work. I then sent and email to centrylink but, haven't heard anything yet
cor-el
  • Top 10 Contributor
  • Moderator
17671 Lösungen 159854 Antworten
Veröffentlicht

If you use "Clear history when Firefox closes" to clear Cookies then exclude cookies and instead let cookies expire when Firefox is closed to make them session cookies.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Keep until: "I close Firefox"

Create a cookie 'allow' exception for cookies that you want to keep.

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions
If you use "Clear history when Firefox closes" to clear Cookies then exclude cookies and instead let cookies expire when Firefox is closed to make them session cookies. *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Keep until: "I close Firefox" Create a cookie 'allow' exception for cookies that you want to keep. *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions