X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Wont apply signature to forwards or replies?

Veröffentlicht

Hello, I recently installed thunderbird and cannot get my signature to work on forwards or replies. I have both checked off in the setting but still it does not happen. Any ideas? Thanks,

Hello, I recently installed thunderbird and cannot get my signature to work on forwards or replies. I have both checked off in the setting but still it does not happen. Any ideas? Thanks,

Ausgewählte Lösung

I have solved this issue and its on me. The option to have the signature on relies and forwards was set to have the signature under the quoted text. The results were that I could not see the signature without scrolling way down to the end of the emails. I changed the setting to place the signature below my reply and it is working properly. Thanks to all.

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Weitere Informationen

user01229325 2241 Lösungen 10216 Antworten
Veröffentlicht

Hilfreiche Antwort

Probably because you have not set that option.

Right click the account in the Folder Pane Select Settings Composition and Addressing Click the check box.

You have to set this on each account that you have.

Probably because you have not set that option. Right click the account in the Folder Pane Select Settings Composition and Addressing Click the check box. You have to set this on each account that you have.

Hilfreiche Antwort

Thanks but I do have the options checked for my account to have both Forwarding and Replies have the signature.

Thanks but I do have the options checked for my account to have both Forwarding and Replies have the signature.
user01229325 2241 Lösungen 10216 Antworten
Veröffentlicht

Have a look in Config Editor and see if the check boxes worked.

Go to Options-Advanced-General

Promise to be careful

In the search field enter sig_on

See if all these are set to True.

Have a look in Config Editor and see if the check boxes worked. Go to Options-Advanced-General Promise to be careful In the search field enter sig_on See if all these are set to True.

Fragesteller

Thanks again but that did not work either. The first line that had "fwd" in it was marked "false" and I changed it. Then restarted and the outcome is the same. Photo attached.

Thanks again but that did not work either. The first line that had "fwd" in it was marked "false" and I changed it. Then restarted and the outcome is the same. Photo attached.
Zenos 2265 Lösungen 12258 Antworten
Veröffentlicht

You have just one account?

You have just one account?
Matt
  • Top 10 Contributor
  • Moderator
3216 Lösungen 22010 Antworten
Veröffentlicht

To diagnose problems with Thunderbird, try the following. Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender.

To diagnose problems with Thunderbird, try the following. Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender.

Fragesteller

Zenos said

You have just one account?

I have 4 accounts. All have the same settings.

''Zenos [[#answer-824818|said]]'' <blockquote> You have just one account? </blockquote> I have 4 accounts. All have the same settings.

Fragesteller

Matt said

To diagnose problems with Thunderbird, try the following. Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender.

Thanks, I did this and did not get any change in results. I then went to my add on and only have one which is Lightning.

''Matt [[#answer-824834|said]]'' <blockquote> To diagnose problems with Thunderbird, try the following. Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender. </blockquote> Thanks, I did this and did not get any change in results. I then went to my add on and only have one which is Lightning.

Fragesteller

Update: I got to thinking that since I have 4 accounts, but only need a signature on one, that may be causing the issue. SO I created a signature for each account. Still no change. None of my accounts can input the signature on forwards and replies.

Update: I got to thinking that since I have 4 accounts, but only need a signature on one, that may be causing the issue. SO I created a signature for each account. Still no change. None of my accounts can input the signature on forwards and replies.
Matt
  • Top 10 Contributor
  • Moderator
3216 Lösungen 22010 Antworten
Veröffentlicht

Something not normally considered is that Thunderbird only stores non default preferences, so the absence of a preference indicates it is still in a default state.

I have taken the following settings from one of my own accounts. What I notice on yours, I finally tried to read that tny print in the image, is that there are no settings for the account, only the default so you need to add them

mail.identity.id23.suppress_signature_separator;false

This when set to true suppresses the -- that is used to separate the signature from the rest of the mail.

mail.identity.id23.sign_mail;false

Turns on mail signatures for the account when true

mail.identity.id23.sig_on_reply;true

Turns on signatures for replies when set to true

mail.identity.id23.sig_on_fwd;true

Turns on signatures for forwards when set to true

mail.identity.id23.sig_date;0

Modification time of the signature file.

mail.identity.id23.sig_bottom;true

Places the signature at the bottom of the email

mail.identity.id23.htmlSigFormat;false

Tells Thunderbird if the signature in in HTML format

mail.identity.id23.attach_signature;false

Attach signature from a file.

You do not need to add all of those preferences, and you will need to use the correct identity number for your identity in Thunderbird. As there is only an id1 in your preferences, I would assume you should be using id1 instead of id23 as my preferences show. (case is important is is id1 not ID1)

I think you need to add.

mail.identity.id1.sig_on_fwd and set it to true
mail.identity.id1.sig_on_reply and set it to true
Something not normally considered is that Thunderbird only stores non default preferences, so the absence of a preference indicates it is still in a default state. I have taken the following settings from one of my own accounts. What I notice on yours, I finally tried to read that tny print in the image, is that there are no settings for the account, only the default so you need to add them mail.identity.id23.suppress_signature_separator;false This when set to true suppresses the -- that is used to separate the signature from the rest of the mail. mail.identity.id23.sign_mail;false Turns on mail signatures for the account when true mail.identity.id23.sig_on_reply;true Turns on signatures for replies when set to true mail.identity.id23.sig_on_fwd;true Turns on signatures for forwards when set to true mail.identity.id23.sig_date;0 Modification time of the signature file. mail.identity.id23.sig_bottom;true Places the signature at the bottom of the email mail.identity.id23.htmlSigFormat;false Tells Thunderbird if the signature in in HTML format mail.identity.id23.attach_signature;false Attach signature from a file. You do not need to add all of those preferences, and you will need to use the correct identity number for your identity in Thunderbird. As there is only an id1 in your preferences, I would assume you should be using id1 instead of id23 as my preferences show. (case is important is is id1 not ID1) I think you need to add. mail.identity.id1.sig_on_fwd and set it to true mail.identity.id1.sig_on_reply and set it to true

Fragesteller

Matt said

Something not normally considered is that Thunderbird only stores non default preferences, so the absence of a preference indicates it is still in a default state. I have taken the following settings from one of my own accounts. What I notice on yours, I finally tried to read that tny print in the image, is that there are no settings for the account, only the default so you need to add them I think you need to add. mail.identity.id1.sig_on_fwd and set it to true mail.identity.id1.sig_on_reply and set it to true

I have both of those in my config editor and both are set to true.

''Matt [[#answer-826870|said]]'' <blockquote> Something not normally considered is that Thunderbird only stores non default preferences, so the absence of a preference indicates it is still in a default state. I have taken the following settings from one of my own accounts. What I notice on yours, I finally tried to read that tny print in the image, is that there are no settings for the account, only the default so you need to add them I think you need to add. mail.identity.id1.sig_on_fwd and set it to true mail.identity.id1.sig_on_reply and set it to true </blockquote> I have both of those in my config editor and both are set to true.
Matt
  • Top 10 Contributor
  • Moderator
3216 Lösungen 22010 Antworten
Veröffentlicht

Lets have a look at the troubleshooting information on the help menu.

To find the Troubleshooting information:

  • Open Help (or click on three-line-icon and select Help)
  • Choose Troubleshooting Information
  • Use the button Copy to clipboard to select all. Do not check box "Include account names"!
  • Paste this in your post.
Lets have a look at the troubleshooting information on the help menu. To find the Troubleshooting information: * Open Help (or click on three-line-icon and select Help) * Choose Troubleshooting Information * Use the button Copy to clipboard to select all. Do not check box "Include account names"! * Paste this in your post.

Fragesteller

Application Basics

   Name: Thunderbird
   Version: 38.5.0
   User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101 Thunderbird/38.5.0
   Profile Folder: Show Folder
             (Local drive)
   Application Build ID: 20151221142744
   Enabled Plugins: about:plugins
   Build Configuration: about:buildconfig
   Memory Use: about:memory
 Mail and News Accounts
   account1:
     INCOMING: account1, , (pop3) mail.nonameinc.com:110, alwaysSTARTTLS, passwordCleartext
     OUTGOING: mail.nonameinc.com:587, alwaysSTARTTLS, passwordCleartext, true
   account2:
     INCOMING: account2, , (none) Local Folders, plain, passwordCleartext
   account3:
     INCOMING: account3, , (pop3) mail.luxuryrvlots.com:110, alwaysSTARTTLS, passwordCleartext
     OUTGOING: mail.luxuryrvlots.com:587, alwaysSTARTTLS, passwordCleartext, true
   account4:
     INCOMING: account4, , (imap) imap.gmail.com:993, SSL, OAuth2
     OUTGOING: smtp.gmail.com:465, SSL, OAuth2, true
   account5:
     INCOMING: account5, , (pop3) pop.gmail.com:995, SSL, passwordCleartext
     OUTGOING: smtp.gmail.com:465, SSL, OAuth2, true
 Crash Reports
 Extensions
   Lightning, 4.0.4.1, true, {e2fda1a4-762b-4020-b5ad-a41df1933103}
 Important Modified Preferences
   Name: Value
     browser.cache.disk.capacity: 358400
     browser.cache.disk.smart_size_cached_value: 358400
     browser.cache.disk.smart_size.first_run: false
     browser.cache.disk.smart_size.use_old_max: false
     extensions.lastAppVersion: 38.5.0
     font.internaluseonly.changed: false
     font.name.monospace.el: Consolas
     font.name.monospace.x-cyrillic: Consolas
     font.name.monospace.x-unicode: Consolas
     font.name.monospace.x-western: Consolas
     font.name.sans-serif.el: Calibri
     font.name.sans-serif.x-cyrillic: Calibri
     font.name.sans-serif.x-unicode: Calibri
     font.name.sans-serif.x-western: Calibri
     font.name.serif.el: Cambria
     font.name.serif.x-cyrillic: Cambria
     font.name.serif.x-unicode: Cambria
     font.name.serif.x-western: Cambria
     font.size.fixed.el: 14
     font.size.fixed.x-cyrillic: 14
     font.size.fixed.x-unicode: 14
     font.size.fixed.x-western: 14
     font.size.variable.el: 17
     font.size.variable.x-cyrillic: 17
     font.size.variable.x-unicode: 17
     font.size.variable.x-western: 17
     mail.openMessageBehavior.version: 1
     mail.winsearch.firstRunDone: true
     mailnews.database.global.datastore.id: c867da82-832b-472b-99d5-7cc34b75a62
     network.cookie.prefsMigrated: true
     network.predictor.cleaned-up: true
     places.database.lastMaintenance: 1451926658
     places.history.expiration.transient_current_max_pages: 104858
     plugin.importedState: true
 Graphics
     Adapter Description: Intel(R) HD Graphics 4600
     Vendor ID: 0x8086
     Device ID: 0x0416
     Adapter RAM: Unknown
     Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
     Driver Version: 10.18.15.4256
     Driver Date: 7-17-2015
     Direct2D Enabled: false
     DirectWrite Enabled: false (10.0.10586.0)
     ClearType Parameters: ClearType parameters not found
     WebGL Renderer: false
     GPU Accelerated Windows: 0
     AzureCanvasBackend: skia
     AzureSkiaAccelerated: 0
     AzureFallbackCanvasBackend: cairo
     AzureContentBackend: cairo
 JavaScript
 Incremental GC: 1
 Accessibility
   Activated: 1
   Prevent Accessibility: 0
 Library Versions
     Expected minimum version
     Version in use
     NSPR
     4.10.10
     4.10.10
     NSS
     3.19.2.1 Basic ECC
     3.19.2.1 Basic ECC
     NSS Util
     3.19.2.1
     3.19.2.1
     NSS SSL
     3.19.2.1 Basic ECC
     3.19.2.1 Basic ECC
     NSS S/MIME
     3.19.2.1 Basic ECC
     3.19.2.1 Basic ECC
Application Basics Name: Thunderbird Version: 38.5.0 User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101 Thunderbird/38.5.0 Profile Folder: Show Folder (Local drive) Application Build ID: 20151221142744 Enabled Plugins: about:plugins Build Configuration: about:buildconfig Memory Use: about:memory Mail and News Accounts account1: INCOMING: account1, , (pop3) mail.nonameinc.com:110, alwaysSTARTTLS, passwordCleartext OUTGOING: mail.nonameinc.com:587, alwaysSTARTTLS, passwordCleartext, true account2: INCOMING: account2, , (none) Local Folders, plain, passwordCleartext account3: INCOMING: account3, , (pop3) mail.luxuryrvlots.com:110, alwaysSTARTTLS, passwordCleartext OUTGOING: mail.luxuryrvlots.com:587, alwaysSTARTTLS, passwordCleartext, true account4: INCOMING: account4, , (imap) imap.gmail.com:993, SSL, OAuth2 OUTGOING: smtp.gmail.com:465, SSL, OAuth2, true account5: INCOMING: account5, , (pop3) pop.gmail.com:995, SSL, passwordCleartext OUTGOING: smtp.gmail.com:465, SSL, OAuth2, true Crash Reports Extensions Lightning, 4.0.4.1, true, {e2fda1a4-762b-4020-b5ad-a41df1933103} Important Modified Preferences Name: Value browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false extensions.lastAppVersion: 38.5.0 font.internaluseonly.changed: false font.name.monospace.el: Consolas font.name.monospace.x-cyrillic: Consolas font.name.monospace.x-unicode: Consolas font.name.monospace.x-western: Consolas font.name.sans-serif.el: Calibri font.name.sans-serif.x-cyrillic: Calibri font.name.sans-serif.x-unicode: Calibri font.name.sans-serif.x-western: Calibri font.name.serif.el: Cambria font.name.serif.x-cyrillic: Cambria font.name.serif.x-unicode: Cambria font.name.serif.x-western: Cambria font.size.fixed.el: 14 font.size.fixed.x-cyrillic: 14 font.size.fixed.x-unicode: 14 font.size.fixed.x-western: 14 font.size.variable.el: 17 font.size.variable.x-cyrillic: 17 font.size.variable.x-unicode: 17 font.size.variable.x-western: 17 mail.openMessageBehavior.version: 1 mail.winsearch.firstRunDone: true mailnews.database.global.datastore.id: c867da82-832b-472b-99d5-7cc34b75a62 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1451926658 places.history.expiration.transient_current_max_pages: 104858 plugin.importedState: true Graphics Adapter Description: Intel(R) HD Graphics 4600 Vendor ID: 0x8086 Device ID: 0x0416 Adapter RAM: Unknown Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32 Driver Version: 10.18.15.4256 Driver Date: 7-17-2015 Direct2D Enabled: false DirectWrite Enabled: false (10.0.10586.0) ClearType Parameters: ClearType parameters not found WebGL Renderer: false GPU Accelerated Windows: 0 AzureCanvasBackend: skia AzureSkiaAccelerated: 0 AzureFallbackCanvasBackend: cairo AzureContentBackend: cairo JavaScript Incremental GC: 1 Accessibility Activated: 1 Prevent Accessibility: 0 Library Versions Expected minimum version Version in use NSPR 4.10.10 4.10.10 NSS 3.19.2.1 Basic ECC 3.19.2.1 Basic ECC NSS Util 3.19.2.1 3.19.2.1 NSS SSL 3.19.2.1 Basic ECC 3.19.2.1 Basic ECC NSS S/MIME 3.19.2.1 Basic ECC 3.19.2.1 Basic ECC
Matt
  • Top 10 Contributor
  • Moderator
3216 Lösungen 22010 Antworten
Veröffentlicht

So we have 5 accounts, so my assumption about it being id1 may be a long way from correct.

Could you please repeat the screen shot of the config editor as what it shows and what you are telling me you have are different.

So we have 5 accounts, so my assumption about it being id1 may be a long way from correct. Could you please repeat the screen shot of the config editor as what it shows and what you are telling me you have are different.

Fragesteller

I just noticed the 5 accounts as well. But I only setup 4.

I just noticed the 5 accounts as well. But I only setup 4.
Matt
  • Top 10 Contributor
  • Moderator
3216 Lösungen 22010 Antworten
Veröffentlicht

The 5th account is local folders. It is built in and non removable.

lets check some real basics.

Send me an email that has your signature. unicorn dot consulting at gmail dot com.

I will then send you one I would like you to reply.

While you might not be seeing the signature, I would like to see the actual source in both cases. I have no idea what I should be finding, but your preferences look good.

The 5th account is local folders. It is built in and non removable. lets check some real basics. Send me an email that has your signature. unicorn dot consulting at gmail dot com. I will then send you one I would like you to reply. While you might not be seeing the signature, I would like to see the actual source in both cases. I have no idea what I should be finding, but your preferences look good.

Ausgewählte Lösung

I have solved this issue and its on me. The option to have the signature on relies and forwards was set to have the signature under the quoted text. The results were that I could not see the signature without scrolling way down to the end of the emails. I changed the setting to place the signature below my reply and it is working properly. Thanks to all.

I have solved this issue and its on me. The option to have the signature on relies and forwards was set to have the signature under the quoted text. The results were that I could not see the signature without scrolling way down to the end of the emails. I changed the setting to place the signature below my reply and it is working properly. Thanks to all.
Matt
  • Top 10 Contributor
  • Moderator
3216 Lösungen 22010 Antworten
Veröffentlicht

It is the simplest things that usually trip us up. :)

It is the simplest things that usually trip us up. :)

Fragesteller

Matt said

It is the simplest things that usually trip us up. :)

Thanks again for all the help.

''Matt [[#answer-828278|said]]'' <blockquote> It is the simplest things that usually trip us up. :) </blockquote> Thanks again for all the help.