X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox as default browser (regular solution doesn't work)

Veröffentlicht

Hello,

I've tried to make Firefox (version 43.0.1) my default browser on Windows10 (version 1511 Build 150586.36), but the "default apps" page in the control centre doesn't give me any options beside Microsoft Edge and looking for an app in the store. Searching the store does not yield any results for Firefox either.

I have been using Windows 10 for some months now, and always had Firefox as the default; however, since an update about a week ago, the option simply vanished.

FIrefox works fine otherwise, but opening links from mails or documents automatically uses Edge without giving me any other option.

Thanks for any help, and happy holidays.

Hello, I've tried to make Firefox (version 43.0.1) my default browser on Windows10 (version 1511 Build 150586.36), but the "default apps" page in the control centre doesn't give me any options beside Microsoft Edge and looking for an app in the store. Searching the store does not yield any results for Firefox either. I have been using Windows 10 for some months now, and always had Firefox as the default; however, since an update about a week ago, the option simply vanished. FIrefox works fine otherwise, but opening links from mails or documents automatically uses Edge without giving me any other option. Thanks for any help, and happy holidays.

Ausgewählte Lösung

I've managed to find a more roundabout solution.

In System / Default Apps, I have now ignored the "default browser", and instead gone to "set defaults by app". Whereas Firefox still doesn't appear in the former case (and Windows now seems to believe there is no default browser at all), marking Firefox to open all associated file extensions seems to have done the trick in all other ways.

Thanks again for the support, FredMcD. Your time is appreciated.

Diese Antwort im Kontext lesen 1

Mehr Details zum System

Installierte Plugins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.13
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • A component of your photo software powered by RocketLife
  • Shockwave Flash 20.0 r0
  • iTunes Detector Plug-in

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4245 Lösungen 59390 Antworten
Veröffentlicht

Hilfreiche Antwort

https://www.bing.com/search?q=win+10+default+browser+firefox&qs=n&form=QBRE&pq=win+10+default+browser+firefox&sc=0-24&sp=-1&sk=&cvid=CAE9C92E7316498B94979081AC029C7D Bing - win 10 default browser firefox
Veröffentlicht

Hilfreiche Antwort

Thanks for the reply, but I did look for answers on google, with this and similar search terms. It returns the same/similar results as bing.

All I could find were the common solutions which is provided by Mozilla itself: go to the system settings, default apps, and set web browser to Firefox.

I.e. the solution offered here: https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser?redirectlocale=en-US&redirectslug=how-make-web-links-open-firefox-default. Which doesn't work: as said in the OP, Firefox doesn't appear in the menu. Please see the picture I attached.

In other words, the control centre doesn't seem to recognise that Firefox exists, so I can't chose it.

Thanks for the reply, but I did look for answers on google, with this and similar search terms. It returns the same/similar results as bing. All I could find were the common solutions which is provided by Mozilla itself: go to the system settings, default apps, and set web browser to Firefox. I.e. the solution offered here: https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser?redirectlocale=en-US&redirectslug=how-make-web-links-open-firefox-default. Which doesn't work: as said in the OP, Firefox doesn't appear in the menu. Please see the picture I attached. In other words, the control centre doesn't seem to recognise that Firefox exists, so I can't chose it.
FredMcD
  • Top 10 Contributor
4245 Lösungen 59390 Antworten
Veröffentlicht

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.
Veröffentlicht

Fragesteller

Many thanks. I'll await their response.

Many thanks. I'll await their response.
Veröffentlicht

Ausgewählte Lösung

I've managed to find a more roundabout solution.

In System / Default Apps, I have now ignored the "default browser", and instead gone to "set defaults by app". Whereas Firefox still doesn't appear in the former case (and Windows now seems to believe there is no default browser at all), marking Firefox to open all associated file extensions seems to have done the trick in all other ways.

Thanks again for the support, FredMcD. Your time is appreciated.

I've managed to find a more roundabout solution. In System / Default Apps, I have now ignored the "default browser", and instead gone to "set defaults by app". Whereas Firefox still doesn't appear in the former case (and Windows now seems to believe there is no default browser at all), marking Firefox to open all associated file extensions seems to have done the trick in all other ways. Thanks again for the support, FredMcD. Your time is appreciated.
FredMcD
  • Top 10 Contributor
4245 Lösungen 59390 Antworten
Veröffentlicht

That was very good work. Well Done.

That was very good work. Well Done.