Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

I can't open links in google search while using Firefox.

  • 3 Antworten
  • 9 haben dieses Problem
  • 280 Aufrufe
  • Letzte Antwort von shiroikiba

more options

I can open links when I search with Bing or Yahoo, and Google searches work when I'm using IE, so it's only when I'm using Google with Firefox. Also, if I try to open links in a new tab, I get Error 404. For example, if I try to open bbc.co.uk/news from the search page it doesn't do anything, if I try to open it in a new tab I get Error 404 and this string in the address bar: https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0CB4QFjAAahUKEwjEzpKmif3IAhUM9GMKHQZeClQ&url=http%3A%2F%2Fwww.bbc.com%2Fnews&usg=AFQjCNFZIG7IKy3foMCFY0dzRExKv9KjFQ

I've tried refreshing Firefox and disabling add-ons; I'm not sure what else to do.

I have Windows 10, if that has anything to do with the problem.

Ausgewählte Lösung

You can try to delete the extensions.* files (extensions.json and extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json file and the prefs.js file to reset the pref setting from the Kaspersky Protection extension.

You can use this button to go to the current Firefox profile folder:

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (3)

more options

Two other Firefox users with Kaspersky security software have reported this problem with Google's exit tracking script. I'm not sure of the easiest solution at this point, but you can check out the state of discussion in these threads:

  • Google search links on firefox returns 404 error — turning off scanning of encrypted connections in Kaspersky settings works around the issue. This isn't a solution; the solution seems to require some coordination between the main Kaspersky program and the Kaspersky Protection extension.

Of course, another workaround would be to use an add-on that strips the tracking off of Google search results...

more options

Ausgewählte Lösung

You can try to delete the extensions.* files (extensions.json and extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json file and the prefs.js file to reset the pref setting from the Kaspersky Protection extension.

You can use this button to go to the current Firefox profile folder:

more options

Thanks for your help! It started working again after I deleted the addons.json file and the prefs.js file.