Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

I want firefox to automatically install ALL my chosen add-ons after an upgrade - no more asking permission

  • 2 Antworten
  • 3 haben dieses Problem
  • 10 Aufrufe
  • Letzte Antwort von Joela

more options

Firefox regularly installs updates. When this happens I am forced to confirm each add-on. When i chose an add-on i did my due diligence, and I want these add-ons to be installed automatically! This is such a time-waster and irritant that it is close to being a deal-breaker for me! Example attached - times that by 30!

Angefügte Screenshots

Alle Antworten (2)

more options

Do you have to do that with every update (Beta: twice a week)?

Sounds that you have security software that is causing a lot of problems with Firefox.

Do you only have the beta version or also other versions like the current release?

Are you using the same profile folder with different Firefox versions?


It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json file.

You can use this button to go to the current Firefox profile folder:

You can also check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

more options

I have the same issue, and am extremely annoyed. Almost daily updates??? Please!!!