Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How to Install Sync Server 1.5 on Qnap NAS?

  • 5 Antworten
  • 1 hat dieses Problem
  • 1 Aufruf
  • Letzte Antwort von pjgmte

more options

Hi All.

I'm trying to install the firefox sync server on my qnap (x86 processor with a Embedded Linux ... with QTS 4.2 firmware ) server but i'm getting some problems...

After installing Sync Server 1.5 qpkg from http://forum.qnap.com/viewtopic.php?f=320&t=116178

I'm getting this error when I try to reach http://[Public url]:5000/token/1.0/sync/1.5:

{"status": "error", "errors": [{"location": "body", "name": "", "description": "Unauthorized"}]}

Many thanks pjgmte

Hi All. I'm trying to install the firefox sync server on my qnap (x86 processor with a Embedded Linux ... with QTS 4.2 firmware ) server but i'm getting some problems... After installing Sync Server 1.5 qpkg from http://forum.qnap.com/viewtopic.php?f=320&t=116178 I'm getting this error when I try to reach http://[Public url]:5000/token/1.0/sync/1.5: {"status": "error", "errors": [{"location": "body", "name": "", "description": "Unauthorized"}]} Many thanks pjgmte

Geändert am von pjgmte

Ausgewählte Lösung

guigs,

Many Thanks for everything!

Is't working!!!

Problem was in the syncserver.ini file...

I just edit the syncserver.ini file and point the host to the internal ip.

like this...

[server:main] use = egg:gunicorn host = 192.168.1.87 port = 5000 workers = 2 timeout = 30

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (5)

more options

Hey, So I asked the sync guys, and I would recommend asking in the sync list:

However it may be, as informed by nalexander, that your python tool chain is not installing.

more options

Hi guigs

Thanks!

Now it's running with this app: Sync 1.5.qpkg

but I'm getting this logs:

log

more options

In your error logs there is a network issue as well as an issue retrieving a recovery key. Are you using the older version of Sync? Might really want to email the sync list here.

more options

guigs said

In your error logs there is a network issue as well as an issue retrieving a recovery key. Are you using the older version of Sync? Might really want to email the sync list here.

Hi guigs

network it's fine (I Think) as you can see if you went here:

http://[public url]:5000/token/1.0/sync/1.5

here you we can see {"status": "error", "errors": [{"location": "body", "name": "", "description": "Unauthorized"}]}

before I had {"status": "error", "errors": ["The public_url setting doesn't match the application url.\nThis will almost certainly cause authentication failures!\n public_url setting is: http://localhost:5000\n application url is: http://192.168.1.87:5000\nYou can disable this check by setting the force_wsgi_environ\noption in your config file, but do so at your own risk."]}

it's a improvement right? ;)

Strange is that if I went here http://[public url]:5000

it says that "it works"

lool

Should try again later today because I think can be related with syncserver.ini configuration issues...

My syncserver.ini file -> syncserver.ini

Don't you think?

many thanks! pjgm

Geändert am von pjgmte

more options

Ausgewählte Lösung

guigs,

Many Thanks for everything!

Is't working!!!

Problem was in the syncserver.ini file...

I just edit the syncserver.ini file and point the host to the internal ip.

like this...

[server:main] use = egg:gunicorn host = 192.168.1.87 port = 5000 workers = 2 timeout = 30