Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox crashes

  • 9 Antworten
  • 1 hat dieses Problem
  • 1 Aufruf
  • Letzte Antwort von khchivers

more options

My Firefox for Mac browser is continually crashing for the last few weeks mostly when I try to view videos such as on Vimeo.

Alle Antworten (9)

more options

Sorry to hear about the crashes.

Are you getting the Mozilla Crash Reporter dialog, or something from the Mac? If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the last section of the support article "Troubleshoot Firefox crashes (closing or quitting unexpectedly)" for steps to get those crash IDs from the about:crashes page, and then post some of the recent ones here.

Also and/or meanwhile, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the option key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any less crashy?

more options

I have tried viewing these web pages in Safe Mode and it still crashed. I also tried refreshing my browser but it still crashed.

I have gotten the Crash Reporter dialog. I have submitted a report to Mozilla. Should I post some of the data from it in a reply here? If so, which data is needed?

Thanks.

more options

If you type or paste about:crashes in the address bar and press Return/Enter, you should see links to your crash reports. You'll see that the online version links to similar reports by other users, any bugs in the tracking system, etc. So the best thing to provide is the links to those crash reports or, if you have report numbers starting with bp- on the about:crashes page, you can copy/paste several rows of those numbers.

more options

Here are the first four crash reports from my list:

bp-d577c5ba-be9f-41c7-a628-05b532150805 8/5/15 10:28 AM bp-bc4a10f6-c0a3-4f12-9bd3-efb652150805 8/5/15 9:29 AM bp-383ac7de-4899-42ab-b755-b96612150805 8/5/15 9:18 AM bp-2781aa6b-d3da-45b1-bae9-de8962150805 8/5/15 9:05 AM

Let me know what other information you might need.

more options

Thanks for the report. All four crashes are related to decoding video played using the built-in HTML5 video player (instead of Flash), and particularly to VDA, which speeds decoding of media by running it on your Nvidia chip.

CoreMedia => VideoToolbox => VideoDecodeAcceleration => CoreFoundation => etc.

The crash could be caused by Firefox not being fully compatible with your current Nvidia graphics card/chipset driver software. Nvidia has a little Java applet on their site that you can use to check for updates, however, your plugin list doesn't show that you have Java installed, so that might not work. There is a manual search process you could try to see if there is an update:

http://www.nvidia.com/Download/index.aspx

If that doesn't help, you might be able to stop Firefox from submitting MP4 media to the system for decoding. Hopefully Vimeo will then switch over to using Flash, but it's also possible that you just won't be able to view videos at all. I have to note I'm running Windows and can't test this myself, but if you want to try it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.apple.mp4.enabled preference to switch it from true to false

I'm not sure whether that disables it right away or after your next quit/start cycle. I suppose you'll know right away after visiting Vimeo! But please allow 30 seconds after the change so Firefox saves it to your preferences file on disk before crashing.

Any difference?

more options

I looked on the nvidia site to download a new driver but could not complete the download process it since it was not from an approved developer from the App store.

I am not sure what changed in the last month or so that started causing these crashes. I have been using Firefox on my Mac for almost three years.

Is my only other option to not allow MP4 videos?

more options

khchivers said

I looked on the nvidia site to download a new driver but could not complete the download process it since it was not from an approved developer from the App store.

Yet another thing I didn't know about Macs.

Is my only other option to not allow MP4 videos?

I don't know whether that's the only option, but it's the only thing I could come up with. The goal is to force Firefox and the site to use Flash if the built-in player causes crashes. If you test it, let us know your results.

more options

I made the change in my configuration and the videos now play without crashing my browser. But now I am having trouble with the audio in those videos. Would the audio have been affected by this configuration change?

more options

I solved the audio problem. It seemed to be unrelated. Thanks.