Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 18 suddenly now renders webpage improperly in Quirks mode while in other versions of firefox and other browsers webpage loads correctly in standard mode

  • 3 Antworten
  • 1 hat dieses Problem
  • 4 Aufrufe
  • Letzte Antwort von cor-el

more options

On desktop I have version 18 Firefox which I don't want to upgrade because not all add-ons I need are available in higher versions. This Version 18 Firefox *used to load a webpage properly* but I've noticed it no longer does (missing graphics and text) and that it is being rendered in Quirks mode. However, on a laptop running version 32 of Firefox, or using Chrome on the same desktop, the webpage loads properly and is rendered in standard compliance mode. How can I force this version of Firefox 18 to once again render the subject webpage in standard mode so that it displays properly like it used to?? Since it formerly worked, and since the page also renders correctly in other browsers and versions of firefox, it doesn't appear that the subject webpage needs editing, only that something happened in this version of Firefox 18 to make it suddenly render the page incorrectly in quirks mode. Can you help me force Firefox to render the page in standard mode WITHOUT editing the webpage? THANKS FOR YOUR HELP!!!

Alle Antworten (3)

more options

Try to clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit a 'forgotten' website then data from that website will be saved once again.

more options

I removed cookies from the subject site, didn't work. I did the "forget about this site" in the history, didn't work. I did not try clearing the whole cache, want to try and avoid that. Also I don't think it could be a "hardware acceleration" issue since on same computer, the subject page loads properly in chrome, rendered in standard compliance mode. I also haven't added or updated any extensions in recent times which could account for this new problem, so for those reasons, I didn't do safe mode suggestion, although I appreciate all suggestions. Wonder if someone else has encountered this problem and found a solution. Or if there's a way without changing a webpage to force Firefox to render it in standard compliance format? Thanks for any and all help.

more options

Try to use the Profile Manager to create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.