X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Hyperlinks still not opening in default (Chrome) browser (new Win8.1)

Veröffentlicht

I have a new notebook preloaded with Win8.1. Have set Chrome as default browser. Installed Thunderbird and everything seems to work fine until I click on a hyperlink in a message body... nothing happens. This was before any add-ons were added. I have read the help article... default browser setup - already set. ... other items were reviewed and I found no abnormalities in my settings.

This seems quite odd as I have no problems on my desktop. Any further ideas to fix this? It gets a little irritating to have to right-click -"Copy Link Location" and then paste into Chrome's address bar.

I have a new notebook preloaded with Win8.1. Have set Chrome as default browser. Installed Thunderbird and everything seems to work fine until I click on a hyperlink in a message body... nothing happens. This was before any add-ons were added. I have read the help article... default browser setup - already set. ... other items were reviewed and I found no abnormalities in my settings. This seems quite odd as I have no problems on my desktop. Any further ideas to fix this? It gets a little irritating to have to right-click -"Copy Link Location" and then paste into Chrome's address bar.

Ausgewählte Lösung

Toad-Hall: network.protocol-handler.external-default; value = true (no change needed)

I'm not even familiar with how to setup Chrome browser for the "modern" or "Metro" interface... I do know that I allowed a stub to run in the background during the first installation... don't know why. Anyway, I could not uninstall Chrome until I exited this background app through the system tray. Once this was "exited", Windows allowed the uninstall.

Then I downloaded/installed Chrome. There was no option or dialog to "set up google chrome browser to also run from the Start app metro window".

Then I went back over the previous steps in this thread to make sure the settings were all proper. They were all as setup previously checked and confirmed. Then...

I started up Thunderbird, selected a message with a link and clicked on it...

It loaded!!! My first thought is that the background stub may be the source of the problem because it is the only difference from the previous setup. Disabling it could very well be the solution.

What is odd to me is that during installation, Chrome asked if it could run in the background and I said no this time. But I decided to check the system tray and surprise!... there was the Chrome icon so I exited it. THEN I started Chrome for the first time after this fresh install.

Wow! What a relief... I use email a lot and clickable links save a lot of time. I suppose I could do more diagnostics to see if the solution is repeatable... but I'm a little tired and now I need to figure out why my new "Homegroup" network isn't allowing network write access...

THANK YOU Toad-Hall (and Matt)!

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.124 Safari/537.36

Weitere Informationen

Matt
  • Top 10 Contributor
  • Moderator
3277 Lösungen 22612 Antworten
Veröffentlicht

Follow the instruction to set chrome as default. https://support.google.com/chrome/answer/95417?hl=en

Also make sure your able to make such a system change in your account. It might be system security that prevent it sticking.

Then there is this option. http://www.thewindowsclub.com/set-chrome-default-browser-windows-8

Note none of these things involve Thunderbird.

Follow the instruction to set chrome as default. https://support.google.com/chrome/answer/95417?hl=en Also make sure your able to make such a system change in your account. It might be system security that prevent it sticking. Then there is this option. http://www.thewindowsclub.com/set-chrome-default-browser-windows-8 Note none of these things involve Thunderbird.

Fragesteller

I triple checked my "default browser" in all the ways possible, both through Windows and Chrome/Settings/Default browser... all report "The default browser is currently Google Chrome". I have no other problem clicking links elsewhere to open automatically -- in Chrome webpages, in a PDF document viewed in a PDF program (PDF-XChange Editor), ... no problems elsewhere. BTW, neither do the links open with Internet Explorer... they are essentially dead links.

So why only Thunderbird messages?

I triple checked my "default browser" in all the ways possible, both through Windows and Chrome/Settings/Default browser... all report "The default browser is currently Google Chrome". I have no other problem clicking links elsewhere to open automatically -- in Chrome webpages, in a PDF document viewed in a PDF program (PDF-XChange Editor), ... no problems elsewhere. BTW, neither do the links open with Internet Explorer... they are essentially dead links. So why '''only''' Thunderbird messages?

Geändert am von tbird_indiana

Matt
  • Top 10 Contributor
  • Moderator
3277 Lösungen 22612 Antworten
Veröffentlicht

Tools menu > options > attachments > incoming and delete any references to HTTP or HTTPS

Tools menu > options > attachments > incoming and delete any references to HTTP or HTTPS

Fragesteller

Matt: Thx for your efforts to attempt to help me. I had already done all the steps mentioned in the suggested fixits for this problem, including checking: Tools menu > options > attachments > incoming -- the box was empty and so there was no references to HTTP or HTTPS.

Are there no solutions beyond the published initial solutions? If not, I may have to attempt to find another mail handler...

Matt: Thx for your efforts to attempt to help me. I had already done all the steps mentioned in the suggested fixits for this problem, including checking: Tools menu > options > attachments > incoming -- the box was empty and so there was no references to HTTP or HTTPS. Are there no solutions beyond the published initial solutions? If not, I may have to attempt to find another mail handler...
Matt
  • Top 10 Contributor
  • Moderator
3277 Lösungen 22612 Antworten
Veröffentlicht

Go to internet explorer, set it as default. Does everything open in it? Now install Firefox and set it as default. Does it work? Now go back to chrome and set it as default. Does it work?

Windows 8 has 2 default browsers, one for the desktop and one for that modern interface, so I am going through the process of trying to diagnose and perhaps get it to set correctly.

Go to internet explorer, set it as default. Does everything open in it? Now install Firefox and set it as default. Does it work? Now go back to chrome and set it as default. Does it work? Windows 8 has 2 default browsers, one for the desktop and one for that modern interface, so I am going through the process of trying to diagnose and perhaps get it to set correctly.

Fragesteller

Matt: I did the steps you suggested: (1) Set Internet Explorer as default -> Thunderbird message hyperlink worked!

(2) Downloaded and installed Firebird, set as default --> Tbird message hyperlink worked!

(3) Set Google Chrome as default browser --> Tbird links did not work...

I am at least a little encouraged now that I saw 2 browsers work, but why in the world would Tbird balk at Chrome? I again tested links in other apps like Chrome webpages and PDFs with embedded links and they worked well with Chrome. But not Tbird...

What now Matt?

Matt: I did the steps you suggested: (1) Set Internet Explorer as default -> Thunderbird message hyperlink worked! (2) Downloaded and installed Firebird, set as default --> Tbird message hyperlink worked! (3) Set Google Chrome as default browser --> Tbird links did '''not''' work... I am at least a little encouraged now that I saw 2 browsers work, but why in the world would Tbird balk at Chrome? I again tested links in other apps like Chrome webpages and PDFs with embedded links and they worked well with Chrome. But not Tbird... What now Matt?

Fragesteller

Anyone have a clue on this? Is it hopeless now?... just wait for Windows 10 upgrade to remove the Windows 8 "modern interface"?

Someone might say that I should switch away from Chrome browser to Firefox browser, but I have found the integration of the Chrome browser with Google's ecosystem and tools to be too compelling for me to switch back to my old favorite...

If no more help is available, I thank Matt for his attempts to diagnose and solve my continuing problem...

Anyone have a clue on this? Is it hopeless now?... just wait for Windows 10 upgrade to remove the Windows 8 "modern interface"? Someone might say that I should switch away from Chrome browser to Firefox browser, but I have found the integration of the Chrome browser with Google's ecosystem and tools to be too compelling for me to switch back to my old favorite... If no more help is available, I thank Matt for his attempts to diagnose and solve my continuing problem...
Toad-Hall
  • Top 10 Contributor
1797 Lösungen 12101 Antworten
Veröffentlicht

Hilfreiche Antwort

Please confirm you have these settings: Close all browsers.

Control Panel > Default Programs Select: 'Set Program access and computer defaults'

click on the 'Custom' downward pointing arrows under 'choose a default web browser' Select: Google Chrome - Select: 'Enable access to this program' do not select any other browsers. make sure only Google chrome has the 'enable access to this program'. All others should be unchecked. click on OK

Confirm this is set as described.

Please confirm you have these settings: Close all browsers. Control Panel > Default Programs Select: 'Set Program access and computer defaults' click on the 'Custom' downward pointing arrows under 'choose a default web browser' Select: Google Chrome - Select: 'Enable access to this program' do not select any other browsers. make sure only Google chrome has the 'enable access to this program'. All others should be unchecked. click on OK Confirm this is set as described.

Fragesteller

Toad-Hall: See my comments after each of your instructions:

= = = = = = = = =

Please confirm you have these settings: Close all browsers. (done)

Control Panel > Default Programs Select: 'Set Program access and computer defaults'

click on the 'Custom' downward pointing arrows under 'choose a default web browser' Select: Google Chrome - Select: 'Enable access to this program' (When Chrome was selected, it grayed out the "Enable access to this program" as automatically selected) do not select any other browsers. (Internet Explorer and Mozilla Firefox were unselected, BUT attempts to force "Google Chrome" as the selected "current Web browser" did not stick. Even when I did select Google Chrome and pressed OK, a subsequent check showed the selection reverted back to "Use my current Web browser". However only the Google Chrome "Enable access to this program" was checked.)

make sure only Google chrome has the 'enable access to this program'. All others should be unchecked.

    (confirmed)

click on OK

    (OK confirmed)

Confirm this is set as described.

= = = = = = = = = = =

Here is a screenshot ... if it works [Screenshot Screenshot]

I then opened a PDF file in PDF-XChange Editor and clicked on a hyperlink -- it opened up in Google Chrome.

I then opened Thunderbird, went to a message with a hyperlink and clicked on it and it continued to be dead.

Is perhaps the problem that I cannot force Google Chrome to be the only selected web browser, even though it is the only one with "Enable access to this program" checked "Use my current Web browser"?

Toad-Hall: See my comments after each of your instructions: = = = = = = = = = = = Please confirm you have these settings: Close all browsers. (''done'') Control Panel > Default Programs Select: 'Set Program access and computer defaults' click on the 'Custom' downward pointing arrows under 'choose a default web browser' Select: Google Chrome - Select: 'Enable access to this program' (When Chrome was selected, it grayed out the "Enable access to this program" as automatically selected) do not select any other browsers. (Internet Explorer and Mozilla Firefox were unselected, BUT attempts to force "Google Chrome" as the selected "current Web browser" did not stick. Even when I did select Google Chrome and pressed OK, a subsequent check showed the selection reverted back to "Use my current Web browser". However only the Google Chrome "Enable access to this program" was checked.) make sure only Google chrome has the 'enable access to this program'. All others should be unchecked. (confirmed) click on OK (OK confirmed) Confirm this is set as described. = = = = = = = = = = = = = Here is a screenshot ... if it works [[https://goo.gl/photos/SQzxRruKW9Jz7RFJ7 Screenshot] Screenshot] I then opened a PDF file in PDF-XChange Editor and clicked on a hyperlink -- it opened up in Google Chrome. I then opened Thunderbird, went to a message with a hyperlink and clicked on it and it continued to be '''dead'''. Is perhaps the problem that I cannot force Google Chrome to be the '''only''' selected web browser, even though it is the only one with "Enable access to this program" checked "Use my current Web browser"?
Toad-Hall
  • Top 10 Contributor
1797 Lösungen 12101 Antworten
Veröffentlicht

feedback sounds correct.

Check: Control Panel > Default Programs Select: 'Associate a file type or protocol with a program'

In my case I'm using Firefox and I have all the following set to use Firefox, so in your case check to see if all of these are set to use Chrome.

  • .htm
  • .html
  • .shtml
  • .xht
  • .xhtml
  • .xml

scroll down to 'Protocols'

  • FTP
  • HTTP
  • HTTPS

Please confirm what you have here and whether you changed anything and if you made changes, did it have any effect.

feedback sounds correct. Check: Control Panel > Default Programs Select: 'Associate a file type or protocol with a program' In my case I'm using Firefox and I have all the following set to use Firefox, so in your case check to see if all of these are set to use Chrome. * .htm * .html * .shtml * .xht * .xhtml * .xml scroll down to 'Protocols' * FTP * HTTP * HTTPS Please confirm what you have here and whether you changed anything and if you made changes, did it have any effect.

Fragesteller

Toad-Hall: Here is what Win8.1 reports: All the following have "Current Default" set for "Google Chrome": Extensions .htm .html .shtml .webp .xht .xhtml

Protocols: FTP HTTP HTTPS IRC MAIL TO MMS NEWS NNTP SMS SMSTO TEL URN WEBCAL

BTW, Tbird updated to 38.0.1 recently. I can only guess where the problem lies... Win8.1 or Tbird. Who would deny Win8's interface problems, yet why is Tbird the only app where links don't work?

Thx for your work so far. I await any further "under the hood" diagnostics...

Toad-Hall: Here is what Win8.1 reports: All the following have "Current Default" set for "Google Chrome": Extensions .htm .html .shtml .webp .xht .xhtml Protocols: FTP HTTP HTTPS IRC MAIL TO MMS NEWS NNTP SMS SMSTO TEL URN WEBCAL BTW, Tbird updated to 38.0.1 recently. I can only guess where the problem lies... Win8.1 or Tbird. Who would deny Win8's interface problems, yet why is Tbird the only app where links don't work? Thx for your work so far. I await any further "under the hood" diagnostics...
Toad-Hall
  • Top 10 Contributor
1797 Lösungen 12101 Antworten
Veröffentlicht

Hilfreiche Antwort

Can you check some settings in config Editor.

Tools > Options > Advanced > General tab click on 'config Editor' button - it will tell you to be careful :)

In top search type: external look for this line: network.protocol-handler.external-default; value = true

Does the Value = true or false? If 'false': double click on that line to toggle to 'true' close window - top right X click on OK

Q: Have you set up google chrome browser to also run from the Start app metro window?

Q: Have you tried this? Uninstall chrome and then reinstall chrome to only run from the desktop and whilst installing select as default.

Can you check some settings in config Editor. Tools > Options > Advanced > General tab click on 'config Editor' button - it will tell you to be careful :) In top search type: external look for this line: '''network.protocol-handler.external-default'''; value = true Does the Value = true or false? If 'false': double click on that line to toggle to 'true' close window - top right X click on OK '''Q:''' Have you set up google chrome browser to also run from the Start app metro window? '''Q:''' Have you tried this? Uninstall chrome and then reinstall chrome to only run from the desktop and whilst installing select as default.

Ausgewählte Lösung

Toad-Hall: network.protocol-handler.external-default; value = true (no change needed)

I'm not even familiar with how to setup Chrome browser for the "modern" or "Metro" interface... I do know that I allowed a stub to run in the background during the first installation... don't know why. Anyway, I could not uninstall Chrome until I exited this background app through the system tray. Once this was "exited", Windows allowed the uninstall.

Then I downloaded/installed Chrome. There was no option or dialog to "set up google chrome browser to also run from the Start app metro window".

Then I went back over the previous steps in this thread to make sure the settings were all proper. They were all as setup previously checked and confirmed. Then...

I started up Thunderbird, selected a message with a link and clicked on it...

It loaded!!! My first thought is that the background stub may be the source of the problem because it is the only difference from the previous setup. Disabling it could very well be the solution.

What is odd to me is that during installation, Chrome asked if it could run in the background and I said no this time. But I decided to check the system tray and surprise!... there was the Chrome icon so I exited it. THEN I started Chrome for the first time after this fresh install.

Wow! What a relief... I use email a lot and clickable links save a lot of time. I suppose I could do more diagnostics to see if the solution is repeatable... but I'm a little tired and now I need to figure out why my new "Homegroup" network isn't allowing network write access...

THANK YOU Toad-Hall (and Matt)!

Toad-Hall: network.protocol-handler.external-default; value = true (''no change needed'') I'm not even familiar with how to setup Chrome browser for the "modern" or "Metro" interface... I do know that I allowed a stub to run in the background during the first installation... don't know why. Anyway, I could not uninstall Chrome until I exited this background app through the system tray. Once this was "exited", Windows allowed the uninstall. Then I downloaded/installed Chrome. There was no option or dialog to "set up google chrome browser to also run from the Start app metro window". Then I went back over the previous steps in this thread to make sure the settings were all proper. They were all as setup previously checked and confirmed. Then... I started up Thunderbird, selected a message with a link and clicked on it... It loaded!!! My first thought is that the background stub may be the source of the problem because it is the only difference from the previous setup. Disabling it could very well be the solution. What is odd to me is that during installation, Chrome asked if it could run in the background and I said no this time. But I decided to check the system tray and surprise!... there was the Chrome icon so I exited it. THEN I started Chrome for the first time after this fresh install. Wow! What a relief... I use email a lot and clickable links save a lot of time. I suppose I could do more diagnostics to see if the solution is repeatable... but I'm a little tired and now I need to figure out why my new "Homegroup" network isn't allowing network write access... THANK YOU Toad-Hall (and Matt)!