Hilfe durchsuchen

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Why when reading Yahoo emails, one of my email addresses requires me to use slider to read horizontally for 30% of my messages?

  • 10 Antworten
  • 2 haben dieses Problem
  • 43 Aufrufe
  • Letzte Antwort von JJM123

more options

I use Firefox Profiles to access 2 email accounts w/o need to sign out & sign in each time I want to read from the other. One of my Yahoo email accounts requires me to use the slider to read entire lines on 30% of my messages. I would use the Hide Ads arrow to widen the message but I do not have the Hide Ads arrow and thankfully, no ads appear in the blank right side. AT&T response is to use Outlook. How can I utilize the wasted space on the right side of my screen OR resize the email pane to avoid the slider necessity? My other email account started this weekend displaying emails with blank space at the bottom and some of the controls at the top of the page hidden. I now have to use the Hide Ads arrow to get rid of the blank bottom and to show the HOME and TOOLS icons. How can I get my display back to normal? AT&T had me Clear History - thought that worked until I signed in again. And how can I get the Ads not to appear as with my address above? Tried to Add ScreenPrint Images but that option seems not to work for BMP or JPG.

Alle Antworten (10)

more options

Check your zoom controls.

<Control> + (plus) enlarge <Control> - (minus) reduce <Control> 0 (zero) restore


Check with the site support if there is still a problem.

more options

If the problem messages have the characteristic fixed width "Courier"-style font, then here is my suspicion:

Firefox recently changed how it handles blocks of "preformatted" text. Previously, they were always wrapped to fit the window, but now, if the site does not set them to wrap, then you get a horizontal scroll bar. I can illustrate with a long line like the following:

This sentence is preformatted text which, on this forum, will not be wrapped but instead will have a horizontal scroll bar. 
(Which is no fun!)

If you right-click the problem text and choose Inspect Element (Q), Firefox will open the Inspector in the lower part of the tab and you may be able to see that the problem area is all within a <pre> tag.

Can you check and confirm that, or is something else going on?

As a quick check, you could try this:

If the Inspector is still open, click Console along its top edge. If it's not still open, press Ctrl+Shift+k to open the Web Console in the lower part of the tab. In the blank at the bottom next to >> type or paste the following long line of script and press Enter to run it (it injects a new style rule into the page to wrap preformatted elements):

var r="pre{white-space:pre-wrap !important}"; var s=document.createElement("style"); s.type="text/css"; s.appendChild(document.createTextNode(r)); document.body.appendChild(s);

Does the too-wide area now wrap?

There likely is a convenient way to inject that into Yahoo! Mail if it works, but I'll need to experiment a bit before making recommendations. Let me know how it goes.

more options

By the way, some of your other symptoms sound as though they might be related to content-filtering add-ons. Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options
Inspector does not show any
 other than Presentation.
Text in console does not help.
more options

Inspector does not show any Pre other than Presentation. Text in console does not help.

more options

Zoom Control - does the trick. Was wondering where that option might be.

more options

Safe Mode did not help. It's as if all panes except Ads have been resized - Image now included.

more options

Hmm, was the screen shot from after you reset the zoom level or before?

The center column seems a bit oversized compared with the others, but I don't have a good guess as to why.

more options

I don't know with that type of ad;

Adblock Plus {web link} Blocks annoying video ads on YouTube, Facebook ads, banners and much more. Adblock Plus blocks all annoying ads, and supports websites by not blocking unobtrusive ads by default (configurable).

Adblock Plus Pop-up Addon {web link} Adblock Plus Pop-up Addon extends the blocking functionality of Adblock Plus to those annoying pop-up windows that open on mouse clicks and other user actions.

Forum; Adblock Plus Homepage {web link}

more options

jscher2000 - The image was with no zooming. Zooming down will get rid of the blank space and show the Mail Search and Tools Gear, but only for that email. Zoom down 2ce will get the bar with Mail, News, Sports, etc. Soon as I go to another message the Mail Search and Tools Gear are again hidden.