X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Low framerate when watching Youtube videos on HTML5 in fullscreen

Veröffentlicht

Ever since Firefox made Youtube videos only play in HTML5, no matter what quality setting I have on the video I'm watching, when I view the video on fullscreen it has low framerate. This problem does not happen with other video sites that uses Flash, like Twitch, Blip, or Dailymotion.

Is it software related to the browser or hardware related with it being HTML5?

Ever since Firefox made Youtube videos only play in HTML5, no matter what quality setting I have on the video I'm watching, when I view the video on fullscreen it has low framerate. This problem does not happen with other video sites that uses Flash, like Twitch, Blip, or Dailymotion. Is it software related to the browser or hardware related with it being HTML5?

Ausgewählte Lösung

Check for updates for your graphics using the above.

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Installierte Plugins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 17.0 r0

Anwendung

  • Firefox 37.0.2
  • User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
  • Hilfe-URL: https://support.mozilla.org/1/firefox/37.0.2/WINNT/sv-SE/

Erweiterungen

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • BetterTTV 6.8.3 (firefox@betterttv.net)
  • Download Statusbar Fixed 1.2.00 ({4204c864-50bf-467a-95b3-0912b7f15869})
  • FrankerFaceZ 1.55 (jid1-snHdAu6px3p0jA@jetpack)
  • InstantFox 3.0.0 (searchy@searchy)

JavaScript

  • incrementalGCEnabled: True

Grafiken

  • adapterDescription: NVIDIA GeForce GTX 560 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x1200
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.17415
  • driverDate: 4-8-2015
  • driverDate2:
  • driverVersion: 9.18.13.5012
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Veränderte Einstellungen

Verschiedenes

  • User JS: Nein
  • Barrierefreiheit: Nein
FredMcD
  • Top 10 Contributor
4314 Lösungen 60576 Antworten
Veröffentlicht

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Fragesteller

As stated, I am currently not experiencing problems with Flash players. Just the HTML5 one that Youtube is using.

As stated, I am currently not experiencing problems with Flash players. Just the HTML5 one that Youtube is using.
FredMcD
  • Top 10 Contributor
4314 Lösungen 60576 Antworten
Veröffentlicht

Ausgewählte Lösung

Check for updates for your graphics using the above.

Check for updates for your graphics using the above.

Hilfreiche Antwort

My graphic drivers currently has the latest updates installed to them. I'm using Geforce Experience to look for and install the latest drivers for my graphics card.

Disabling protected mode didn't solve it, since it's not Flash that I'm having problems with.

I can't choose to disable hardware acceleration, since those instructions are for Flash, and there is no such option for HTML5 as far as I know.

My graphic drivers currently has the latest updates installed to them. I'm using Geforce Experience to look for and install the latest drivers for my graphics card. Disabling protected mode didn't solve it, since it's not Flash that I'm having problems with. I can't choose to disable hardware acceleration, since those instructions are for Flash, and there is no such option for HTML5 as far as I know.
cor-el
  • Top 10 Contributor
  • Moderator
17694 Lösungen 160089 Antworten
Veröffentlicht

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Fragesteller

I have it already disabled, to solve a previous issue I had. https://support.mozilla.org/en-US/questions/1059207

I have it already disabled, to solve a previous issue I had. https://support.mozilla.org/en-US/questions/1059207

Fragesteller

I found what the problem was. On the quality settings for each Youtube video, whenever I have "Auto" on, and try watching it fullscreen, then it has low framerate.

But when I manually select the quality, and fullscreen it, then it's just as good as not having it fullscreen.

I found what the problem was. On the quality settings for each Youtube video, whenever I have "Auto" on, and try watching it fullscreen, then it has low framerate. But when I manually select the quality, and fullscreen it, then it's just as good as not having it fullscreen.

Fragesteller

Okay, it's only with bad framerate when the quality is anything but 1080p. But when it's 1080p, there is no problem with it.

Okay, it's only with bad framerate when the quality is anything but 1080p. But when it's 1080p, there is no problem with it.

Hilfreiche Antwort

I'm still having the same problems, not only with Youtube, but also with Twitch switching over from Flash to HTML5. Except on Twitch, the framerate is consistently low, and sometimes stutters.

I'm still having the same problems, not only with Youtube, but also with Twitch switching over from Flash to HTML5. Except on Twitch, the framerate is consistently low, and sometimes stutters.
cepir 0 Lösungen 3 Antworten
Veröffentlicht

Hey, i' ve had the same problem when youtube changed to HTML5. I've found this solution working: go to about:config, then find the option media.webm.intel_decoder.enabled and set it to true. I have no clue what is that option and why is it disabled by default, but it worked.

Hey, i' ve had the same problem when youtube changed to HTML5. I've found this solution working: go to about:config, then find the option '''media.webm.intel_decoder.enabled''' and set it to '''true'''. I have no clue what is that option and why is it disabled by default, but it worked.
s9209122222 0 Lösungen 1 Antworten
Veröffentlicht

cepir said

Hey, i' ve had the same problem when youtube changed to HTML5. I've found this solution working: go to about:config, then find the option media.webm.intel_decoder.enabled and set it to true. I have no clue what is that option and why is it disabled by default, but it worked.

I don't have this option.

''cepir [[#answer-769375|said]]'' <blockquote> Hey, i' ve had the same problem when youtube changed to HTML5. I've found this solution working: go to about:config, then find the option '''media.webm.intel_decoder.enabled''' and set it to '''true'''. I have no clue what is that option and why is it disabled by default, but it worked. </blockquote> I don't have this option.