Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why doesn't Firefox Sync work in my home network, but at work?

  • 7 Antworten
  • 4 haben dieses Problem
  • 378 Aufrufe
  • Letzte Antwort von brancalessio

more options

Firefox Sync on my laptop does not work when my laptop is connected to my home network, but e.g. if I'm at my office.

The internet connection at my home is fine, I can surf the web with that very Firefox on both IPv4 and IPv6, DNS etc. is also working. Logging in to accounts.firefox.com also works, as does connecting Firefox to the Sync account. Only the process of syncing itself fails. On my desktop computer at home, I have exactly the same problems. When I open https://sync-209-us-west-2.sync.services.mozilla.com/ in a browser tab, I see a confirmation message that sync runs on that server, so apparently the network path between my computer and that server is free.

Upon investigation with Wireshark, I see the successful TLS handshake, then some packets from the client that are not answered and after some time the server closes the connection (Encrypted Alert). Apparently, no content is transferred between client and server. I attach a screenshot of how Wireshark sees the conversation between server and client (The image upload here didn't work so I put it on the web: http://ibin.co/1zXABHKdj5mA).

To exclude a possible misconfiguration or bad add-on, I created a clean new Firefox profile and connected it to my Firefox account, but this shows exactly the same problems.

Fun fact: Firefox on my Android phone does sync in my home network.


Below, I will link two log files, one successful sync (office network) and one failed sync (home network): Sync @ office: http://pastebin.com/rZmfrbdL Sync @ home: http://pastebin.com/a3KUCevJ

Ausgewählte Lösung

The problem appears to be with your ISP - you can refer them to https://bugzilla.mozilla.org/show_bug.cgi?id=1118958 and they may be able to find a work-around by changing your plan or helping you configure a different MTU for the network.

I hope this helps,

Mark

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (7)

more options

Any chance you are on a DS-Lite network at home? If so, what's your ISP? The home network symptoms look a little like https://bugzil.la/1118958

more options

Yes, my internet uplink uses DS-lite. My ISP is Unitymedia, the same one as mentioned in the bug you linked.

more options

Thanks for the update! We'd love to try and diagnose this but that wireshark capture doesn't give us enough to work with. If you use IRC, it would be great if you could join our network (see https://wiki.mozilla.org/IRC), join the #sync channel and ping either "markh" or "bobm" while on your network and we may be able to track this down further.

more options

Hi everyone!

I have the same problem and the same ISP (Unitymedia).

Firefox Sync does not work under Linux Mint 17.2 Rafaela 64 bit, when I use my home network (ethernet or wifi). On the contrary, it works regularly with the office network and with another home network (with a different ISP, actually in a different country).

I point out that it does not work either with the Firefox provided by the packages of my Linux distribution or with the Firefox build by Mozilla.

Funny enough, everything works in Windows 8.1.

I do not understand what should I do. Do I have to contact my ISP?

Is this a bug of Firefox, Linux Mint, or my ISP?

I also started a discussion on Linux Mint forums: here. There is some of my error logs, but nothing new from what already posted.

Thanks for your answers!

more options

Ausgewählte Lösung

The problem appears to be with your ISP - you can refer them to https://bugzilla.mozilla.org/show_bug.cgi?id=1118958 and they may be able to find a work-around by changing your plan or helping you configure a different MTU for the network.

I hope this helps,

Mark

more options

Sorry Mark, I forgot to keep you updated on this issue.

I used the same workaround as in the mentioned bugreport, i.e. set

net.ipv4.tcp_mtu_probing = 1

in /etc/sysctl.conf, which fixes the Firefox Sync issue as well as connectivity problems to several websites.

I'll nevertheless talk to my ISP and see what they have to say.

Thanks!

more options

Hi everyone and thanks for your answers! I need to read and understand them. I'm not so strong in networking. After that I plan to write an email to my ISP.

I manually modified the MTU to 1250 (the default value is 1500) with

sudo ifconfig eth0 mtu 1250 sudo ifconfig wlan0 mtu 1250

This seems to be a workaround, but I have another question.

As I told, I'm using Linux Mint 17.2 Rafaela 64 bit. Before replacing my harddrive, I was using Ubuntu 12.04 LTS (32 bit, I think). Firefox Sync was actually working. Can you explain why?

Thanks again for your answers!

Geändert am von brancalessio