Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is displaying my homepage as a news feed

  • 1 Antwort
  • 1 hat dieses Problem
  • 303 Aufrufe
  • Letzte Antwort von jscher2000

more options

Firefox has started to display my homepage (www.msn.com) as a newsfeed rather than the full content. I tried clearing my cache and it worked once, but has gone back to displaying as a feed. If I use another browser, such as internet explorer, the page displays correctly.

The feed display is unacceptable. I don't want to use another browser, but will be forced to do so if this problem can't be corrected.

Ausgewählte Lösung

Does it seem more like:

  • Firefox is displaying the same content, but failing to style it properly, or
  • Firefox is displaying a different page, such as a mobile version

Have you noticed any issues with site certificates, such as Firefox complaining that sites' certificates are untrusted?


You mentioned clearing the cache was helpful once. When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (1)

more options

Ausgewählte Lösung

Does it seem more like:

  • Firefox is displaying the same content, but failing to style it properly, or
  • Firefox is displaying a different page, such as a mobile version

Have you noticed any issues with site certificates, such as Firefox complaining that sites' certificates are untrusted?


You mentioned clearing the cache was helpful once. When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or globe icon in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?