Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

After upgrade to FF36.0.4 I can't view pages that require Flash Player.

  • 14 Antworten
  • 2 haben dieses Problem
  • 18 Aufrufe
  • Letzte Antwort von central_texan

more options

I upgraded to FF 36.0.4 and was unable to access pages I had before. I installed Flash 17.0.0.134, Quicktime 7.7.6, and latest Shockwave and still unable to view National Weather Service animated radar images. FF says I need plug in but not which one. Flash home page gives same msg where it should tell you which version you have.

Ausgewählte Lösung

You have:

C:\Windows\System32\Macromed\Flash\NPSWF32_17_0_0_134.dll

One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there?

If Firefox is set to scan but still does not find Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is "Shockwave Flash" finally there?

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (14)

more options

hello, flash doesn't appear to be in your list of plugins. can you go to the firefox menu ≡ > addons > plugins & see if shockwave flash is listed there and set to always activate? in case it isn't present in your list of plugins, then try re-installing it through the offline installer available at https://www.adobe.com/products/flashplayer/distribution3.html (use the windows .exe installer for plugin based browsers)

more options

That is true, it's not showing in the list of plug-ins. I have downloaded and installed it several times and it still does not show up in FF. When I check the Flash icon in the control panel is shows the following versions installed: Active X ver: 16.0.0.305, NPAPI Plug-in ver: 17.0.0.134, PPAPI plug-in ver: not installed. The Adobe Shockwave Player has been installed also but does not show up in FF. It is version 12.1. Any help is appreciated.

more options

in this case you could try the following and reset the file that holds the plugin information in firefox: go to the firefox menu ≡ > help ? > troubleshooting information, click on profile folder/show folder and close all firefox windows afterwards. a windows explorer window should open up - in there delete the file named pluginreg.dat - it will be regenerated again the next time you launch the browser....

more options

Okay, I did that but nothing changed in my plug-in list. Should I re-install Flash and Shockwave now?

more options

yes, try to remove it first as described in adobe's support knowledge-base: https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

more options

Okay. I removed it and it appears that the removal was successful. Flash does not appear on the list of installed programs nor in the control panel. Should I attempt re-installation through Firefox or just run the install .exe for Flash 17? I actually downloaded the offline installer AND the stub for Flash 17. Is one preferable to the other?

more options

if you have a choice then use the offline installer...

more options

If Firefox doesn't find the Flash plugin then it is possible that the registry keys that Firefox scan to find plugins didn't get created.

Uninstalling and reinstalling Flash could possibly fix this. You may have to run the Flash installer as Administrator.

Best is to use the full installer that you can find on this page like posted above.

more options

Okay. Re-installed Flash and it now shows up in the Add/Remove programs list AND in the Control Panel but NOT in FF. Your link to how plug-ins are searched for and found is a bit over my head. I have been working all day on an administrator's account and there is not an "Administrator" user on the machine. I've actually used two versions of FF and have experienced the same issues with both versions. Should I maybe uninstall FF and then delete the folders in Program Files so any remnants might be deleted also? I'm kind of running out of options. BTW, Thanks for your help.

more options

I am relatively capable of editing the registry so if there is a way to set a value there, I might be able to do that. Also, the link shown for the download of the file I am using to install looks like the page I downloaded the file from initially.

more options

when you manually navigate to C:\Windows\SysWOW64\Macromed\Flash, do you have some files referencing flash 17 in that folder (in particular NPSWF32_17_0_0_134.dll)?

more options

I don't have a SYSWOW64 folder (I'm using XP SP3) but that file is in c:\windows\system32\Macromed/Flash.

more options

Ausgewählte Lösung

You have:

C:\Windows\System32\Macromed\Flash\NPSWF32_17_0_0_134.dll

One possible reason for an installed plugin not to appear on the Add-ons page is if Firefox has been set NOT to scan the registry for plugins. Another is that Firefox's settings file storing plugin data has become corrupted. Here are the steps to check those possibilities:

Confirm that Firefox is scanning the registry for plugins

Firefox finds the Flash plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page, Plugins section again, can you find "Shockwave Flash" there?

If Firefox is set to scan but still does not find Flash and list it on the Add-ons page...

Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins.

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button to launch a new Windows Explorer window showing your settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Start Firefox back up again. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is "Shockwave Flash" finally there?

more options

jscher2000! ! ! You're the MAN! The setting was set to 'User'. All is well! I don't see an option to set this issue to "SOLVED", but it is.

Thanks a million!

And thanks to all who weighed in on this issue. I learned a lot!