Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

I had to reinstall Firefox, and now I have no search engine. There are none listed in Options:Search, and I cannot even do a search from the location bar.

  • 5 Antworten
  • 1 hat dieses Problem
  • 4 Aufrufe
  • Letzte Antwort von cor-el

more options

When I tried to launch Firefox this evening, I got an error message saying "Could not find Mozilla runtime" (even though it worked fine this morning). Following a suggestion on the help forum, I uninstalled and reinstalled Firefox. That solved the problem, but now I have no search engine; clicking the spyglass icon gives me nothing, and if I type a search term into the search bar and click the arrow (or hit Enter), nothing happens. When I open the menu and go to Options:Search, there are no search engines listed -- not even a default! When I try to add one, nothing happens. Also, I am unable to do a search from the address bar; when I type or paste a phrase or URL into the address bar and try to search, nothing happens. I am reduced to going to the Google home page and typing in a search term or a URL in order to do any web browsing. Help!

P.S. I am a senior citizen and admittedly ignorant as to anything but basic computer terminology and operation, so please (if possible) keep it simple! :-)

Ausgewählte Lösung

You're welcome

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (5)

more options

In the search tab within Firefox options you should see a button labelled "Restore Default Search Engines". Does selecting this do anything?

more options

No, I tried that; nothing happens.

more options

There are other things that need your attention.

Check that you do not run Firefox in compatibility mode or with a reduced screen resolution.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.


You can check if you have the XML files of the default search engines including Google in the browser\searchplugins folder in the Firefox program folder.

If not then you need to reinstall Firefox.


Try to delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Firefox will rebuild the search.json file from the default search engines in the "browser\searchplugins" folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

more options

OK, I unchecked everything in the compatibility tab. I found eight search engine XML files in the browser\searchplugins folder (once I finally located it), and I deleted the search.json file and search-metadata.json file (again, after I finally located them). I could not find a search.sqlite file. Now what do I do?

Oh, OK, I just closed Firefox and restarted Windows, and it seems to have done the trick. Thanks very much!

Geändert am von guycolbyiv

more options

Ausgewählte Lösung

You're welcome