Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

flash slows FF with hangs and 'not responding' messages.

  • 15 Antworten
  • 11 haben dieses Problem
  • 12377 Aufrufe
  • Letzte Antwort von dukster

more options

Shockwave flash is causing hangs giving 'firefox is not responding' message and slows my internet experience. I know its the flash add-on because when i disable it, firefox performs much better. I've tried all the suggestions concerning flash problems on this site and nothing has worked. I am running win 7 64 bit (home premium). plus Firefox 36.0.1. All drivers appear to be up to date but i will double check.

my question is.... is there a way to easily disable/enable flash w/o going into the add-ons manager? Depending on what i'm doing, i'm in add-ons manager to either enable it when i need it or to disable it when firefox is slow and hangs.

I've gotten to the point where i just open add-ons manager in a tab and leave it open because i know i'll probably be in there turning flash on or off depending on how its effecting my machine.

Also, i tried running flash in 'ask to activate' mode, but you have to reload the page so it can find the add-on.

This problem has been ongoing for a couple of months now; Firefox performance used to be so much better but this problem doesn't seem to be getting resolved. I like firefox, I really don't want to go to another browser.

Thanks, Duke

Ausgewählte Lösung

Please ignore the above reply!

One reason for frequent slow script errors is the protected mode feature of the Flash player plugin. The Protected Mode feature has security benefits, but seems to have compatibility issues on some systems. You can disable it by creating or editing a settings file. The following pages/posts provide different approaches for that:

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

Any improvement?

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (15)

more options

Uninstall firefox. then try to install Firefox 4

more options

Ausgewählte Lösung

Please ignore the above reply!

One reason for frequent slow script errors is the protected mode feature of the Flash player plugin. The Protected Mode feature has security benefits, but seems to have compatibility issues on some systems. You can disable it by creating or editing a settings file. The following pages/posts provide different approaches for that:

Flash needs to completely unload from memory (exiting and starting Firefox up again might help) before this takes effect.

Any improvement?

more options

well, looks like that did it. i used the manual steps method and it seems to be working quite well now.

thank-you very much jscher2000.

P.S. this removes protected mode in firefox. i went to the security @ adobe page and read the explanation (of protection mode in firefox), however, it was technically over my head. If you don't mind, would you explain in layman terms what i am giving up in terms of protection?

Geändert am von dukster

more options

I'm not sure I understand this feature well myself, but the general idea is to reduce the potential for Flash media to inject malware into your system by pulling it out of Firefox and running it in a different process that has reduced privileges on the system. If it only it worked for everyone!

more options

thanks jscher2000, ff still running smooth.

appreciate your help,

Duke

more options

Well, you'll never guess whats happening again. FF was running find and now back to hangs and not responding messages.

I ran scans on Norton, Malwarebytes, Adwcleaner.... laptop is clean. I don't see why it would be OK after the fix and 8 days later muck up again.

The mms.cfg file is still in there dated 3/16/15, the day it was installed. any ideas?

duke

more options

Just to confirm, since you have 64-bit Windows, you edited the mms.cfg file here:

C:\Windows\SysWOW64\Macromed\Flash

You could open it to double-check that ProtectedMode=0 is still in there.

more options

Yes, that location and 'ProtectedMode=0' is still in there.

I un-installed ff last night only to find a copy of it still running in memory this AM. Weird.

I ended up deleting the whole ff folder out of the 'Programs' folder so i think its totally gone including preferences and bookmarks(?) which is fine.

So, its going to be a fresh install next. Any suggestions will be greatly appreciated.

Duke

more options

Hi Duke, your bookmarks and other Firefox data actually are in the C:\Users folder so it's safe to delete the folder under C:\Program Files (or C:\Program Files (x86) on 64-bit systems).

When you run the installer again, it should detect and use your previous settings folder. To get a clean start on that as well, you can:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should come with completely fresh settings databases and a fresh cache folder.

This does not replace your existing setup; the new folder exists in parallel with your current settings.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Don't delete anything here.

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like March29, and ignore the option to change the folder location. Then start Firefox in the new profile you created.

Does that work any better?

Note: When returning to the Profile Manager to switch back to your normal profile, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

more options

Ok, downloaded ff Setup Stub 36.0.4 from Mozilla website. Created new profile and have ff open using new profile.

I have also Opera open and doing some quick comparisons. They seem to be running about the same, I need to set-up ff with the usual adblocker and other extensions so i can get it configured properly.

Thank-you for your help, let me run it for a few days and get back to you with an up-date.

Thanks, duke
more options

I forgot to mention how to get your bookmarks into the new profile.

You can use the Library dialog (Ctrl+Shift+b or "Show All Bookmarks") to access the Restore feature. The trick is knowing where to find your bookmark backups in your regular profile. After clicking Choose File... you can paste this into the file name space and press Enter to drill down to your profile folders:

%APPDATA%\Mozilla\Firefox\Profiles

The semi-randomly-named folder that has your last backup is usually the one ending with "default". Click into that one, then into the bookmarkbackups folder. Here you can pick the most recently updated file to restore.

Important: a Restore wipes any bookmarks currently in your active Firefox profile and replaces it with the contents of the restored backup.

more options

Thank-you for that.

FF is just weird. I went into Options and when it opened there was no info in the 'general' tab window.... completely blank. changed a few options in the other catogories and closed the window. went back in, home page options and all the normal things were in back the 'general' window, clicked on the 'advanced' tab and nothing is in that window.

Do you think I have a Windows 7 problem?

more options

I don't know what would cause one tab of the Options dialog to blank out. Firefox may have been trying to gather some information from the system and it was taking much longer than expected. But that's just a guess and I don't have a solution for that.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

more options

I wanted to give an update if anyone was following this thread looking for answers. I finally did a System File Check on my OS; problems were found and corrected. This seems to have fixed most if not all my issues i was having w/ FF.

Even if your scans show your computer is clean, it doesn't mean you do not have corrupted files. Important lesson for me anyway.

FF is running like it used to. Thank-you jscher2000 and cor-el for your help.

Duke