Hilfe durchsuchen

YouTube looks weird and won't play videos

  • 7 Antworten
  • 7 haben dieses Problem
  • 11053 Aufrufe
  • Letzte Antwort von daykopajj

more options

YouTube website looks completely different and won't play any videos. Asks me for an application to play videos which it shouldn't do.

I took a screenshot but your image upload feature is not working. Little wheel spun around endlessly and never uploaded). So I will have to describe it.

YouTube looks like a cheap website with little thumbnails of the videos in a column along the left side of the screen with horizontal lines separating them. If you try to play a video you get a little box that says "This link needs to be opened with an application". Adobe Media Player launches but will not play anything. QuickTime won't launch at all, says file not compatible. But this is irrelevant, it should not require another application to play YouTube videos.

iMac OS 10.9.5 Firefox 36.0.1

Ausgewählte Lösung

Have you noticed anything else strange about Youtube or other sites? For example, has Firefox indicated that any sites have bad security certificates?

General advice:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache. Either:

  • "3-bar" menu button > Preferences > Advanced
  • (menu bar) Firefox > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


In case one of your extensions is involved, could you test the site in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

Diese Antwort im Kontext lesen 👍 4

Alle Antworten (7)

more options

Hello,

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

more options

Ausgewählte Lösung

Have you noticed anything else strange about Youtube or other sites? For example, has Firefox indicated that any sites have bad security certificates?

General advice:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache. Either:

  • "3-bar" menu button > Preferences > Advanced
  • (menu bar) Firefox > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock in the address bar > More Information > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


In case one of your extensions is involved, could you test the site in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

more options

I cannot right-click anything. I have an iMac

Looks like the image upload function is working now so attached is what YouTube looks like on my computer

more options

Fortunately, I listed two alternatives that members of the one-button crowd can use to access the Page Info dialog and remove their youtube.com cookies.

That sure looks like a mobile interface. If clearing the Youtube cookies doesn't resolve the issue, I wonder whether there is any reason for Youtube to mistake your Firefox for a mobile browser? None of your extensions look like they would do that, although you might review your Greasemonkey userscripts if any are activated on Youtube.

more options

No address bar and no padlock. Do I delete all these files?

more options

Yes, since I don't know which Youtube cookies contain what data, please remove each of them.

As for not having an address bar, that's puzzling. There should always be a bar showing the address of the current page and for secure pages, the globe that normally appears to the left of the address should change to a padlock.

An exception would be Firefox's full screen mode...

more options

It worked. Thanks!