Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

firefox theme problem

  • 1 Antwort
  • 1 hat dieses Problem
  • 7 Aufrufe
  • Letzte Antwort von the-edmeister

more options

after months i created a theme which i love with old theme restorer and stylish but one problem still remain!!!!!!!!!!!!!! if i maximize windows half left (or right )and then maximize window to take all screen (not full screen) the ui is not properly restored extra pixel about 4 are subtracked see pic my stylish is

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
@-moz-document url(chrome://browser/content/browser.xul) {
#TabsToolbar {
	min-height: 22px!important
}
.tab-background-start[selected=true]::after,
.tab-background-start[selected=true]::before,
.tab-background-start,
.tab-background-end,
.tab-background-end[selected=true]::after,
.tab-background-end[selected=true]::before,
.tabbrowser-tabs{
	min-height: 22px!important
}

#nav-bar .toolbarbutton-1:not([type=menu-button]),
#nav-bar .toolbarbutton-1 > .toolbarbutton-menubutton-button,
#nav-bar .toolbarbutton-1 > .toolbarbutton-menubutton-dropmarker {
	padding-top: 1px!important;
	padding-bottom: 1px!important
}
    
#main-window:not([inFullscreen]) #TabsToolbar:-moz-window-inactive {
    margin-bottom: 1px !important;
}

#main-window:-moz-window-inactive #TabsToolbar {
    margin-bottom: 0 !important;
}
	
#main-window[sizemode="maximized"]{ margin-top: -27px; } 
#main-window[sizemode="normal"]{ margin-top: -24px; }

	

#nav-bar {

background:none !important;
}
/* normal */

#main-window:not([inFullscreen]):not([privatebrowsingmode]) #TabsToolbar {
    margin-bottom: 1px;
    margin-top: -7px;
    border: 0.1px solid !important;
}

#main-window:not([inFullscreen]):not([privatebrowsingmode]) .tabbrowser-tabs {
    margin-bottom: -2px !important;
    
    
}
.tab-throbber { display: none !important }

/* private */

#main-window[privatebrowsingmode] #TabsToolbar {
    margin-bottom: -1px !important;
    margin-top: -4px !important;
}

#main-window[privatebrowsingmode] #TabsToolbar:-moz-window-inactive {
    margin-bottom: -1px !important;
    border: 0.1px solid !important;
}


.tabbrowser-tab[pinned=true] {

    width: 0.4in;

}
tabs {
    margin-left: -16px !important;

}

tabs > * > *  {
    
    max-height: 27px;
}

#nav-bar {
    
    height: 33.5px !important;

    border: 0.1px solid !important;
}

/* Lower the tab bar */
tab {height: 26px !important;
     max-height: 26px !important;
     -moz-appearance: none !important;
}
/*Style Small Buttons*/
#navigator-toolbox:not([iconsize="large"]) #nav-bar toolbarbutton:not([class="box-inherit toolbarbutton-menubutton-button"]):not([id="back-button"]):not([id="forward-button"]):not([id="zoom-out-button"]):not([id="zoom-in-button"]):not([id="urlbar-reload-button"]):not([id="urlbar-stop-button"]):not([id="urlbar-go-button"]),
#navigator-toolbox:not([iconsize="large"]) toolbar #back-button,
#navigator-toolbox:not([iconsize="large"]) toolbar #forward-button,
#navigator-toolbox:not([iconsize="large"]) toolbar #zoom-out-button,
#navigator-toolbox:not([iconsize="large"]) toolbar #zoom-in-button {
border-radius: 1px !important;
min-height: 28px !important;
max-height: 28px !important;}
     



		toolbarbutton:hover > .toolbarbutton-icon,

		statusbarpanel:hover > .statusbarpanel-icon,
		
		statusbarpanel:hover > image,
		
		/*statusbarpanel:hover > label,/*uncomment if needed*/
		
		.urlbar-icon:hover,
		
		#urlbar > dropmarker:hover,

		#page-proxy-favicon:hover {

			/*opacity: 1.00 !important;/*uncomment if needed*/

			margin-top: -1px !important;

			-moz-transform: scale(1.25) !important;

			image-rendering: auto !important;

		}
	.tabbrowser-tab[selected="true"],
.tabbrowser-tab:not([selected="true"]):hover {
	background-image: url(file:///Users/Al3/Library/Application%20Support/firefox/imagemia.png) !important;

}

    .tabbrowser-tab[selected="true"] {
   border-top: 1px solid #FF0000   !important;
  }

/* Change text color of loading/reloading tab - Magenta */
.tabbrowser-tab[busy]{
   border-top: 3px solid #00ddff   !important;
    }

   
}

the main problem is related to

#main-window[sizemode="maximized"]{ margin-top: -27px; } 
#main-window[sizemode="normal"]{ margin-top: -24px; }

when RE-maximizing windows margin top is messed!!!!!!!!!!! please halp me i love firefox but i m very feed up!!!!!!!!!!!

since i cannot even upload creen shot here a public link for it shame!!!!!!! https://copy.com/DxqBIu0TC2ooLe7n

Angefügte Screenshots

Geändert am von cor-el

Alle Antworten (1)

more options

Both those screenshots are too small to actually see the problem that you mention - except maybe on a Retina screen. And considering you are running the Nightly 38.0a1 version, which isn't always stable ....

Try posting at MozillaZine in the Builds forum. http://forums.mozillazine.org/viewforum.php?f=23 Or the Theme Development forum. http://forums.mozillazine.org/viewforum.php?f=18