Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox not detecting/using system proxy settings

  • 2 Antworten
  • 3 haben dieses Problem
  • 34 Aufrufe
  • Letzte Antwort von kmantel

more options

I use a command line script to change among various proxies (and none). Firefox does not recognize when a proxy is turned on or fails to connect to it (no error messages), while other browsers and applications do just fine. I have tried selecting "Use system proxy settings" and "Auto-detect proxy settings for this network."

My script contains these lines to activate a proxy

reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections" /v DefaultConnectionSettings /t REG_BINARY /d 46000000b10000000200000014000000736f636b733d3132372e302e302e313a313131311c0000002a2e6c6f63616c3b3139322e3136382e31312e2a3b3c6c6f63616c3e000000000000000000000000000000000000000000000000000000000000000000000000 /f

reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v ProxyEnable /t REG_DWORD /d 1 /f

reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v MigrateProxy /t REG_DWORD /d 1 /f


The first line enables the proxy to take effect without entering inetcpl.cpl. Again, this works for any application other than Firefox. The proxies are all through ssh with port forwarding.

I do not want to manually configure a proxy in Firefox, because I do not want to change this every time I need to change proxies or turn them off. This is not an acceptable solution.

I am on Windows 8.1 64bit, with Firefox version 35.0

Any idea what might be going on here?

I use a command line script to change among various proxies (and none). Firefox does not recognize when a proxy is turned on or fails to connect to it (no error messages), while other browsers and applications do just fine. I have tried selecting "Use system proxy settings" and "Auto-detect proxy settings for this network." My script contains these lines to activate a proxy reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections" /v DefaultConnectionSettings /t REG_BINARY /d 46000000b10000000200000014000000736f636b733d3132372e302e302e313a313131311c0000002a2e6c6f63616c3b3139322e3136382e31312e2a3b3c6c6f63616c3e000000000000000000000000000000000000000000000000000000000000000000000000 /f reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v ProxyEnable /t REG_DWORD /d 1 /f reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v MigrateProxy /t REG_DWORD /d 1 /f The first line enables the proxy to take effect without entering inetcpl.cpl. Again, this works for any application other than Firefox. The proxies are all through ssh with port forwarding. I do not want to manually configure a proxy in Firefox, because I do not want to change this every time I need to change proxies or turn them off. This is not an acceptable solution. I am on Windows 8.1 64bit, with Firefox version 35.0 Any idea what might be going on here?

Geändert am von kmantel

Alle Antworten (2)

more options
more options

Thank you for the response, but as above, the "Auto-detect proxy settings for this network." setting does not work.

Geändert am von kmantel