Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How do I stop firefox downloading files as a blank webpage?

  • 8 Antworten
  • 1 hat dieses Problem
  • 1017 Aufrufe
  • Letzte Antwort von bgreen7

more options

By mistake I recently changed a Firefox download setting that now makes all files I try to download as blank web pages. When the window comes up and asks me for what I want Firefox to do with the file it says Firefox (default) and when I open the file it opens a blank webpage. So far I've tried numerous things including resetting to the factory state and completely uninstalling and reinstalling the browser. Some help with this would be much appreciated.

Ausgewählte Lösung

Its been a while since I posted last it looks like I resolved my issue. It turns out the files weren't opening properly because they were being saved as 7z files. I installed a 7z extractor so I can open the files no problem now.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (8)

more options

If you choose the Save option instead of the Open option, does that work around the issue temporarily?

Are there particular types of files affected? Normally Firefox would not be the default application to handle downloads.

more options

I have tried both the save and open options and get the same results. So far every file I've tried to download is like this. I'm certain its a setting I changed but don't know where I can change it back. Thanks for your response.

more options

You mentioned resetting to the factory state. If you used Firefox's Reset feature (this creates an Old Firefox Data folder on your desktop), then you probably have addressed most of the settings that could be causing this.

In case one of your extensions is involved, could you test downloading in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

more options

I just tried to restart in safe mode but I'm getting the same result.

more options

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

Thanks for the suggestion but deleting the mimeTypes.rdf folder didn't change anything.

more options

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

Note that you should be cautious with opening files in Firefox via the open with dialog because Firefox shouldn't ask if it could handle this file internally.

With file (content) type does in mention in the dialog?

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Please update the Flash plugin. The currently installed version (Shockwave Flash 10.3 r181) is outdated and has known security vulnerabilities.

You can find the latest Flash player versions for Firefox on this page:

more options

Ausgewählte Lösung

Its been a while since I posted last it looks like I resolved my issue. It turns out the files weren't opening properly because they were being saved as 7z files. I installed a 7z extractor so I can open the files no problem now.