Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Disable animation of "bookmark this page" prompt?

  • 5 Antworten
  • 3 haben dieses Problem
  • 30 Aufrufe
  • Letzte Antwort von frred

more options

How can I turn off or disable the newly added animation of the "bookmark this page" prompt?

It was previously possible to press Ctrl+D to set a bookmark and immediately follow this up by pressing Enter. This no longer is possible, because the small prompt window takes so long to animate up.

Generally speaking, I dislike all kinds of animations. So I have gone through great lengths to turn of favicon animation, zoom up animations, have replaced the new download window by an addon, turned gifs to animate only once, use an ad-blocker and turned off the tabs-animation by editing the respective file.

Now, there is a new animation that takes away from my time and distracts me from whats important. How can I turn it off, please?

Ausgewählte Lösung

Option #1 Install the Kill Panel Animations add-on.

Option #2 If you have the Stylish add-on installed, install the following user style.

Option #3 If you don't want to install any add-ons, put the code of the above user style in the userChrome.css file and restart Firefox. Make sure the @namespace line appears only once at the top of the file.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (5)

more options

Ausgewählte Lösung

Option #1 Install the Kill Panel Animations add-on.

Option #2 If you have the Stylish add-on installed, install the following user style.

Option #3 If you don't want to install any add-ons, put the code of the above user style in the userChrome.css file and restart Firefox. Make sure the @namespace line appears only once at the top of the file.

more options

The Classic Theme Restorer extension uses this code to hide this animation.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* disable  star bookmark animation */
#bookmarked-notification {visibility:collapse!important}
#bookmarks-menu-button *, #bookmarked-notification, #bookmarked-notification-dropmarker-icon {animation:none!important}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userChrome.css file in the editor window
  • Make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file

Geändert am von cor-el

more options

Thank you for the excellent and fast answers cor-el and Gingerbread Man.

Editing the userChrome.css in FF 36 had no effect.

The Addon "kill-panel-animations" is a solution.

The animations are specified in CSS3 in the sources here: chrome://browser/skin/browser.css

I dont know enough yet (anchors, notifications, the popup xml) to try to fix the problem via the userChrome.css.

more options

The code still works for me in Firefox 36 and only highlights the star blue.

See:

  • chrome://browser/skin/browser.css

If you use a custom theme then you may need different CSS rules.

more options

cor-el said

The code still works for me in Firefox 36 and only highlights the star blue.

Thank you for the heads-up on the userChrome.css changes.

While the plugin works and appears to rebind the handling, using the direct approach by changing userChrome.css has no effect on my computer. Something seems to be missing or taking precedence. I tried disabling all addons and also substituted https for http in the namespace url. The default theme is active and there are no further changes to userChrome. Nonetheless, I need to wait 800ms (feels longer cause I need to wait on visual feedback) after pressing Ctrl-D before pressing enter to add a new bookmark.

I also tried the suggestion made in a bug-report (possibly unrelated bug report), but it had no effect: #PanelUI-popup[type="arrow"] { transition-property: none; }