X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Thunderbird takes 30 seconds to startup with Unresponsive Script citing mailWindow.js. 6-8 IMAP accounts, mainly gmail. SOLVED by updating to 38.1.0

Veröffentlicht

I have Thunderbird 31.1.2, on my Windows 8.1. I have about 6-8 IMAP accounts, mainly from gmail.

Thunderbird has always opened within a second or 2 when I click on it. Then all of a sudden it started taking 30 seconds to open. The main toolbar at the top will appear, with the folders on the left. The main viewing window stays blank and Thunderbird remain unresponsive for 30 seconds. Then everything loads fine.

I couldn't bother to figure out the problem so I lived with it for a few months. Now the same thing has happened with my Thunderbird on my Windows 7 installation, opening the same IMAP accounts. Just that the Windows 7 installation gives this error after the 30 seconds:

"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://messenger/content/mailWindow.js:174"

So now that I have 2 Thunderbirds taking so long to open, I have to find a solution. Can anyone assist? Thanks

I have Thunderbird 31.1.2, on my Windows 8.1. I have about 6-8 IMAP accounts, mainly from gmail. Thunderbird has always opened within a second or 2 when I click on it. Then all of a sudden it started taking 30 seconds to open. The main toolbar at the top will appear, with the folders on the left. The main viewing window stays blank and Thunderbird remain unresponsive for 30 seconds. Then everything loads fine. I couldn't bother to figure out the problem so I lived with it for a few months. Now the same thing has happened with my Thunderbird on my Windows 7 installation, opening the same IMAP accounts. Just that the Windows 7 installation gives this error after the 30 seconds: "A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. Script: chrome://messenger/content/mailWindow.js:174" So now that I have 2 Thunderbirds taking so long to open, I have to find a solution. Can anyone assist? Thanks

Geändert am von Wayne Mery

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

Weitere Informationen

Petille 1 Lösungen 8 Antworten
Veröffentlicht

For several months I've had a problem with it lagging or becoming unresponsive for a minute or so if i had the bad idea to erase messages quickly with the delete button or if i was trying to do anything in TB while a notification was displaying.

I had assumed it was lightning but I loved the agenda so much that I decided to live with this. I shortened the notification display and made sure to either select several messages with shift or to pause a sec between each delete with the keyboard.

However, since 31.1.2. I have the exact problem as OP. I'm also on 8.1. For two days now, the agenda does not synch with Google agenda and does not keep anything I enter in it directly either. So I decided the trouble was not worth it anymore and desinstalled ALL the plugins. Only to realize that the problem was not the plugin but TB itself.

This is miserable. I get Script : chrome://messenger/content/mailWindow.js:174 thunderbird Too.

What to do?

For several months I've had a problem with it lagging or becoming unresponsive for a minute or so if i had the bad idea to erase messages quickly with the delete button or if i was trying to do anything in TB while a notification was displaying. I had assumed it was lightning but I loved the agenda so much that I decided to live with this. I shortened the notification display and made sure to either select several messages with shift or to pause a sec between each delete with the keyboard. However, since 31.1.2. I have the exact problem as OP. I'm also on 8.1. For two days now, the agenda does not synch with Google agenda and does not keep anything I enter in it directly either. So I decided the trouble was not worth it anymore and desinstalled ALL the plugins. Only to realize that the problem was not the plugin but TB itself. This is miserable. I get Script : chrome://messenger/content/mailWindow.js:174 thunderbird Too. What to do?
christ1
  • Top 25 Contributor
2200 Lösungen 16086 Antworten
Veröffentlicht

What is your anti-virus software?

What is your anti-virus software?
Petille 1 Lösungen 8 Antworten
Veröffentlicht

I use Eset.

I use Eset.
christ1
  • Top 25 Contributor
2200 Lösungen 16086 Antworten
Veröffentlicht

Petille,

I think it would be better if you raise a new thread for your problem.

Petille, I think it would be better if you raise a new thread for your problem.

Fragesteller

christ1, I don't use one. Only security program i have is Comodo Firewall (just the firewall).

christ1, I don't use one. Only security program i have is Comodo Firewall (just the firewall).
christ1
  • Top 25 Contributor
2200 Lösungen 16086 Antworten
Veröffentlicht
Try to start *Windows* in safe mode with networking enabled. - Win8 http://windows.microsoft.com/en-US/windows-8/windows-startup-settings-including-safe-mode - Win7 http://windows.microsoft.com/en-US/windows7/Start-your-computer-in-safe-mode - XP http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx Still in Windows safe mode, start Thunderbird in safe mode. - https://support.mozilla.org/en-US/kb/safe-mode Does the problem go away?
Petille 1 Lösungen 8 Antworten
Veröffentlicht

OK tried the safe mode and that does not change anything. It still takes 30 seconds to have TB responsive

Yesterday, I disabled Eset anti spam anti phishing and protocol filtering for 10 min.

Immediately, the message Script : chrome://messenger/content/mailWindow.js:174 thunderbird stopped showing up and deleting quickly with keyboard has not been causing any freeze since then, even if Eset is back to normal. And messages have not reappeared after being deleted.

Also, since Windows auto update, Lightning is working again, sync properly with gmail so I've decided to be happy that Agenda and my fav email client work and be patient when it opens

With 32 g RAM I am not used to wait for apps...

OK tried the safe mode and that does not change anything. It still takes 30 seconds to have TB responsive Yesterday, I disabled Eset anti spam anti phishing and protocol filtering for 10 min. Immediately, the message'' Script : chrome://messenger/content/mailWindow.js:174 thunderbird'' stopped showing up and deleting quickly with keyboard has not been causing any freeze since then, even if Eset is back to normal. And messages have not reappeared after being deleted. Also, since Windows auto update, Lightning is working again, sync properly with gmail so I've decided to be happy that Agenda and my fav email client work and be patient when it opens With 32 g RAM I am not used to wait for apps...

Geändert am von Petille

Fragesteller

Hey christ1, the same problem occurs in safe mode for windows 8.1 and windows 7 and safe mode in thunderbird.

Hey christ1, the same problem occurs in safe mode for windows 8.1 and windows 7 and safe mode in thunderbird.
christ1
  • Top 25 Contributor
2200 Lösungen 16086 Antworten
Veröffentlicht

What is the size of your mail files? Are you compacting folders on a regular basis?

What is the size of your mail files? Are you compacting folders on a regular basis?

Fragesteller

@christ1 they are mainly IMAP email accounts (Gmail). I have 5 IMAP accounts and 1 POP.

The 2 main email accounts have 2300~ emails each at the moment with size on disk being 611MB and 576MB for them. The other IMAP accounts have less than 1000 emails.

My POP account has 40 emails, with size on disk being less than 1 MB.

I understand compacting doesn't do much for IMAP accounts, but more for POP so I haven't been doing any compacting. But I compacted them anyway after your post and no change in startup.

I also repaired the folder on each of the accounts, but no difference in startup.

Some of the larger attachments on some of the emails stand at 21mb and less. My sync settings are set to only sync the past week emails and past 30 days of emails for my large accounts. "Keep messages for this account on my computer" option is turned off for ALL accounts.

I hope this info helps?

@christ1 they are mainly IMAP email accounts (Gmail). I have 5 IMAP accounts and 1 POP. The 2 main email accounts have 2300~ emails each at the moment with size on disk being 611MB and 576MB for them. The other IMAP accounts have less than 1000 emails. My POP account has 40 emails, with size on disk being less than 1 MB. I understand compacting doesn't do much for IMAP accounts, but more for POP so I haven't been doing any compacting. But I compacted them anyway after your post and no change in startup. I also repaired the folder on each of the accounts, but no difference in startup. Some of the larger attachments on some of the emails stand at 21mb and less. My sync settings are set to only sync the past week emails and past 30 days of emails for my large accounts. "Keep messages for this account on my computer" option is turned off for ALL accounts. I hope this info helps?

Geändert am von docarchy

christ1
  • Top 25 Contributor
2200 Lösungen 16086 Antworten
Veröffentlicht

Hilfreiche Antwort

I wouldn't expect the size of the mail files to be a problem in the first place. However, are you accumulating messages in Inbox? If so, move them to a different folder.

I wouldn't expect the size of the mail files to be a problem in the first place. However, are you accumulating messages in Inbox? If so, move them to a different folder.

Fragesteller

@christ1, since I moved to a gmail address many many years ago, I have not been deleting email msgs which would be to keep my inbox relatively small. That was in the days of POP. So I don't delete emails.

Are you thinking the number of emails in my inbox might be a contributing factor?

So create a new folder and move older emails from my inbox to that folder? Want me to try this on my larger accounts that have over 2000 emails in the inbox? Or all my accounts?

@christ1, since I moved to a gmail address many many years ago, I have not been deleting email msgs which would be to keep my inbox relatively small. That was in the days of POP. So I don't delete emails. Are you thinking the number of emails in my inbox might be a contributing factor? So create a new folder and move older emails from my inbox to that folder? Want me to try this on my larger accounts that have over 2000 emails in the inbox? Or all my accounts?

Geändert am von docarchy

christ1
  • Top 25 Contributor
2200 Lösungen 16086 Antworten
Veröffentlicht

It's not about deleting messages, but moving messages out of Inbox. It's best practice to keep your Inbox as clean as possible. Inbox is most susceptible for corruption, and it's read first thing when Thunderbird starts and is receiving new mail. Also see http://kb.mozillazine.org/Keep_it_working_-_Thunderbird

It's not about deleting messages, but moving messages out of Inbox. It's best practice to keep your Inbox as clean as possible. Inbox is most susceptible for corruption, and it's read first thing when Thunderbird starts and is receiving new mail. Also see http://kb.mozillazine.org/Keep_it_working_-_Thunderbird
Wayne Mery
  • Top 25 Contributor
  • Moderator
601 Lösungen 5748 Antworten
Veröffentlicht

News - new news...

docarchy

Please try this. In Options->Advanced->Config editor, find these 2 preferences with these values: mail.db.idle_limit 300000 mail.db.max_open 30

Are they at those value? Then, try to increase mail.db.max_open to 10000 or more than the number of your folders in total.

News - new news... docarchy Please try this. In Options->Advanced->Config editor, find these 2 preferences with these values: mail.db.idle_limit 300000 mail.db.max_open 30 Are they at those value? Then, try to increase mail.db.max_open to 10000 or more than the number of your folders in total.

Fragesteller

Wayne Mery said

News - new news... docarchy Please try this. In Options->Advanced->Config editor, find these 2 preferences with these values: mail.db.idle_limit 300000 mail.db.max_open 30 Are they at those value? Then, try to increase mail.db.max_open to 10000 or more than the number of your folders in total.
Hey Wayne, thanks for the response.

Since my last post, the issue resolved itself, all on it's own, on my Windows 8.1. But continued on my Windows 7.

But now the problem returned again on my Windows 8.1 today.

For your instructions, yes those values are as you said they are. I changed max_open to 10000, but the start up still took approximately 30 seconds to open.

This time the error line has moved to: Script: chrome://messenger/content/mail-offline.js:34

''Wayne Mery [[#answer-693414|said]]'' <blockquote> News - new news... docarchy Please try this. In Options->Advanced->Config editor, find these 2 preferences with these values: mail.db.idle_limit 300000 mail.db.max_open 30 Are they at those value? Then, try to increase mail.db.max_open to 10000 or more than the number of your folders in total. </blockquote>Hey Wayne, thanks for the response. Since my last post, the issue resolved itself, all on it's own, on my Windows 8.1. But continued on my Windows 7. But now the problem returned again on my Windows 8.1 today. For your instructions, yes those values are as you said they are. I changed max_open to 10000, but the start up still took approximately 30 seconds to open. This time the error line has moved to: Script: chrome://messenger/content/mail-offline.js:34

Fragesteller

christ1 said

It's not about deleting messages, but moving messages out of Inbox. It's best practice to keep your Inbox as clean as possible. Inbox is most susceptible for corruption, and it's read first thing when Thunderbird starts and is receiving new mail. Also see http://kb.mozillazine.org/Keep_it_working_-_Thunderbird
christ1, I haven't tried moving my emails from my inbox to other folders across my 5 email accounts. I would like to take that as a last resort as it will be a little time consuming.

Maybe I could create a new thunderbird profile, add each imap account 1 by 1, restart after each and see when the start-up time is affected? Could be a particular account or # of folders, or # of emails. I'll give it a try.

''christ1 [[#answer-643469|said]]'' <blockquote> It's not about deleting messages, but moving messages out of Inbox. It's best practice to keep your Inbox as clean as possible. Inbox is most susceptible for corruption, and it's read first thing when Thunderbird starts and is receiving new mail. Also see http://kb.mozillazine.org/Keep_it_working_-_Thunderbird </blockquote>christ1, I haven't tried moving my emails from my inbox to other folders across my 5 email accounts. I would like to take that as a last resort as it will be a little time consuming. Maybe I could create a new thunderbird profile, add each imap account 1 by 1, restart after each and see when the start-up time is affected? Could be a particular account or # of folders, or # of emails. I'll give it a try.
Wayne Mery
  • Top 25 Contributor
  • Moderator
601 Lösungen 5748 Antworten
Veröffentlicht

Hilfreiche Antwort

If https://support.mozilla.org/en-US/questions/1025125#answer-641195 did not help you, then I offer that a developer is working on startup performance activity. This work make take a few weeks to become available. So I suggest we wait for the results of that work.

If https://support.mozilla.org/en-US/questions/1025125#answer-641195 did not help you, then I offer that a developer is working on startup performance activity. This work make take a few weeks to become available. So I suggest we wait for the results of that work.

Fragesteller

Wayne Mery said

If https://support.mozilla.org/en-US/questions/1025125#answer-641195 did not help you, then I offer that a developer is working on startup performance activity. This work make take a few weeks to become available. So I suggest we wait for the results of that work.
Wayne, good to know. Look forward to the results.
''Wayne Mery [[#answer-696091|said]]'' <blockquote> If https://support.mozilla.org/en-US/questions/1025125#answer-641195 did not help you, then I offer that a developer is working on startup performance activity. This work make take a few weeks to become available. So I suggest we wait for the results of that work. </blockquote>Wayne, good to know. Look forward to the results.
Wayne Mery
  • Top 25 Contributor
  • Moderator
601 Lösungen 5748 Antworten
Veröffentlicht

docarchy, please install 38.0b1 from beta link at http://www.mozilla.org/en-US/thunderbird/channel/

Is the problem gone?

docarchy, please install 38.0b1 from beta link at http://www.mozilla.org/en-US/thunderbird/channel/ Is the problem gone?

Fragesteller

Wayne Mery said

docarchy, please install 38.0b1 from beta link at http://www.mozilla.org/en-US/thunderbird/channel/ Is the problem gone?

Hi Wayne,

Installed the beta in a new folder (C:\Program Files (x86)\Mozilla Thunderbird2). It opened much faster (a few seconds) on first start up, but after closing and opening again, it went back to opening in about 25 seconds.

This was on my Windows 7. Will install on Windows 8 next.

Should I try working with a new profile and adding my accounts again to see if it's the profile that is corrupt?

Edit: Installed on my Windows 8.1 and same experience as on Windows 7. On first start, Thunderbird open instantly. Closing and then reopening thunderbird and it's back to 25 - 30 seconds.

''Wayne Mery [[#answer-714068|said]]'' <blockquote> docarchy, please install 38.0b1 from beta link at http://www.mozilla.org/en-US/thunderbird/channel/ Is the problem gone? </blockquote> Hi Wayne, Installed the beta in a new folder (C:\Program Files (x86)\Mozilla Thunderbird2). It opened much faster (a few seconds) on first start up, but after closing and opening again, it went back to opening in about 25 seconds. This was on my Windows 7. Will install on Windows 8 next. Should I try working with a new profile and adding my accounts again to see if it's the profile that is corrupt? Edit: Installed on my Windows 8.1 and same experience as on Windows 7. On first start, Thunderbird open instantly. Closing and then reopening thunderbird and it's back to 25 - 30 seconds.

Geändert am von docarchy