Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

When I use Command-F to find text on a page in Ffx, the text I type into the "find" box gets put onto my clipboard, replacing what is there. This just started.

  • 15 Antworten
  • 56 haben dieses Problem
  • 4 Aufrufe
  • Letzte Antwort von jscher2000

more options

I am using a MacBookPro with Mavericks, updated to 10.9.3. I am using Ffx version 30.0. It appears to be "Mozilla Firefox Yahoo! Edition yahoo 1.16". I am not particularly interested in keeping the Yahoo! part and I am not sure how I got it to be Yahoo (and not just Ffx) - I think that happened a few years ago.

I have restarted my computer, shut down all other programs (nothing else is running), I went to about: support and clicked to Reset Firefox - nothing helps.

This began a couple of days ago (roughly 6/16/2014) and it is driving me absolutely mad. I copy some text onto my clipboard using Command-C and then I use Command-F to find text on the firefox window. then when I try to paste my clipboard text (with Command-V), whatever I typed into the Command-F window is what gets pasted. This overwriting of my clipboard is brand new - Ffx never worked this way before.

I am not using a ton of plugins - and I can dump any/all of them except Flash and QuickTime.

Hoping someone can help me...this is really compromising my productivity!


Alle Antworten (15)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thank you, but this did not work. I restarted in Safe Mode, switched to default theme, did not click Reset. Using Command-F still adds whatever text I type in search to my clipboard and overwrites what is already there.  :(((

more options

More info: I have (and had) the Default theme running. The problem persists. I turned off hardware acceleration - the problem persists. i checked "search when I start typing" (to go around the Command-F shortcut) - the problem persists. I have no extensions. I have very few add-ons. Since the problem persists in safe mode, I presume it's not any of the add-ons. The troubleshooting docs lead me to check extensions. add-ons, theme, hardware acceleration. All of those have been ruled out as the problem now... what's left?

more options

As for not keeping Yahoo branding, can't help you. You could try a fresh, clean profile. Sometimes, entries / changes made by addons may cause probs even if they're removed.

You may want to search the web for this problem - using various engines. It's a pretty specific problem.

Otherwise, since safe mode & fresh profile didn't work, I'd back up profile, Completely uninstall Fx, then remove any remaining files,' Then reboot. Shut down everything - disconnect from web. Install fresh copy of Fx. Test it out.

You can try copying over 1st your userprefs.js if you want. After each thing you install or copy over, need to verify it's still working, before installing another.

I generally don't install new versions over top of old ones - it causes a more problems in the long run.

more options

Thanks, joebt. Well, I did get rid of the Yahoo nonsense by trashing my firefox copy and downloading a fresh copy. Problem persisted. Then I found something that MAY explain this : version 30 release notes refers to "Mac OSX Command-E sets find term to selected text" on the following page:


This is felt to be a feature? It would be great if you could turn it OFF. I may have enabled this in error, but command-E again does not turn it OFF.

I found a way to download the previous version of Ffx (29.0.1) and indeed the problem does NOT happen using that version. So it seems to be a "feature" that was purposely introduced with version 30 - but a feature that can't be disabled once it's enabled?? acckkkk such pain. I will have to use Chrome until Firefox makes this "feature" something I can toggle. Ugh .

Thanks for your help, guys! I appreciate your advice - it was useful to me, and helped me to troubleshoot.

more options

Hi LieseS, I don't think the advertised feature is your problem. Neither Command+e nor Command+f should modify the clipboard. They should just populate any selected text in the page into the find bar itself.

If you have the patience for a little more testing:

Can you tell when the problem occurs in your style of usage of the bar:

  • immediately after typing one or more characters, while Firefox is searching for the first match
  • when you click one of the buttons (e.g., next arrow, previous arrow, or one of the others)
  • when you use one of the shortcut keys (e.g., F3 or command+g for next, Shift+F3 or Shift+command+g for previous)
  • some other time

You are not alone: another Mac user (version 10.8.5) reported this problem as well: Copy-paste problem with Firefox 30 (unsolved).

more options

This bug (fixed) may explain it a bit better. https://bugzilla.mozilla.org/show_bug.cgi?id=326743 Most of what I found about the change in Fx 30 just made a statement of that change (as you included) - w/o any explanation of how it worked.

If I understand the change in Fx OSx platform, for Command-E, what you describe as irritating is now default behavior?

And appears to be the way command-E normally works in other apps for OSx?

Geändert am von Joebt

more options

A bug has been filed for this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1020743

more options

Hi, Jscher2000 - thanks for replying. this part Edited to say "Oh i get what you mean by "the bar" you mean the find bar - I will check and try to answer your 3 queries now . A specific description Is: l copy (command-C) some text (say, from window in tab 1 of Firefox) and then go to tab 2 and seeking text using Command-F or / to locate a specific area. The purpose is to paste in the copied text from tab 1 into a spot on tab 2 (located with the find function). But what gets pasted is the text just typed into the search bar at the bottom of tab 2 - what was typed after command -F ( or / ) is over-writing my copied text from tab 1. URL or address bar really doesn't come into play...

Geändert am von LieseS

more options

Yes, joebt, you put it exactly right "the change in Fx OSx platform, for Command-E, the irritating" ( = read: NIGHTMARE) behavior is now default behavior.

It would be fine if it could be toggled on and off with command-E or any other key combo. Or any software setting. Anything, to just be able to turn it off.

I am not sure if this is how command-E works in other apps; that's what the notes say, but I have not myself noticed that before (have not used command-E) in all the time I have been using Mac OS ...

more options

Hi LieseS, I get the general idea, but I'm curious how soon your clipboard is overwritten. If you open the find bar and just type the letter a, is your clipboard replaced with a at that point, or does some additional step need to occur beyond the automatic "find first match" behavior? If I had access to a Mac I could test this, I would keep a separate application open and paste after each action in Firefox watching for when the data loss occurs.

more options

Thanks , jscher2000. Yes, if I click Command-F , whatever I type (even if it is just the letter a) will become the clipboard's contents (revealed when I use command-V). In that case, if I click command-F and type just a, then click Command-V, just a will be pasted. It doesn't need more than one character to wipe out my clipboard.

more options

Hi LieseS, I had the same problem, also on a Mac (10.8.5), and had to go back to Firefox 29 because of it. With Firefox 30, whatever I typed after command-F overwrote the contents of the clipboard. See Copy-paste problem with Firefox 30. https://support.mozilla.org/en-US/questions/1006098

Geändert am von sarahbeth

more options

I have the same problem and it is DEVASTATINGLY FRUSTRATING. For the love of all things good and green on this earth, please add an option to shut this off.

This function completely ruins my workflow, I'm going to have to switch to Chrome until this is fixed. Which is a shame, I love Firefox and I've been using it for as long as I can remember. But its just not an option when I cant control my clipboard. :"C

more options

Hi kellybot, this will be fixed in Firefox 31 (official bug report), which is scheduled to be released next week.

If you can't wait, you can install Firefox 31 now in its beta test form. This 9th generation of the beta test version is close to final now.


Note: if you install the Beta version, Firefox will want to auto-update you to the next Beta. To get out of Beta and back to the regular release channel, run the full installer of Firefox 31 when it is available here: https://www.mozilla.org/firefox/all/