Wiederherstellen wichtiger Daten aus einem alten Profil

Ein Firefox-Profil speichert alle Ihre wichtigen Daten wie Lesezeichen, Chronik, Passwörter usw. Wenn Sie ein neues Firefox-Profil erstellen und in dieses bestimmte Dateien aus dem bisherigen Profil übertragen, bedeutet das einen sauberen Neubeginn für Sie. Ihre wichtigen persönlichen Daten bleiben dabei erhalten.

Wenn Sie zunehmend Probleme mit Firefox bekommen, empfiehlt es sich, einfach ein neues Firefox-Profil anzulegen und dort Ihre wichtigsten Daten hineinzukopieren, anstatt den genauen Grund des Problems zu suchen und zu beheben.

Wenn Sie zunehmend Probleme mit Firefox bekommen, empfiehlt es sich, einfach ein neues Firefox-Profil anzulegen und dort Ihre wichtigsten Daten hineinzukopieren, anstatt den genauen Grund des Problems zu suchen und zu beheben. Das Zurücksetzen von FirefoxDas Restaurieren von Firefox erledigt dies automatisch für Sie.

Hinweis: Da häufig Einstellungsänderungen und Erweiterungen die Ursache von Problemen sind, erklärt dieser Artikel nicht, wie Sie diese von Profil zu Profil kopieren können. Erst nach Abarbeitung der in diesem Artikel erklärten Schritte können Sie die Erweiterungen neu installieren und die Firefox-Einstellungen erneut an Ihre Wünsche anpassen.

Daten Ihres aktuell genutzten Firefox-Profils sichern

Bevor Sie beginnen, empfehlen wir dringend, eine vollständige Sicherungskopie des existierenden Firefox-Profilordners zu erstellen – für den Fall, dass etwas schiefgehen sollte. Bitte lesen Sie dazu den Artikel Daten in Firefox-Profilen sichern und wiederherstellen.

Ein neues Firefox-Profil erstellen

Wie Sie ein neues Firefox-Profil erstellen, erfahren Sie im Artikel Firefox-Profile mithilfe des Profil-Managers erstellen und löschen.

Dateien von einem zum anderen Profilordner kopieren

Hinweis: Firefox muss vollständig beendet sein, während Sie Daten von einem Profilordner zum anderen kopieren.
  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet. Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder mit ihm zu arbeiten, folgen Sie der Anleitung Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8 Profilordner öffnen - Fx29 - Linux Profilordner öffnen - Fx35 - Mac

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie BeendenBeenden Firefox 29 Schließen .

  4. Klicken Sie mit der rechten MaustasteHalten Sie die Ctrl-Taste gedrückt und klicken Sie mit der Maus auf eine Datei, die Sie kopieren möchten, und wählen Sie Kopieren.
  5. Öffnen Sie den neuen Profilordner.
  6. Klicken Sie mit der rechten MaustasteHalten Sie die Ctrl-Taste gedrückt und klicken Sie mit der Maus in den neuen Profilordner und wählen Element Einfügen.

Wiederholen Sie die Schritte 2-5 für jede Datei, die Sie in den neuen Profilordner übertragen wollen.

Wenn Sie Ihre persönlichen Daten in das neue Firefox-Profil kopieren, kann es vorkommen, dass Sie den Fehler, den Sie beheben wollen, ungewollt mitübertragen. Je mehr Dateien Sie übertragen, desto größer ist die Wahrscheinlichkeit dafür. Deshalb empfiehlt sich folgende Vorgehensweise:

  • Übertragen Sie zuerst nur Ihre wichtigsten persönlichen Dateien, auf die Sie unter keinen Umständen verzichten möchten.
  • Prüfen Sie dann, ob der Fehler noch vorhanden ist. Wenn nicht, können Sie weitere Dateien in das neue Profil übertragen und erneut prüfen, ob das Problem beseitigt ist.

Ihre wichtigsten Daten und deren Dateien

Lesezeichen und Chronik

  • places.sqlite

Diese Datei enthält alle Firefox-Lesezeichen und die Liste der Webseiten, die Sie bisher besucht haben. Weitere Informationen erhalten Sie im Artikel Mit Lesezeichen Ihre Lieblingsseiten speichern und verwalten.

Lesezeichen, Downloads und Chronik

  • places.sqlite

Diese Datei enthält alle Firefox-Lesezeichen und Listen der Dateien, die Sie heruntergeladen haben, sowie der Webseiten, die Sie bisher besucht haben. Weitere Informationen erhalten Sie im Artikel Mit Lesezeichen Ihre Lieblingsseiten speichern und verwalten.

Passwörter

Ihre Passwörter werden in zwei verschiedenen Dateien gespeichert, die beide erforderlich sind:

  • key3.db – Diese Datei enthält die Schlüsseldatenbank Ihrer Passwörter. Um die gespeicherten Passwörter ins neue Profil zu übertragen, müssen Sie diese und die folgende Datei kopieren.
  • signons.sqlitelogins.json – Gespeicherte Passwörter.

Weitere Informationen erhalten Sie im Artikel Passwörter verwalten – speichern, löschen und ändern gespeicherter Passwörter in Firefox.

Seitenspezifische Einstellungen

  • permissions.sqlite

Diese Datei enthält Ihre Voreinstellungen für jede besuchte Webseite –  z. B. welcher Webseite Sie erlaubt oder verboten haben, Cookies zu speichern, Erweiterungen zu installieren, Grafiken darzustellen und Pop-ups zuzulassen.

Suchmaschinen

  • search.sqlite
  • Ordner /searchplugins/

Wenn Sie zusätzliche Suchmaschinen installiert haben, finden Sie diese im Ordner /searchplugins/. Die Datei search.sqlite enthält die Reihenfolge der Suchmaschinen in Firefox. Weitere Informationen erhalten Sie im Artikel Suchleiste – Suchmaschinen in Firefox hinzufügen, ändern und verwalten.

  • search.json

Diese Datei enthält die Suchmaschinendaten. Weitere Informationen erhalten Sie im Artikel Suchleiste – Suchmaschinen in Firefox hinzufügen, ändern und verwalten.

Persönliches Wörterbuch

  • persdict.dat

Diese Datei enthält jene Wörter, die Sie selbst dem Firefox-Wörterbuch hinzugefügt haben. Wenn Sie keine eigenen Wörter hinzugefügt haben, ist diese Datei nicht vorhanden. Weitere Informationen erhalten Sie im Artikel Rechtschreibprüfung in Firefox nutzen.

Such- und Formulardaten

  • formhistory.sqlite

Diese Datei enthält die in der Firefox-Suchleiste eingegebenen Suchbegriffe und die Eingaben in Formularen von Webseiten. Weitere Informationen erhalten Sie im Artikel Formular-Autovervollständigung.

Cookies

  • cookies.sqlite

Cookies können von Webseiten für eine Vielzahl von Informationen gesetzt werden –  z. B. für Ihre Anmeldung auf einer Webseite, die personalisierte Darstellung von Webseiten, persönliche Daten zur Identifikation usw.

Sicherheitszertifikate-Einstellungen

  • cert8.db

Diese Datei enthält alle Einstellungen zu Ihren Sicherheitszertifikaten sowie alle SSL-Zertifikate, die Sie in Firefox importiert haben.

Datei-Formate und Download-Aktionen

  • mimeTypes.rdf

Die Datei enthält Ihre Einstellungen, wie Firefox mit bekannten Dateien umgehen soll, z. B. ob Sie eine Datei speichern oder mit einer bestimmten Anwendung öffnen möchten. Weitere Informationen erhalten Sie im Artikel Einstellen, was Firefox tun soll, wenn eine Datei angeklickt oder heruntergeladen wird.

Download-Chronik

  • downloads.sqlite

Diese Datei enthält Informationen über die Dateien, die Sie heruntergeladen haben. Weitere Informationen erhalten Sie im Artikel Suchen und Verwalten von heruntergeladenen Dateien.



Basiert auf Informationen des Artikels Transferring data to a new profile - Firefox (mozillaZine KB).


Diesen Artikel teilen: <a href="http://mzl.la/1xKrzkF">http://mzl.la/1xKrzkF</a>

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: philipp, ThomasLendo, Wawuschel, pollti, Artist, graba. Auch Sie können helfen – erfahren Sie, wie.