Benutzerprofile – wo Firefox Ihre Lesezeichen, Passwörter und andere persönlichen Daten ablegt | Anleitung

Benutzerprofile – wo Firefox Ihre Lesezeichen, Passwörter und andere persönlichen Daten ablegt

Wussten Sie, dass Firefox Ihre Einstellungen wie z.B. Ihre Startseite, Symbolleisten, Lesezeichen und Passwörter in einem eigenen Profilordner ablegt? Dieser Profilordner wird getrennt von den Firefox-Programmdateien gespeichert. Im Fall, daß etwas schiefgehen sollte mit Firefox, können Sie immer noch auf Ihre Einstellungen zugreifen. Das heißt auch, daß Sie Firefox deinstallieren können ohne Ihre Einstellungen zu verlieren und es ist nicht notwendig Firefox erneut zu installieren, falls Sie Ihre Einstellungen löschen oder ein Problem beheben möchten.

Diese Information dient der Referenz. Sie müssen diesen Schritten nicht folgen, wenn Sie nicht von einem anderen Artikel dazu aufgefordert wurden.

Wie finde ich mein Profil?

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

Hinweis: Wenn Sie Firefox nicht starten und verwenden können, folgen Sie der Anleitung im nächsten Abschnitt, um Ihr Profil zu finden.

Mein Profil finden, ohne Firefox zu starten

  1. Auf dem Start-Bildschirm klicken Sie auf die Kachel Desktop um die Desktop-Ansicht zu öffnen
  2. Auf dem Desktop bewegen Sie sich in die rechte untere Ecke um Zugriff auf die Charm-Seitenleiste zu erhalten
  3. Wählen Die dort die Kategorie Suchen. Die Suchen-Seitenleiste wird geöffnet
  4. Geben Sie dies in das Suchfeld ein %APPDATA%\Mozilla\Firefox\Profiles\ ohne die Eingabetaste zu drücken. Eine Liste der Profile wird angezeigt
  5. Klicken Sie auf das Profil mit „default“ im Namen, um es in einem Fenster zu öffnen
  1. Klicken Sie auf die Start-Schaltfläche von Windows und geben Sie %APPDATA%\Mozilla\Firefox\Profiles\ in das Eingabefeld am unteren Rand des Startmenüs ein, ohne die Eingabetaste zu drücken. Daraufhin wird im Startmenü eine Liste der verfügbaren Profile angezeigt.
  2. Klicken Sie auf eines der Profile (z.B. xxxxxxxx.default), um den entsprechenden Profilordner im Windows-Explorer zu öffnen.

    a58c2481f8610cfdf0587592bf155871-1263117201-688-1.png
  1. Klicken Sie zuerst auf die Start-Schaltfläche von Windows und dann auf Ausführen....

    a58c2481f8610cfdf0587592bf155871-1263117201-688-2.png

  2. Geben Sie <%APPDATA%\Mozilla\Firefox\Profiles\ ein und klicken Sie auf OK.

    a58c2481f8610cfdf0587592bf155871-1263117201-688-3.png

Im Windows-Explorer öffnet sich daraufhin der Profiles-Ordner, der die einzelnen Profile enthält.

  1. Öffnen Sie den Ordner "Library" Ihres Mac-Benutzerkontos
    • (OS X 10.6 oder älter) Klicken Sie im Dock auf Finder. Ihr Home-Ordner wird direkt ausgewählt (normalerweise der Name Ihres Mac-Benutzerkontos). Auf der rechten Seite dieses Fensters klicken Sie aus den Ordner Library um ihn zu öffnen.
    • (OS X 10.7 oder neuer) Klicken Sie im Dock auf Finder. Klicken Sie in der Menüleiste auf das Menü Gehe zu, halten Sie die Wahltaste mac-wahltaste gedrückt und wählen Sie Library. Ein Fenster mit dem Inhalt des Ordners "Library" wird geöffnet.
  2. Öffnen Sie dort den Ordner "Application Support", danach öffnen Sie dort den Ordner "Firefox" und anschließend den Ordner "Profiles".
  3. Öffnen Sie dort auf den Ordner mit „default“ im Namen, um Ihr Profil zu öffnen

Ubuntu

Für Distributionen wie Ubuntu, die Unity als Arbeitsoberfläche per Voreinstellung einsetzen:

  1. Klicken Sie im Startmenü von Unity auf das Symbol für den Persönlichen Ordner.
    • Alternativ dazu können Sie den Schnellstart öffnen, indem Sie auf das oberste Ubuntu-Symbol klicken oder die Taste Windows/Super betätigen, und tippen Sie „persönlich“ ein. Wählen Sie das Symbol für den „Persönlichen Ordner“ aus.

    Persönlicher Ordner 01 Unity
    Der Dateimanager öffnet sich.
  2. Bewegen Sie die Maus an den oberen Rand des Bildschirms und klicken Sie auf das Menü Ansicht. Wählen Sie Verborgene Dateien anzeigen und setzen Sie damit ein Häkchen vor diese Option.

    Persönlicher Ordner 02 Unity
  3. Klicken Sie doppelt auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
  4. Klicken Sie doppelt auf den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

    Persönlicher Ordner 03 Unity

GNOME Version 3

Für Distributionen wie Fedora, Red Hat Enterprise Linux und andere, die die GNOME-Arbeitsumgebung per Voreinstellung einsetzen:

  1. Klicken Sie auf die Schaltfläche Aktivitäten in der linken, oberen Ecke des Bildschirms.
  2. Tippen Sie „persönlich“ in das Suchfeld rechts oben ein und öffnen Sie den „Persönlichen Ordner“ im Dateimanager.

    Persönlicher Ordner 01 Fedora
    Der Dateimanager öffnet sich.
  3. Klicken Sie auf das Menü Ansicht und aktivieren Sie Verborgene Dateien anzeigen.

    Persönlicher Ordner 02 Fedora
  4. Klicken Sie doppelt auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
  5. Klicken Sie doppelt auf den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

GNOME Version 2

  1. Klicken Sie auf das Menü Orte oben links auf dem Bildschirm und wählen Sie Persönlicher Ordner aus. Ein Fenster des Dateimanagers wird erscheinen.
  2. Klicken Sie auf das Menü Ansicht und aktivieren Sie Verborgene Dateien anzeigen.

    a64b318a52ca9ee53eb43686f1b993d7-1252101959-148-1.jpg

  3. Klicken Sie doppelt auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
  4. Klicken Sie doppelt auf den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

    a64b318a52ca9ee53eb43686f1b993d7-1252101015-702-1.png

KDE

Für Distributionen wie Kubuntu, openSUSE, Mandriva Linux, PCLinuxOS, Knoppix und andere, die die Arbeitsumgebung KDE Software Compilation per Voreinstellung einsetzen:

  1. Öffnen Sie den Dateimanager Ihrer Distribution.
    • (Kubuntu) Klicken Sie auf das K links unten und wählen Sie Rechner aus und öffnen Sie dort Persönlicher Ordner.

      Persönlicher Ordner 01 Kubuntu
    • (openSUSE) Klicken Sie auf das openSUSE-Symbol links unten und wählen Sie Rechner aus und öffnen Sie dort Persönlicher Ordner.
  2. Gehen Sie in das Menü Ansicht.
  3. Aktivieren Sie die Option Versteckte Dateien anzeigen.

    Persönlicher Ordner 02 openSUSE
  4. Klicken Sie auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
  5. Klicken Sie auf den Ordner firefox. Ihre einzelnen Profil-Ordner befinden sich in diesem Ordner.

LXDE

Für Distributionen wie Lubuntu und andere, die die LXDE-Arbeitsumgebung als Standard oder Alternative einsetzen:

  1. Starten Sie den Dateimanager im LXPanel.
  2. Gehen Sie in das Menü Ansicht.
  3. Aktivieren Sie die Option Verborgene Dateien anzeigen.
  4. Klicken Sie doppelt auf den Ordner .mozilla in Ihrem Persönlichen Ordner.
  5. Klicken Sie doppelt auf den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

Andere

Für Distributionen wie Linux Mint und andere, die Arbeitsumgebung einsetzen, die sich von den oben angesprochenen unterscheiden:

  1. Öffnen Sie den Dateimanager oder den Persönlichen Ordner über das Hauptmenü oder Panel Ihrer Distribution.
  2. Gehen Sie in das Menü Ansicht oder Anzeige.
  3. Aktivieren Sie die Option Verborgene Dateien anzeigen oder eine ähnlich lautende.
  4. Öffnen Sie den Ordner .mozilla in Ihrem Persönlichen Ordner.
  5. Öffnen Sie den Ordner firefox. Ihre einzelnen Profilordner befinden sich in diesem Ordner.

Welche Daten sind in meinem Profil abgelegt?

Hinweis: Nur die wichtigen Daten, die für eine Profilwiederherstellung nützlich sind, werden hier beschrieben.
  • Lesezeichen und Chronik: Die Datei places.sqlite enthält all Ihre Firefox-Lesezeichen und die Liste aller Webseiten, die Sie besucht haben. Mehr dazu erfahren Sie im Artikel Lesezeichen.
  • Passwörter: Ihre Passwörter werden in den Dateien key3b.db und signons.sqlite gespeichert. Mehr dazu erfahren Sie im Artikel Passwörter verwalten – speichern, löschen und ändern gespeicherter Passwörter in Firefox.
  • Seitenspezifische Einstellungen: Die Dateien permissions.sqlite und content-prefs.sqlite speichern viele Ihrer Berechtigungen und Einstellungen (wie die Zoom-Stufe), die je Webseite vergeben werden. Sie speichern zum Beispiel, welchen Seiten Sie erlaubt haben, Pop-ups anzuzeigen. Mehr dazu erfahren Sie im Artikel Wie verwalte ich Website-Berechtigungen? and Webseitenzoom.
  • Suchmaschinen: Die Datei search.sqlite und der Ordner searchplugins speichern die Suchmaschinen, die in der Firefox-|Such-Leiste verfügbar sind.
  • Persönliches Wörterbuch: Die Datei persdict.dat speichert die benutzerdefinierten Wörter, die Sie zu Ihrem Firefox-Wörterbuch hinzugefügt haben. Mehr dazu erfahren Sie im Artikel Rechtschreibprüfung nutzen.
  • Formular-Chronik: Die Datei formhistory.sqlite speichert, wonach Sie in der Firefox-Suchleiste gesucht und welche Daten Sie in Formulare auf Webseiten eingetragen haben. Mehr dazu erfahren Sie im Artikel Formular-Autovervollständigung.
  • Download-Chronik: Die Datei downloads.sqlite merkt sich, was Sie heruntergeladen haben. Mehr dazu erfahren Sie im Artikel Suchen und Verwalten von heruntergeladene Dateien.
  • Cookies: Ein Cookie enthält Daten, die eine Website, die Sie besucht haben, auf Ihrem Rechner gespeichert hat. In der Regel sind das Ihre seitenspezifischen Einstellungen oder Ihr Anmeldestatus. Alle Cookies werden in der Datei cookies.sqlite gespeichert.
  • DOM-Speicher: Englisch wird es „DOM storage“ genannt und ist dafür geschaffen worden, um größere Datenmengen auf sicherere Weise zu speichern und leichter nutzbar zu machen, als mit Cookies möglich ist. Die Daten werden für Webseiten in der Datei webappsstore.sqlite und für about:*-Seiten in der Datei chromeappsstore.sqlite abgespeichert.
  • Sicherheitszertifikatseinstellungen: Die Datei cert8.db speichert Ihre Sicherheitszertifikatseinstellungen und jedes SSL-Zertifikat, das Sie in Firefox importiert haben.
  • Sicherheitsgeräteeinstellungen: Die Datei secmod.db enthält die Datenbank mit den Sicherheitsmodulen.
  • Download-Aktionen: Die Datei mimeTypes.rdf speichert Ihre Präferenzen, die Firefox mitteilen, was getan werden soll, wenn Firefox auf eine Datei von einem bestimmten Dateityp stößt. Beispielsweise ist hier gespeichert, dass Firefox eine PDF-Datei mit dem Adobe-Reader öffnen soll, wenn Sie auf eine entsprechende Verknüpfung klicken. Mehr dazu erfahren Sie im Artikel Einstellen, was Firefox tun soll, wenn eine Datei angeklickt oder heruntergeladen wird.
  • Plugin-MIME-Typ: Die Datei pluginreg.dat speichert die MIME-Typen Ihrer installierten Plugins. Mehr dazu erfahren Sie im Artikel Plugins mit Firefox verwenden.
  • Gespeicherte Sitzungen: Die Datei sessionstore.js enthält die geöffneten Tabs und Fenster. Mehr dazu erfahren Sie im Artikel Sitzungswiederherstellung.
  • Symbolleisten-Anpassungen: Die Datei localstore.rdf speichert die Symbolleisten sowie die Fenstergrößen und Fensterpositionen. Mehr dazu erfahren Sie im Artikel Symbolleisten und Schaltflächen in Firefox anpassen.
  • Benutzerdefinierte Stile: Falls Sie vorhanden sind, speichern die Dateien \chrome\userChrome.css und \chrome\userContent.css benutzerspezifische Änderungen, die entweder das Aussehen von Firefox betreffen oder das Aussehen oder Verhalten von HTML-Elementen.

Mit Profilen arbeiten



Teile diesen Artikel: http://mzl.la/NYhKHH

War der Artikel hilfreich?

Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: KadirTopal, ThomasLendo, Wawuschel, kopibold. Auch Sie können helfen – erfahren Sie, wie.
Hilfe zu einer anderen Plattform erhalten:
Artikel anzeigen für:

Firefox