Symbolleisten werden immer zurückgesetzt | Fehlerbehebung

Symbolleisten werden immer zurückgesetzt

Manchmal speichert Firefox die vom Benutzer vorgenommenen Änderungen an Symbolleisten oder anderen Einstellungen nicht.

Dieser Artikel beschreibt, wie Sie das grundlegende Problem lösen können, das möglicherweise zu einem oder mehreren der folgenden Fehlverhalten von Firefox führt:

  • Sie haben Schaltflächen hinzugefügt, neu angeordnet oder entfernt, aber diese Änderungen gehen durch einen Neustart von Firefox verloren.
  • Sie haben die Größe oder Position des Firefox-Fensters geändert, aber die Änderungen gehen durch einen Neustart von Firefox verloren.
  • Sie können keine neuen Lesezeichen hinzufügen.

Lösung 1: Die Datei xulstore.json löschen

Möglicherweise ist die Datei xulstore.json in Ihrem Firefox-Profil beschädigt. Sie können diese Datei löschen, damit Firefox die Datei erneut erstellen kann.

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet. Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder mit ihm zu arbeiten, folgen Sie der Anleitung Mein Profil finden, ohne Firefox zu starten.

    Profilordner öffnen - Fx29 - Win8 Profilordner öffnen - Fx29 - Linux Profilordner öffnen - Fx35 - Mac

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Schließen Sie Firefox:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Beenden close 29 .

  4. Finden und löschen Sie die Datei xulstore.json (oder benennen Sie sie um, z. B. in xulstore.jsonALT, um die alte Datei als Backup zu behalten).
  5. Jetzt können Sie den Profilordner schließen und Firefox öffnen.

Lösung 2: Firefox restaurierenbereinigen

Beim RestaurierenBereinigen von Firefox werden die Symbolleisten-Einstellungen zurückgesetzt und alle Add-ons entfernt, darunter auch jene, die möglicherweise das Problem verursachten.

Hinweis: Wenn Sie die Funktion zum Bereinigen verwenden, werden Ihre Lesezeichen, die Chronik der zuvor besuchten Seiten, geöffnete Tabs, Fenster, Passwörter, Cookies und die Daten der Formular-Autovervollständigung gesichert. Jedoch werden Ihre Erweiterungen und Themes entfernt und Ihre Einstellungen werden auf den Ausgangszustand zurückgesetzt.Wenn Sie die Funktion zum Restaurieren verwenden, werden Ihre Lesezeichen, die Chronik der zuvor besuchten Seiten, geöffnete Tabs, Fenster, Passwörter, Cookies und die Daten der Formular-Autovervollständigung gesichert. Jedoch werden Ihre Erweiterungen und Themes entfernt und Ihre Einstellungen werden auf den Ausgangszustand zurückgesetzt.Wenn Sie die Zurücksetzen-Funktion verwenden, werden Ihre Lesezeichen, die Chronik der zuvor besuchten Seiten, geöffnete Tabs, Fenster, Passwörter, Cookies und die Daten der Formular-Autovervollständigung gesichert. Jedoch werden Ihre Erweiterungen und Themes entfernt und Ihre Einstellungen werden auf den Ausgangszustand zurückgesetzt. Wenn Sie die Zurücksetzen-Funktion verwenden, werden Ihre Lesezeichen, die Chronik der zuvor besuchten Seiten, Passwörter, Cookies und die Daten der Formular-Autovervollständigung gesichert. Jedoch werden Ihre Erweiterungen und Themes entfernt; die offenen Tabs, Fenster und Tab-Gruppen werden nicht gesichert; und Ihre Einstellungen werden auf den Ausgangszustand zurückgesetzt. Erfahren Sie mehr darüber.
  1. Wenn Sie diese Seite gerade mit Firefox aufgerufen haben, klicken Sie hier direkt auf die Schaltfläche Firefox bereinigen.
    Beim Seitenaufruf mit einem anderen Browser funktioniert das Restaurieren nicht.
    • Sie finden die Schaltfläche zum Restaurieren von Firefox auch in der rechten oberen Ecke der Seite about:support (Informationen zur Fehlerbehebung) in Firefox.

      about:support - Fx35 - Win8 Fx restaurieren - about support - Fx41 - Win10 about:support - Fx36 - Linux about:support - Fx35 - Mac

  2. Klicken Sie im sich öffnenden Bestätigungsfenster auf Firefox restaurieren, um fortzufahren.

    Fx resataurieren - Fx35 - Win8 Fx resataurieren - Fx41 - Win10 Fx resataurieren - Fx36 - Linux Fx restaurieren - Fx35 - Mac

  3. Firefox wird geschlossen und restauriert. Wenn der Vorgang abgeschlossen ist, wird ein Dialogfenster alle Daten auflisten, die in das neue Profil importiert wurden. Klicken Sie auf Fertigstellen und Firefox wird gestartet.

    Fx restaurieren - Fertigstellen - Fx35 - Win8 Fx restaurieren - Fertigstellen - Fx35 - Linux Fx restaurieren - Fertigstellen - Fx35 - Mac
  1. Wenn Sie diese Seite gerade mit Firefox aufgerufen haben, klicken Sie hier direkt auf die Schaltfläche Firefox bereinigen.
    Beim Seitenaufruf mit einem anderen Browser funktioniert das Bereinigen nicht.
  2. Klicken Sie im sich öffnenden Bestätigungsfenster auf Firefox bereinigen, um fortzufahren.

    Firefox bereinigen - Fx44

  3. Firefox wird geschlossen und bereinigt. Wenn der Vorgang abgeschlossen ist, wird ein Dialogfenster alle Daten auflisten, die in das neue Profil importiert wurden. Klicken Sie auf Fertigstellen und Firefox wird gestartet.

    Fx restaurieren - Fertigstellen - Fx35 - Win8 Fx restaurieren - Fertigstellen - Fx35 - Linux Fx restaurieren - Fertigstellen - Fx35 - Mac
Hinweis: Eine Schaltfläche zum BereinigenRestaurieren von Firefox finden Sie auch im Fenster des Abgesicherten Modus. Dies ist sehr hilfreich, wenn Sie Firefox nicht normal starten können.

Fx restaurieren - Abgesicherter Modus - Fx35 - Win8 Fx restaurieren - Abgesicherter Modus - Fx36 - Linux Fx restaurieren - Abgesicherter Modus - Fx35 - Mac Abgesicherter Modus Firefox bereinigen fx44

Wenn Sie die Schaltfläche zum BereinigenRestaurieren in Ihrer Firefox-Version nicht finden, können Sie Firefox auch manuell bereinigenrestaurieren, indem Sie ein neues Profil erstellen. Weitere Informationen und eine detaillierte Anleitung zum Erstellen eines neuen Profils erhalten Sie im Artikel Wiederherstellen wichtiger Daten aus einem alten Profil.

War der Artikel hilfreich?

Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel, pollti, Artist, Daniel2099. Auch Sie können helfen – erfahren Sie, wie.

Letzte Aktualisierung: 2016-09-24

Hilfe zu einer anderen Plattform erhalten:
Artikel anzeigen für:

Firefox