PDF-Dateien in Firefox öffnen | Anleitung

PDF-Dateien in Firefox öffnen

PDF-Dokument Ein PDF-Anzeige-Plugin kann alternativ zum integrierten PDF-Anzeige-Programm dazu verwendet werden, eine PDF-Datei innerhalb des Firefox-Fensters anzuzeigen. Dieser Artikel erklärt beide Methoden und zeigt, wie Sie die häufigsten Fehler beheben können.
PDF-Dokument Ein PDF-Anzeige-Plugin oder die PDF-Viewer-Erweiterung können dazu verwendet werden, eine PDF-Datei innerhalb des Firefox-Fensters anzuzeigen. Dieser Artikel erklärt beide Methoden und zeigt, wie Sie die häufigsten Fehler beheben können.
Hinweis: Der PDF-Viewer ist jetzt in Firefox integriert. Aktualisieren Sie Firefox, um ihn zu bekommen.

Den integrierten PDF-Viewer verwenden

Firefox enthält jetzt einen integrierten Betrachter für PDF-Dokumente, mit dem Sie fast alle im Internet verfügbaren PDF-Dateien öffnen können, ohne dazu ein Plugin zu benötigen. Der integrierte Betrachter für PDF-Dokumente ist standardmäßig aktiviert.

Die PDF-Viewer-Erweiterung verwenden

PDF Viewer (aka pdf.js) ist eine neue revolutionäre Erweiterung, die Web-Standard-Technologien verwendet und es Ihnen erlaubt, fast alle PDF-Dateien, die Sie im Internet finden können, ohne Plugin in Firefox anzuzeigen.

PDF JS DE

Wenn Sie das Plugin eines Betrachters für PDF-Dateien (wie den Adobe Reader) installiert haben, müssen Sie dieses deaktivieren, damit die PDF-Viewer-Erweiterung funktioniert.

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Add-ons. Der Tab mit der Add-ons-Verwaltung öffnet sich.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Die Add-ons-Verwaltung öffnet sich.

    Add-ons-Manager öffnen - fx29 - Win8 Menüschaltfläche Add-ons-Manager öffnen Fx36 Win8 Add-ons-Manager öffnen - fx35 - Mac Linux: Australis - Add-ons öffnen

  2. Gehen Sie im Tab mit der Add-ons-Verwaltung zum Abschnitt Plugins.
  3. Wählen Sie jedes PDF-Plugin aus und klicken Sie daneben auf Deaktivieren.


Die Funktionen der PDF-Viewer-Symbolleiste

  • Sidebar ein-/ausblenden - die Schaltfläche, die sich ganz links befindet, öffnet eine Sidebar mit Miniaturansichten aller Seiten des Dokuments. Einige Dokumente verfügen auch über eine Gliederungsansicht. Mit dieser können Sie auf einfache Weise durch umfangreiche Dokumente navigieren.
    Sidebar umschalten
  • Eine Seite vor- und zurückblättern oder direkt eine bestimmte Seite ansteuern - Mit den beiden Pfeilen können Sie die Seiten vor- und zurückblättern oder durch Eingabe der Seitenzahl eine gewünschte Seite direkt ansteuern.
    PDF Seite
  • Die Ansichtsgröße des Dokuments ändern - Klicken Sie auf die Schaltflächen + und -, um die aktuelle Ansicht zu vergrößern oder zu verkleinern oder wählen Sie aus dem Menü eine der vorgegebenen Zoomstufen aus.
    PDF Zoom DE
  • Vollbild oder Präsentationsmodus - Ein Klick auf diese Schaltfläche zeigt das PDF-Dokument auf der gesamten Bildschirmfläche an. Drücken Sie ESC, um den Präsentationsmodus zu verlassen.
    PDF Fullscreen
  • Drucken - Klicken Sie auf die Schaltfläche „Drucken“, um den Drucken-Dialog zu öffnen.
    PDF Print
  • Dokument speichern - Klicken Sie auf diese Schaltfläche, um das Dokument auf Ihrem Rechner zu speichern oder um es mit einem anderen Betrachter für PDF-Dateien zu öffnen.
    PDF Download
  • Aktuelle Ansicht kopieren - Klicken Sie mit der rechten MaustasteHalten Sie die Ctrl-Taste gedrückt und klicken Sie mit der Maus auf die Schaltfläche Aktuelle Ansicht, um die aktuelle Ansicht in einem neuen Tab oder einem neuen Fenster zu öffnen.
    PDF Copy


PDF-Viewer-Tastaturkürzel

Befehl Tastenkombination
Nächste Seite n oder j oder
Vorherige Seite p oder k oder
Ansicht vergrößern Strg + +Befehlstaste + +
Ansicht verkleinern Strg + -Befehlstaste + -
Automatischer Zoom Strg + 0Befehlstaste + 0
Dokument im Uhrzeigersinn drehen r
Dokument gegen den Uhrzeigersinn drehen Umschalttaste + r

Fehlerbehebung beim PDF-Viewer

Manche Dokumente werden nicht richtig dargestellt oder sind ohne Inhalt

Mit einigen PDF-Datei-Typen hat der PDF-Viewer Probleme, die Schriftarten, Farben oder das gesamte Dokument korrekt darzustellen. Um diese Dateien dennoch anzuzeigen:

  • Klicken Sie rechts oben auf die Schaltfläche „Dokument speichern“. Dadurch öffnet sich das Dokument mit dem auf Ihrem Rechner als Standard festgelegten Betrachter.

Alle PDF-Dateien können nicht geöffnet werden

Einige Erweiterungen, die JavaScript blockieren, können das Anzeigen von PDF-Dokumenten verhindern. Deaktivieren Sie diese Erweiterungen, damit die Anzeige von PDF-Dokumenten wieder funktioniert:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Add-ons. Der Tab mit der Add-ons-Verwaltung öffnet sich.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons. Die Add-ons-Verwaltung öffnet sich.

    Add-ons-Manager öffnen - fx29 - Win8 Menüschaltfläche Add-ons-Manager öffnen Fx36 Win8 Add-ons-Manager öffnen - fx35 - Mac Linux: Australis - Add-ons öffnen

  2. Gehen Sie im Tab mit der Add-ons-Verwaltung zum Abschnitt Extensions.
  3. Klicken Sie bei allen blockierenden Erweiterungen auf Deaktivieren.

Weitere Informationen erhalten Sie im Artikel Fehlerbehebung bei Erweiterungen, Themes und Hardwarebeschleunigung.

Ein Plugin zur Anzeige von PDF-Dateien verwenden

Wenn Sie PDF-Dokumente nicht mit dem in Firefox integrierten PDF-Betrachter (pdf.js) anzeigen möchten, können Sie ein PDF-Lese-Plugin wie Adobe Reader, Sumatra PDF oder PDF-XChange Viewer verwenden.Adobe Reader oder MozPlugger KParts-Plugin (KDE) verwenden.Schubert|it PDF Browser Plugin für Mac OS X 10.6 und später verwenden.

Um vom integrierten PDF-Betrachter zu einem Plugin zu wechseln:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie Einstellungen.Klicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Einstellungen.Klicken Sie in der Menüleiste auf das das Menü Firefox und wählen Sie Einstellungen....Klicken Sie oben im Firefox-Fenster auf das Menü Bearbeiten (oder auf die Schaltfläche Firefox, wenn die Menüleiste ausgeblendet ist) und wählen Sie Einstellungen....

    Einstellungen - Fx20 - Win7


    EinstellungenFx4Win7.png


    Einstellungen - Fx20 - WinXP


    Einstellungen_Fx4_Linux


    010897fd58f6e294a60e43bbcf0ffe51-1281982768-69-1.png

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Einstellungen.

    Einstellungen öffnen - Fx29 - Win7



    Einstellungen öffnen - Fx29 - Win8



    Einstellungen öffnen - Fx37 - Win8.1



    Einstellungen öffnen - Fx29 - Linux



    Einstellugen öffnen - Fx34 - MacOS

  2. Gehen Sie zum Abschnitt Anwendungen.
  3. Suchen Sie in der Spalte Dateityp nach dem Eintrag Portable Document Format (PDF) und klicken Sie darauf, um ihn auszuwählen.
  4. Klicken Sie in der Spalte Aktion auf PDF-Anzeige-Programm (in Firefox) verwenden.

    AcrobatReader in Firefox verwenden - Fx29 - Win8 e05dfa26d042e50e96172239cb698b18-1255252986-187-1.png

Wenn PDF-Dateien heruntergeladen werden, statt angezeigt zu werden, versuchen Sie diese Lösungen

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie Einstellungen.Klicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie Einstellungen.Klicken Sie in der Menüleiste auf das das Menü Firefox und wählen Sie Einstellungen....Klicken Sie oben im Firefox-Fenster auf das Menü Bearbeiten (oder auf die Schaltfläche Firefox, wenn die Menüleiste ausgeblendet ist) und wählen Sie Einstellungen....

    Einstellungen - Fx20 - Win7


    EinstellungenFx4Win7.png


    Einstellungen - Fx20 - WinXP


    Einstellungen_Fx4_Linux


    010897fd58f6e294a60e43bbcf0ffe51-1281982768-69-1.png

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Einstellungen.

    Einstellungen öffnen - Fx29 - Win7



    Einstellungen öffnen - Fx29 - Win8



    Einstellungen öffnen - Fx37 - Win8.1



    Einstellungen öffnen - Fx29 - Linux



    Einstellugen öffnen - Fx34 - MacOS

  2. Gehen Sie zum Abschnitt Anwendungen.
  3. Suchen Sie nach Adobe Acrobat Document (wenn Sie Adobe Reader verwenden) oder PDF-Dateien (für andere PDF-Readers) in der Liste und klicken Sie darauf, um es auszuwählen.
  4. Klicken Sie auf die Auswahlliste in der Spalte Aktion und wählen Sie den oben genannten Eintrag aus.

    AcrobatReader in Firefox verwenden - Fx29 - Win8 e05dfa26d042e50e96172239cb698b18-1255252986-187-1.png

    • Falls PDF-Anzeige-Programm (in Firefox) verwenden nicht als Option aufgelistet ist, folgen Sie der Anleitung Download-Aktionen zurücksetzen weiter unten und wiederholen Sie dann diese Schritte hier erneut.
  5. Klicken Sie auf OK, um das Einstellungen-Fenster zu schließenKlicken Sie auf Schließen, um das Einstellungen-Fenster zu schließenSchließen Sie das Einstellungen-FensterSchließen Sie den Einstellungen-Tab (about:preferences) .

Weitere Lösungen

Download-Aktionen zurücksetzen

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet. Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder mit ihm zu arbeiten, folgen Sie der Anleitung Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8 Profilordner öffnen - Fx29 - Linux Profilordner öffnen - Fx35 - Mac

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie BeendenBeenden Firefox 29 Schließen .

  4. Löschen Sie die Datei mimetypes.rdf.

Einstellungen Ihrer Anwendung zum Anzeigen von PDF-Dokumenten überprüfen

Wenn Ihr PDF-Plugin mit einer Lese-Anwendung zusammenhängt, überprüfen Sie, wenn vorhanden, die Plugin-Einstellungen dieses Programms.

  • Adobe Reader 9 + 10:
    1. Öffnen Sie den Adobe Reader.
    2. Klicken Sie oben im Fensterin der Menüleiste des Adobe Readers auf das Menü Bearbeiten und klicken Sie auf Voreinstellungen…. Das Fenster mit den Voreinstellungen öffnet sich.
    3. Gehen Sie zur Kategorie Internet in der linken Spalte.
    4. Stellen Sie sicher, dass bei PDF in Browser anzeigen ein Häkchen gesetzt ist.

      e05dfa26d042e50e96172239cb698b18-1278343632-105-1.png

    5. Klicken Sie auf OK, um das Fenster zu schließen. Schließen Sie danach den Adobe Reader.
  • Adobe Reader 11:
    1. Öffnen Sie den Adobe Reader.
    2. Klicken Sie oben im Fensterin der Menüleiste des Adobe Readers auf das Menü Bearbeiten und klicken Sie auf Voreinstellungen…. Das Fenster mit den Voreinstellungen öffnet sich.
    3. Gehen Sie zur Kategorie Allgemein in der linken Spalte.
    4. Klicken Sie dort auf die Schaltfläche Standard-PDF-Programm auswählen
    5. Falls sich das Fenster Standard-PDF-Programm auswählen öffnet: Wählen Sie das gewünschte Programm aus und klicken Sie auf Übernehmen.
    6. Klicken Sie auf OK, um das Fenster zu schließen. Schließen Sie danach den Adobe Reader.

Wenn PDF-Dateien weiterhin nicht in Firefox angezeigt werden können, folgen Sie diesen Anleitungen:

Die Plugin-Datenbank reinitialisieren

Befolgen Sie die Anleitung Die Plugin-Datenbank reinitialisieren.

Damit erzwingen Sie, dass Firefox die Plugin-Datenbank neu erstellt. Wenn Sie weiterhin keine PDF-Dateien in Firefox ansehen können, folgen Sie den folgenden Anleitungen.

Die Anwendung neu installieren

Wenn Ihr PDF-Plugin mit einer Lese-Anwendung zusammenhängt und die obigen Schritte nicht geholfen haben, deinstallieren Sie die Anwendung zur Anzeige von PDF-Dateien und installieren Sie sie erneut:

Wenn PDF-Dateien weiterhin nicht in Firefox angezeigt werden können, lesen Sie den nächsten Absatz:

Weitere Informationen für Adobe Reader

War keiner der bisher beschriebenen Lösungswege erfolgreich, finden Sie hier weitere Anweisungen: Adobes Fehlersuchseite „Can't view PDF on the web“ (englisch).

 


Diesen Artikel teilen: http://mzl.la/1BAQIvG

War der Artikel hilfreich?

Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel, boersenfeger, pollti, Artist, graba. Auch Sie können helfen – erfahren Sie, wie.
Hilfe zu einer anderen Plattform erhalten:
Artikel anzeigen für:

Firefox