Lesezeichen werden nicht gespeichert

  • Wenn Lesezeichen, die Sie in der Vergangenheit gespeichert haben, jetzt fehlen, lesen Sie den Artikel Verlorene Lesezeichen.

Neue Lesezeichen hinzufügen oder andere Änderungen nicht möglich

Wenn Sie nicht in der Lage sind, neue Lesezeichen hinzuzufügen, oder wenn Änderungen, die Sie an der Symbolleiste vorgenommen haben, nach einem Neustart nicht mehr vorhanden sind, lesen Sie den Artikel Symbolleisten werden immer zurückgesetzt.

Wenn Sie nicht in der Lage sind, neue Lesezeichen hinzuzufügen, oder wenn Änderungen, die Sie an Lesezeichen vornehmen, nicht übernommen werden und wenn Sie eine Erweiterung installiert haben, die etwas mit Lesezeichen zu tun hat (z.B. zum Synchronisieren von Lesezeichen oder zum Aufspüren von Duplikaten), folgen Sie der Anleitung im Artikel Fehlerbehebung bei Erweiterungen, Themes und Hardware-Beschleunigung. Dort können Sie ermitteln, ob eine Erweiterung das Problem verursacht.

Wir empfehlen, dass Sie alle Erweiterungen, die etwas mit Lesezeichen zu tun haben, laut dieser Anleitung deaktivieren, bevor Sie mit den restlichen Lösungsvorschlägen fortfahren.

Änderungen gehen nach einem Neustart von Firefox verloren

Wenn Sie zwar Lesezeichen hinzufügen, löschen, sortieren und andere Änderungen an den Lesezeichen vornehmen können, diese allerdings nach einem Neustart wieder verloren gehen, probieren Sie die folgenden Lösungen aus:

Places-Einstellungen

Wenn Änderungen an den Lesezeichen nach einem Neustart von Firefox 3 nicht gespeichert werden, setzen Sie die browser.places-Einstellungen auf die Standardwerte zurück:

  1. Tippen Sie in die Adressleiste about:config und drücken Sie die EingabetasteReturn.

    • Die Warnung „Hier endet möglicherweise die Gewährleistung!“ erscheint beim Aufruf von about:config. Klicken Sie auf Ich werde vorsichtig sein, versprochen!, um fortzufahren.

      about_config_win_fx4 about:config - Linux - Fx18 about_config_mac_fx4

      about:config - Fx29 - Linux about:config - Fx29 - Mac about:config - Fx29 - Win8
  2. Tippen Sie browser.places in das Filter-Eingabefeld ein.
  3. Für jede browser.places-Einstellung, die den Status vom Benutzer festgelegt hat, klicken Sie mit der rechten Maustaste daraufhalten Sie die Strg-Taste gedrückt, während Sie sie anklicken und wählen Sie Zurücksetzen.

Places-Datenbankdatei

Lesezeichen und die Chronik sind im Firefox-Profilordner in der Datei places.sqlite gespeichert. Sollte es ein Problem mit dieser Datei geben, so gehen Änderungen an den Lesezeichen nach jedem Neustart von Firefox verloren. Dieses Problem kann behoben werden, indem Sie Firefox dazu bringen, die Places-Datenbank wie folgt neu zu erstellen:

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8

    Profilordner öffnen - Fx29 - Linux

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Löschen Sie die Datei places.sqlite im Firefox-Profilordner und – sofern sie existiert – places.sqlite-journal oder benennen Sie sie um.
  5. (Optional) Löschen Sie auch die Datei localstore.rdf. Allerdings werden dadurch alle Änderungen an der Symbolleiste rückgängig gemacht und müssen danach neu erstellt werden.

Firefox erstellt automatisch eine neue Datei places.sqlite und importiert die letzte Lesezeichen-Sicherungsdatei.

Hinweis: Es könnte außerdem notwendig sein, die browser.places-Einstellungen auf die Standardwerte zurückzusetzen (siehe oben).

Lesezeichen-Datei ist schreibgeschützt

Wenn die Änderungen an den Lesezeichen nicht wirksam sind, wenn Sie den Browser neu starten, könnte es sein, dass die Lesezeichen-Datei schreibgeschützt ist. Eine schreibgeschützte Datei kann nicht geändert werden, wodurch verhindert wird, dass die Änderungen an den Lesezeichen gespeichert werden können.

Um den Schreibzugriff auf die Lesezeichen-Datei zu aktivieren:

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8

    Profilordner öffnen - Fx29 - Linux

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Klicken Sie mit der rechten Maustaste auf die Datei places.sqlite und wählen Eigenschaften, um das Eigenschaften-Fenster zu öffnen.
  5. Gehen Sie im Eigenschaften-Fenster zum Reiter Allgemein. Stellen Sie sicher, dass Schreibgeschützt im unteren Fensterteil nicht ausgewählt ist.

    bb29d660686072d5ee243afab05c6bfa-1261244397-722-1.png

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8

    Profilordner öffnen - Fx29 - Linux

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Wählen Sie die Datei places.sqlite.
  5. Wählen Sie in der Menüleiste das Menü Datei und gehen Sie zu Informationen. Das Informationsfenster zur places.sqlite wird geöffnet.
  6. Entfernen Sie im Informationsfenster zur places.sqlite die Markierung beim Geschützt-Kontrollkästchen.

    bb29d660686072d5ee243afab05c6bfa-1266068818-524-1.png
  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder zu verwenden, folgen Sie der Anleitung unter Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8

    Profilordner öffnen - Fx29 - Linux

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  4. Wählen Sie die Datei places.sqlite.
  5. Klicken Sie mit der rechten Maustaste auf die Datei places.sqlite und wählen Eigenschaften, um das Eigenschaften-Fenster zu öffnen.
    • (GNOME) Gehen Sie im Eigenschaften-Fenster zum Reiter Zugriffsrechte. Stellen Sie sicher, dass Ihr Benutzerkonto Schreibrechte für diese Datei besitzt.
    • (KDE) Gehen Sie im Eigenschaften-Fenster zum Reiter Berechtigungen. Stellen Sie sicher, dass Ihr Benutzerkonto Schreibrechte für diese Datei besitzt.




Basiert auf Informationen von Bookmarks not saved (mozillaZine KB)

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel. Auch Sie können helfen – erfahren Sie, wie.