Add-ons können nicht deinstalliert werden

Dieser Artikel beschreibt, wie Sie Erweiterungen und Themes deinstallieren können, die sich nicht nach der Anleitung Add-ons deaktivieren oder deinstallieren bzw. Symbolleisten deinstallieren, die die Firefox-Suche oder -Startseite verändert haben entfernen lassen. Dazu gehören zum Beispiel problematische Toolbars und Suchleisten.

Hinweis:

Das Zurücksetzen von Firefox in seinen Ausgangszustand kann viele Probleme beheben, wobei Sie wichtige Daten vorher sichern können. Ziehen Sie diese Art der Problembehebung in Erwägung, bevor Sie eine langwierige Suche nach der Ursache und der Lösung Ihres Problems beginnen.

Das Restaurieren von Firefox kann viele Probleme beheben, wobei wichtige Daten vorher gesichert werden. Ziehen Sie diese Art der Problembehebung in Erwägung, bevor Sie eine langwierige Suche nach der Ursache und der Lösung Ihres Problems beginnen.

Im Abgesicherten Modus von Firefox deinstallieren

Wenn Sie auf den Add-ons-Manager nicht zugreifen können oder die Entfernen-Schaltfläche bei einer bestimmten Erweiterung ausgegraut ist, versuchen Sie die Deinstallation mit dem Abgesicherten Modus von Firefox.

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Mit deaktivierten Add-ons neu starten…. Firefox wird neu starten und das Dialogfenster für den abgesicherten Modus zeigen.

    Abgesicherter Modus - WinXP - Fx23 Abgesicherter Modus - Win7 - Fx23 AbgesicherterModus_Fx4_linux AbgesicherterModus_Fx4_mac

    Hinweis: Sie können Firefox ebenso im abgesicherten Modus starten, wenn Sie die Umschalttaste gedrückt halten, während Sie Firefox starten.

    Umschalt-Taste + Doppelklick - Win7 - Fx23
    die Wahltaste mac-wahltaste gedrückt halten, während Sie Firefox starten.
    Firefox beenden, das Terminal aufrufen und Folgendes ausführen: firefox -safe-mode
    Eventuell müssen Sie das Installationsverzeichnis von Firefox angeben (z. B. /usr/lib/firefox-4 -safe-mode).
    So öffnen Sie das Terminal (das auch Shell oder Konsole genannt wird):
    • (Unity wie bei Ubuntu) Öffnen Sie den Schnellstart (Dash-Startseite). Klicken Sie dazu entweder auf das Ubuntu-Symbol im Unity-Startmenü oder betätigen Sie einfach die Taste Windows/Super. Tippen Sie das Wort „terminal“ ein und klicken Sie dann auf das erscheinende Symbol mit dem schwarzen Bildschirm darunter.
    • (GNOME wie bei Fedora, Linux Mint) Öffnen Sie das Menü Anwendungen, wählen Sie Zubehör und dann Terminal.
    • (KDE wie bei Kubuntu, openSUSE, Knoppix) Öffnen Sie den Anwendungen-Starter links unten am Bildschirmrand. Geben Sie im Feld Suchen den Befehl Terminal ein und drücken Sie danach die Eingabetaste.
    Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe-Schaltfläche Help-29 und wählen Sie Mit deaktivierten Add-ons neu starten…. Firefox startet dann im abgesicherten Modus neu.

    Abgesicherter Modus - Fx29 - Win8


    Abgesicherter Modus - Fx29 - Linux - GIF


    Abgesicherter Modus - Fx34 - MacOS
    Hinweis: Sie können Firefox auch im abgesicherten Modus starten, indem Sie die Umschalttaste die Wahltaste mac-wahltaste gedrückt halten, während Sie Firefox starten.

    Umschalt-Taste + Doppelklick - Win7 - Fx23
    Sie können Firefox im abgesicherten Modus starten, wenn Sie Firefox beenden, das Terminal aufrufen und Folgendes ausführen: firefox -safe-mode
    Eventuell müssen Sie das Installationsverzeichnis von Firefox angeben (z. B. /usr/lib/firefox).
    So öffnen Sie das Terminal (das auch Shell oder Konsole genannt wird):
    • (Unity wie bei Ubuntu) Öffnen Sie den Schnellstart (Dash-Startseite). Klicken Sie dazu entweder auf das Ubuntu-Symbol im Unity-Startmenü oder betätigen Sie einfach die Taste Windows/Super. Tippen Sie das Wort „terminal“ ein und klicken Sie dann auf das erscheinende Symbol mit dem schwarzen Bildschirm darunter.
    • (GNOME wie bei Fedora, Linux Mint) Öffnen Sie das Menü Anwendungen, wählen Sie Zubehör und dann Terminal.
    • (KDE wie bei Kubuntu, openSUSE, Knoppix) Öffnen Sie den Anwendungen-Starter links unten am Bildschirmrand. Geben Sie im Feld Suchen den Befehl Terminal ein und drücken Sie danach die Eingabetaste.
  2. Klicken Sie im Dialogfenster des Abgesicherten Modus auf Im abgesicherten Modus weiterarbeiten.

Wenn Firefox im Abgesicherten Modus gestartet ist, versuchen Sie erneut, die Erweiterung zu entfernen, und starten Sie dann Firefox neu.

Über die Systemsteuerung deinstallieren

Manche Erweiterungen werden durch andere Programme installiert. Möglicherweise können Sie die betreffende Erweiterung über die Windows-Systemsteuerung deinstallieren:

Installierte Erweiterungen von anderer Software

Manchmal wird durch andere Software eine Firefox-Erweiterung mitinstalliert, die sich nicht über die Add-ons-Verwaltung entfernen lässt, da die Schaltfläche Entfernen nicht funktionstüchtig ist.

Möglicherweise hat die Software, die die Erweiterung installiert hat, eine Option zum Entfernen. Besuchen Sie die Support-Seite des Anbieters, um weitere Einzelheiten nachzulesen. Eine Alternative wäre die Deaktivierung der Erweiterung, die Sie nicht mehr nutzen wollen, in der Add-ons-Verwaltung. Um die Erweiterung, die Sie nicht mehr nutzen wollen, zu deaktivieren, klicken Sie auf die Erweiterung und dann auf die Schaltfläche Deaktivieren. Nach einem Neustart von Firefox ist die Erweiterung deaktiviert.

Microsoft .NET Framework-Assistent

Wenn Sie das Microsoft .NET Framework nutzen, wird durch ein Microsoft-Update die Erweiterung Microsoft .NET Framework Assistant installiert.

Um diese Erweiterung zu entfernen, folgen Sie den Anweisungen im Microsoft-Artikel Wie Sie den .NET Framework-Assistenten für Firefox entfernen.

Java Quick Starter

Wenn Sie die Java-Software installiert haben, erscheint die Erweiterung Java Quick Starter in der Liste der installierten Erweiterungen. Bei dieser Erweiterung ist die Schaltfläche Entfernen inaktiv.

Um die Erweiterung zu entfernen, folgen Sie den Anweisungen im Artikel Oracle's Java Quick Starter.

63538ddbd4c94def3735ebd90334561c-1263318351-46-1.png

Während Sie den Anweisungen folgen, muss Firefox geschlossen sein.

Nach einem Neustart von Firefox ist die Java Quick Starter-Erweiterung deinstalliert.

Manuell deinstallieren

Wenn die Deinstallation auch im Abgesicherten Modus nicht funktioniert, gehen Sie zum Ordner, in dem die Erweiterungen installiert sind:

  1. Öffnen Sie Ihren Profilordner:

    Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox, gehen Sie dann zum Menü HilfeKlicken Sie in der Menüleiste auf das Menü HilfeKlicken Sie oben im Firefox-Fenster auf das Menü Hilfe und wählen Sie Informationen zur Fehlerbehebung.... Der Tab mit Informationen zur Fehlerbehebung wird geöffnet. Klicken Sie auf die Menüschaltfläche New Fx Menu , klicken Sie auf die Hilfe Help-29 und wählen Sie Informationen zur Fehlerbehebung. Der Tab mit Informationen zur Fehlerbehebung wird geöffnet.

  2. Klicken Sie unter Allgemeine Informationen auf Ordner anzeigenIm Finder anzeigenOrdner öffnen. Ein Fenster mit Ihren ProfildateienIhrem Profilordner wird geöffnet.
    Hinweis: Falls es Ihnen nicht möglich ist, Firefox zu starten oder mit ihm zu arbeiten, folgen Sie der Anleitung Wie finde ich mein Profil, ohne Firefox starten zu müssen.

    Profilordner öffnen - Fx29 - Win8 Profilordner öffnen - Fx29 - Linux Profilordner öffnen - Fx35 - Mac

    OpenProfileFolder - Win - Fx21 OpenProfileFolder_linux_Fx4 OpenProfileFolder_mac_Fx4

  3. Öffnen Sie in Ihrem Profilordner den Ordner extensions. Innerhalb des extensions-Ordners ist für jede installierte Erweiterung und jedes Theme ein Ordner angelegt.
  4. Um herauszufinden, welcher Ordner bzw. welche XPI-Datei zu dem Add-on, das Sie deinstallieren möchten, gehört, gehen Sie zurück zum Tab mit den Informationen zur Fehlerbehebung zurück.
  5. Suchen Sie im Abschnitt Erweiterungen die Erweiterung, die Sie entfernen möchten, und notieren Sie die ID-Nummer.
  6. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie BeendenBeenden Firefox 29 Schließen .

  7. Löschen Sie den Ordner oder die XPI-Datei, die mit der notierten ID-Nummer übereinstimmt.

Global installierte Erweiterungen

In seltenen Fällen (z. B. Java-Konsole) werden Erweiterungen im Programmordner von Firefox installiert. Weitere Informationen dazu erhalten Sie in diesem Artikel (englisch) des Mozilla-Entwicklernetzwerks (MDN ≙ Mozilla Developer Network). Um diese global installierten Erweiterungen zu entfernen, machen Sie Folgendes:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie BeendenBeenden Firefox 29 Schließen .

  2. Gehen Sie zum Firefox-Programmordner.
  3. Öffnen Sie dort den Ordner browser/extensions.
  4. Befolgen Sie die weiter oben aufgeführten Schritte, um den betreffenden Ordner bzw. die betreffende XPI-Datei zu finden und zu löschen.
  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie BeendenBeenden Firefox 29 Schließen .

  2. Gehen Sie zu Library/Application Support/Mozilla/.
  3. Öffnen Sie dort den Ordner Extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}.
  4. Befolgen Sie die weiter oben aufgeführten Schritte, um den betreffenden Ordner bzw. die betreffende XPI-Datei zu finden und zu löschen.
  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie den Eintrag Beenden. Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie BeendenBeenden Firefox 29 Schließen .

  2. Gehen Sie zu den folgenden Ordnern:
    • /usr/lib/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/
    • /usr/lib64/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/
    • /usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/
  3. Befolgen Sie die weiter oben aufgeführten Schritte, um den betreffenden Ordner bzw. die betreffende XPI-Datei zu finden und zu löschen.



Basiert auf Informationen des Artikels Uninstalling add-ons (mozillaZine KB)


Diesen Artikel teilen: http://mzl.la/1BuLd50

War der Artikel hilfreich? Bitte warten…

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, Wawuschel, pollti, graba. Auch Sie können helfen – erfahren Sie, wie.