Viser spørgsmål med mærket: Vis alle spørgsmål
  • Løst
  • Arkiveret

utf-8 displayed incorrectly

My site uses a template engine to wrap standard page HTML around templates that contain only the body text. However utf-8 multibyte characters are displayed correctly if… (læs mere)

My site uses a template engine to wrap standard page HTML around templates that contain only the body text. However utf-8 multibyte characters are displayed correctly if there is no HTML header but incorrectly if the standard page header, which explicitly specifies utf-8 encoding, is presented to Firefox.

https://www.jamescobban.net/templates/Articles/FrenchOccupations.html is the template of the body text https://www.jamescobban.net/displayPage.php?template=Articles/FrenchOccupations has the HTML header and footer wrapped around it. You can look at it yourself, but to save time the header added by displayPage is:

   
   
      
        <title>
	    ...text extracted by DisplayPage from the h1 tag...
        </title>
        <meta charset="utf-8">
        <meta content="text/css" http-equiv="default-style">
        <meta content="James A. Cobban" name="author">
        <meta content="© 2018 James A. Cobban" name="copyright">
        <meta content="genealogy, family, tree, ontario, canada " name="keywords">
        <link href="/styles.css" rel="stylesheet" type="text/css">
      

Stillet af jamescobban for 1 år siden

Besvaret af jscher2000 for 1 år siden

  • Løst
  • Arkiveret

What does *raced* from the dev tools - Network - Transferred mean?

Hello, What does (raced) mean in transferred elements? Seems to me the browser is getting the item from the server even though I've set a cache for jpeg and png files. Ot… (læs mere)

Hello,

What does (raced) mean in transferred elements? Seems to me the browser is getting the item from the server even though I've set a cache for jpeg and png files. Other similar items are locally cached as it should.

Thank you,

Stillet af srj.elmi for 1 år siden

Besvaret af TyDraniu for 1 år siden

  • Løst
  • Arkiveret

Websockets on localhost stopped working in 66.0

After updating to Firefox 66.0 on MacOS 10.13.6 today, websockets on my localhost stopped working. When using Create React App (version of "react-scripts": "2.1.8" => … (læs mere)

After updating to Firefox 66.0 on MacOS 10.13.6 today, websockets on my localhost stopped working.

When using Create React App (version of "react-scripts": "2.1.8" => "webpack-dev-server": "3.1.14" => "sockjs": "0.3.19"), hot reload is broken and I get following error in the console:

`The connection to ws://localhost:3000/sockjs-node/743/khw0phgj/websocket was interrupted while the page was loading.`

When I tried https://www.websocket.org/echo.html, it works fine and no problems with hot reload in Chrome 72.0.

How can I debug and fix this problem please? (when I googled the error message, I got a lot of outdated advice from previous versions of Firefox)

Stillet af Peter Hozák for 1 år siden

Besvaret af Peter Hozák for 1 år siden

  • Løst
  • Arkiveret

where I can find Windows Media Player plugin for FF quantum 62.0?

Hi, I have win7pro 864) and I run "FF quantum 62.0 - 32 bit" I'm really struggling with Windows Media Player plugin for FF: I downloaded and installed the latest version… (læs mere)

Hi, I have win7pro 864) and I run "FF quantum 62.0 - 32 bit"

I'm really struggling with Windows Media Player plugin for FF: I downloaded and installed the latest version (1.0.0.8 is it?) but it doesn't work...

Indeed I cannot see it within the installed plugins and if I try to "install by file (np-mswmp.dll)" it gets me an error of file corruption...

I really don't know what to do anymore...Where can I download it?

thanks a lot!

Stillet af mfran2002 for 2 år siden

Besvaret af cor-el for 2 år siden

  • Løst
  • Arkiveret

Our website doesn't display properly on Firefox

Our business website has recently been relaunched, it displays fine on other browsers but is beyond broken on Firefox. I've attached a screenshot of how it looks on Chrom… (læs mere)

Our business website has recently been relaunched, it displays fine on other browsers but is beyond broken on Firefox. I've attached a screenshot of how it looks on Chrome, to see how it looks on Firefox here is our url: https://www.exegetic.biz/.

As you can see it's VASTLY different and VERY frustrating. I've done a fair amount of reading as to what the issue could be but all the suggestions I have found are end user based... For example emptying the cache, clearing cookies, checking the zoom etc. This doesn't really help since I've looked at the site on various devices with FireFox and they all appear the same...

Has anyone else experienced this? Any help would e greatly appreciated!

Stillet af EmmaExegetic for 1 år siden

Besvaret af Wesley Branton for 1 år siden

  • Løst
  • Arkiveret

My website is not working in Firefox but its working fine in Chrome

I just made my website and it's not working in Firefox however in chrome its working fine. It's in Wordpress. Is something wrong with my wordpress plugins. It gives me e… (læs mere)

I just made my website and it's not working in Firefox however in chrome its working fine. It's in Wordpress. Is something wrong with my wordpress plugins.

It gives me error that says "Secure Connection Failed"

Website Link : http://esportsrush.com/

https://i.imgur.com/QnrvzMg.jpg

Can't use the add images button below so posting imgur link here.

Stillet af gomu for 1 år siden

Besvaret af cor-el for 1 år siden

  • Løst
  • Arkiveret

Styles within pages are cached and don't reload. How not to cache styles in local pages?

When developing an html or svg file I repeat editing content and style information and reload the file in Firefox. When editing styles I can't save them notifying cache. … (læs mere)

When developing an html or svg file I repeat editing content and style information and reload the file in Firefox. When editing styles I can't save them notifying cache. When editing content in external editor and reloading file all style changes are lost. However when editing styles in external editor, I can't force to reload them without deleting cache in general and when continuing to edit styles in Firefox all previously lost changes are lost on locally stored file as well. So how can I prevent Firefox from caching style information contained in local html or svg files?

Stillet af Vollbracht for for 11 måneder siden

Besvaret af FranciscoJS12 for for 10 måneder siden

  • Løst

firefox.cfg no longer overwrite new tab content

I'm using firefox developer edition. The latest version: 76.0b2 I have firefox.cfg set up to overwrite new tab content with locally stored html. The code in firefox.cfg t… (læs mere)

I'm using firefox developer edition. The latest version: 76.0b2 I have firefox.cfg set up to overwrite new tab content with locally stored html. The code in firefox.cfg that worked until recent update:

/* set new tab page */ try {

 var newTabURL = "file:///G:/Documents/Newtab.html";
 aboutNewTabService = Cc["@mozilla.org/browser/aboutnewtab-service;1"].getService(Ci.nsIAboutNewTabService);
 aboutNewTabService.newTabURL = newTabURL;

} catch(e){Cu.reportError(e);} // report errors in the Browser Console

In the browser console there is an error message displayed:

[Exception... "Cannot modify properties of a WrappedNative" nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)" location: "JS frame :: firefox.cfg :: <TOP_LEVEL> :: line 7" data: no]

Any idea what that error message means and how to resolve it? Does anything changed regarding new tab overwrite?

Stillet af shdowmyst for for 5 måneder siden

Besvaret af cor-el for for 5 måneder siden

  • Løst

How to remove Event Listener at the inspector panel of firefox devtools?

Guys, Removing Event listener on chrome is simple, just view it on the bottom right section, expand the element on the event trees, then click the 'remove' button. Tada a… (læs mere)

Guys, Removing Event listener on chrome is simple, just view it on the bottom right section, expand the element on the event trees, then click the 'remove' button. Tada and putta, the event is no longer functional. But, on firefox platform, how to achieve that???

Stillet af 1983115293 for for 5 måneder siden

Besvaret af Buddhika for for 5 måneder siden

  • Løst
  • Arkiveret

Instead of redirecting to our main site like all the other major browsers do, we get: "Warning: Potential Security Risk Ahead" in Firefox

When you go to https://www.northshore.com, instead of redirecting to our main site (https://www.northshorecare.com) Firefox displays an incorrect warning that the site yo… (læs mere)

When you go to https://www.northshore.com, instead of redirecting to our main site (https://www.northshorecare.com) Firefox displays an incorrect warning that the site you were about to be redirected to is somehow a potential security risk. This happened to me in regular Firefox, Nightly and the Developer edition, so it's not just an anomoly. The live site is fully SSL-compliant and poses no such threat to the user. Is it because the redirecting domain is not secure? Can you create an exception so that people don't see this erroneous message? Or is there a way we can alter the redirect so that it doesn't trigger this warning?

The old adage "you never get a second chance to make a first impression" is in full effect in this situation and I'm sure you can see that we certainly don't want to give people any reason to not continue to our site, so hopefully you can offer a solution to this problem.

Thanks in advance!

Stillet af paul-northshore for 1 år siden

Besvaret af paul-northshore for 1 år siden

  • Løst
  • Arkiveret

remove synced data from cloud while configured to use local sync server

We use a firefox sync server locally for around 50 users. One server updated automatically and lost the custom value for the "identity.sync.tokenserver.uri" setting in ab… (læs mere)

We use a firefox sync server locally for around 50 users. One server updated automatically and lost the custom value for the "identity.sync.tokenserver.uri" setting in about:config. This meant that any user using firefox on that server had their sync account data sent and stored in the mozilla cloud sync server. What is the process to clear and remove all the synced data from the cloud sync server for several users without removing the local sync server's contents as well?

The issue here is technically how it is done. If I reset an account's password, and then change it from my laptop which is set to use the local sync server, from what I can tell that would remove the contents from the local sync server rather than the cloud one, or would it do both somehow? Then there is the question of if I change the password while on that server, choose a new one, it will then start syncing to the cloud sync server again right?

Stillet af joel.stockley for 2 år siden

Besvaret af Shadow110 for 2 år siden

  • Arkiveret

Firefox cannot load a Web site

Hi, I'm reporting that firefox, firefox ERS and firefox developer edition (all latest version) are not able to load the Web site https://www.klaytn.com/. While the Web si… (læs mere)

Hi,

I'm reporting that firefox, firefox ERS and firefox developer edition (all latest version) are not able to load the Web site https://www.klaytn.com/. While the Web site works well with qupzilla and chromium browser (brave). I already tried all the step in the official documentation (fresh empty profile).

Thank you

Stillet af erotavlas for 1 år siden

Seneste svar af erotavlas for 1 år siden

  • Løst
  • Arkiveret

Do you support NgbHighlight component?

ngb-highlight selector doesn't get customer listeners (mouseenter, mouseleave) app.component.html <ngb-highlight (mouseenter)="hello()" class="autocomplete-item" [resu… (læs mere)

ngb-highlight selector doesn't get customer listeners (mouseenter, mouseleave)

app.component.html <ngb-highlight (mouseenter)="hello()" class="autocomplete-item" [result]="replaceSpace(result)" [term]="replaceSpace(term)"></ngb-highlight>

app.component.ts hello() {console.log('What?')}

it doesn't run, why?

Stillet af dxlam for 2 år siden

Besvaret af Shadow110 for 2 år siden

  • Arkiveret

SSL_ERROR_BAD_CERT_DOMAIN with SAN certificate

I am testing with a SAN certificate shown at the bottom -- The CN is gvm and contains the SANs 172.28.242.30, 172.28.242.28, 172.28.242.25, 172.28.242.24, 172.28.242.29, … (læs mere)

I am testing with a SAN certificate shown at the bottom -- The CN is gvm and contains the SANs 172.28.242.30, 172.28.242.28, 172.28.242.25, 172.28.242.24, 172.28.242.29, 172.28.242.30, 172.28.242.28, 172.28.242.25, 172.28.242.24, 172.28.242.29, 172.28.242.30, cem, cmtg, gsec.ott7gvm1.genband.com, gvm, gvweb.ott7gvm1.genband.com.

When I access my website using Firefox 62.4 (on WIndows 8.1) and URL https://172.28.242.25:2443, I get the login page without any warnings. However, using https://gsec.ott7gvm1.genband.com:2443 results in the following warning -- Note that other browsers, IE and Chrome works without this warning.


gsec.ott7gvm1.genband.com:2443 uses an invalid security certificate.

The certificate is only valid for the following names: 172.28.242.30, 172.28.242.28, 172.28.242.25, 172.28.242.24, 172.28.242.29, 172.28.242.30, 172.28.242.28, 172.28.242.25, 172.28.242.24, 172.28.242.29, 172.28.242.30, cem, cmtg, gsec.ott7gvm1.genband.com, gvm, gvweb.ott7gvm1.genband.com Error code: SSL_ERROR_BAD_CERT_DOMAIN


I am at a loss to understand the root cause of this issue . I tried uninstalling / re-installing Firefox and renaming cert9.db with much luck.


BEGIN CERTIFICATE-----

MIIGizCCBHOgAwIBAgICEAAwDQYJKoZIhvcNAQELBQAwgY8xCzAJBgNVBAYTAkNB MRAwDgYDVQQIDAdPbnRhcmlvMR4wHAYDVQQKDBVSaWJib24gQ29tbXVuaWNhdGlv bnMxKTAnBgNVBAsMIFJpYmJvbiBDMjAgQ2VydGlmaWNhdGUgQXV0aG9yaXR5MSMw IQYDVQQDDBpSaWJib24gQzIwIEludGVybWVkaWF0ZSBDQTAeFw0xODA5MTQwMzA2 MTFaFw0yODEyMjAwMzA2MTFaMF0xCzAJBgNVBAYTAkNBMQswCQYDVQQIDAJPTjEP MA0GA1UEBwwGT3R0YXdhMQ8wDQYDVQQKDAZSaWJib24xETAPBgNVBAsMCFNlY3Vy aXR5MQwwCgYDVQQDDANndm0wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIB AQDdXoa40UF6a2FGZF1qOaBvLq/KXpeDeiNH3lcGvc5poUjZmOIO29GbpNfPzw67 a1dTtleURSeDDD/5jTIoA33/gNLpSTgUODNBKlCS4KJZNs2mJwfFAlRN7adIn/yi aPIHou0iFA3NtK/U41Fau/fEo6CJRehiPdUTpvsCMISICJYcQvywly4N1bynZlLm 3VCfgmvvSJKvUGWmukCUwDz7zIJ9Iy6NypEqvcFL4taa9BTKCj/t+VaByenxnGm9 Lawy99lPGn1lMU16BA6ZroSJdyYctJXD/Ba6NHTGkOp7R+dX+vvId2Ax3uUBdLaF cXwYmfV48CtWtXMn2BAzI8AhAgMBAAGjggIgMIICHDAJBgNVHRMEAjAAMBEGCWCG SAGG+EIBAQQEAwIGQDAzBglghkgBhvhCAQ0EJhYkT3BlblNTTCBHZW5lcmF0ZWQg U2VydmVyIENlcnRpZmljYXRlMB0GA1UdDgQWBBS/lnccheoSdMSAcI3RZ6HQ/yIt ZjCBtQYDVR0jBIGtMIGqgBShJAKvPFFkDVHb29yQNKcpc+vSeKGBjaSBijCBhzEL MAkGA1UEBhMCQ0ExEDAOBgNVBAgMB09udGFyaW8xHjAcBgNVBAoMFVJpYmJvbiBD b21tdW5pY2F0aW9uczEpMCcGA1UECwwgUmliYm9uIEMyMCBDZXJ0aWZpY2F0ZSBB dXRob3JpdHkxGzAZBgNVBAMMElJpYmJvbiBDMjAgUm9vdCBDQYICEAAwDgYDVR0P AQH/BAQDAgWgMBMGA1UdJQQMMAoGCCsGAQUFBwMBMIHKBgNVHREEgcIwgb+HBKwc 8h6HBKwc8hyHBKwc8hmHBKwc8hiHBKwc8h2CDTE3Mi4yOC4yNDIuMzCCDTE3Mi4y OC4yNDIuMjiCDTE3Mi4yOC4yNDIuMjWCDTE3Mi4yOC4yNDIuMjSCDTE3Mi4yOC4y NDIuMjmCDTE3Mi4yOC4yNDIuMzCCA2NlbYIEY210Z4IZZ3NlYy5vdHQ3Z3ZtMS5n ZW5iYW5kLmNvbYIDZ3ZtghpndndlYi5vdHQ3Z3ZtMS5nZW5iYW5kLmNvbTANBgkq hkiG9w0BAQsFAAOCAgEAMzOSS46TlO9PNPWgAUyaYCYDsFzvVC7gCk6ne2x2z3v6 qfyaANw0a4h2ItQf4CymQ6I9X52LN80u4oc7qF+fW+zDdhiHMx8swGv31h8KiRKu 9fHZrCMWLWJFFHVtnuooK+wMQUWaRbsQDu94EBqmyE66Xg+Gg2cMGqGJ3Oko40kT xaYVogvvIzKqVN6z+h0FjetH9UrmlLAYu+LMem+TD5ddPcDOnKIPUnK6E136xqN9 H2u3pTjRf0aDEIUOj5fTGl5NDRxUSqSqWWlARTd+LkqF/sVi6WHh8qCaEeAOEsvz 8cRLqstV6ZEptXD7cbio2oO8ziGEEW8uLqxMjikesL3GC+D67JyD9NwuuKsalKGR r9+4S1nGhTuZy5BxbRRNbTkzh/gxMkGBHgFJz4fsn4dOX1eF9ZhKDBJdomqV0h91 fcnovlIR6y12a1ZKxo20yFYnmT3g1rW1BoDNVy/8Ob/MsZqWpQLRaZ85gCfsFGDn tc6R5N6FKDUZy0hJosuzFiFxeUHy9sXddc0BZPAswsawHWBn3rDNH/iRH/EHi3G2 bH4Ua5e6KcODjAImQaMPWgtRV8P2iSVAwShEPlbVMyA2uSDmra6g3mXGOBI4VuWS VC0g0wv2H8AdkMR0DdgTFs/JvJtSBwMFWsLKqmRac454F1zPALLNsOKNOdziTW4=


END CERTIFICATE-----

Stillet af lalirat for 2 år siden

Seneste svar af lalirat for 2 år siden

  • Løst
  • Arkiveret

"select device" does not show in rdm

Firefox 64.0 on Windows 10. When RDM is invoked, the box where you can select a device is NOT SHOWING. I saw one post where it was suggested to open Browser Control, and … (læs mere)

Firefox 64.0 on Windows 10. When RDM is invoked, the box where you can select a device is NOT SHOWING.

I saw one post where it was suggested to open Browser Control, and there are errors shown. I just do not know what they mean or how to proceed.

Can anyone help? TIA! André

The message shown is:

[2018-12-11T18:26:21.995Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/gb4hho3chcad4bp5um2eouhyhrmdr496/httpsscan background.js:34:9 [2018-12-11T18:26:22.036Z] Request status: 2 background.js:34:9 [2018-12-11T18:26:22.040Z] Request status: 3 background.js:34:9 [2018-12-11T18:26:22.042Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:9 [2018-12-11T18:26:22.043Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:9 Use of nsIFile in content process is deprecated. NetUtil.jsm:266:12 [2018-12-11T18:26:23.954Z] Details: {"requestId":"1809","url":"https://www.mozilla.org/media/css/BUNDLES/protocol-core.cc4e6306808b.css","originUrl":"https://www.mozilla.org/en-US/","documentUrl":"https://www.mozilla.org/en-US/","method":"GET","type":"stylesheet","timeStamp":1544552783952,"frameId":0,"parentFrameId":-1,"proxyInfo":null,"ip":null,"frameAncestors":[],"tabId":1} background.js:34:9 [2018-12-11T18:26:23.957Z] requestId: 1809 background.js:34:9 uncaught exception: 2147500033 browser.xml:1048:13 [Exception... "Method not implemented'Method not implemented' when calling method: [nsIWebNavigation::sessionHistory]" nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)" location: "JS frame :: chrome://global/content/bindings/browser.xml :: construct :: line 1048" data: no] construct chrome://global/content/bindings/browser.xml:1048:13 start resource://devtools/client/responsive.html/browser/tunnel.js:179:7 InterpretGeneratorResume self-hosted:1255:8 next self-hosted:1210:9 start resource://devtools/client/responsive.html/browser/swap.js:217:13 InterpretGeneratorResume self-hosted:1255:8 next self-hosted:1210:9 [2018-12-11T18:26:32.996Z] Details: {"requestId":"1810","url":"https://www.mozilla.org/favicon.ico","originUrl":"https://www.mozilla.org/en-US/","documentUrl":"https://www.mozilla.org/en-US/","method":"GET","type":"image","timeStamp":1544552792969,"frameId":0,"parentFrameId":-1,"proxyInfo":null,"ip":null,"frameAncestors":[],"tabId":1} background.js:34:9 [2018-12-11T18:26:33.008Z] requestId: 1810 background.js:34:9 [2018-12-11T18:26:33.099Z] Details: {"requestId":"1811","url":"https://www.mozilla.org/media/img/favicon/favicon-196x196.c80e6abe0767.png","originUrl":"https://www.mozilla.org/en-US/","documentUrl":"https://www.mozilla.org/en-US/","method":"GET","type":"image","timeStamp":1544552793080,"frameId":0,"parentFrameId":-1,"proxyInfo":null,"ip":null,"frameAncestors":[],"tabId":1} background.js:34:9 [2018-12-11T18:26:33.099Z] Details: {"requestId":"1812","url":"https://www.mozilla.org/media/img/favicon.d4f1f46b91f4.ico","originUrl":"https://www.mozilla.org/en-US/","documentUrl":"https://www.mozilla.org/en-US/","method":"GET","type":"image","timeStamp":1544552793082,"frameId":0,"parentFrameId":-1,"proxyInfo":null,"ip":null,"frameAncestors":[],"tabId":1} background.js:34:9 this.nativeTab.linkedBrowser is null ext-browser.js:765 [2018-12-11T18:26:33.391Z] requestId: 1811 background.js:34:9 [2018-12-11T18:26:33.392Z] requestId: 1812 background.js:34:9 this.nativeTab.linkedBrowser is null ext-browser.js:765 [2018-12-11T18:26:51.997Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/gb4hho3chcad4bp5um2eouhyhrmdr496/httpsscan background.js:34:9 [2018-12-11T18:26:52.039Z] Request status: 2 background.js:34:9 [2018-12-11T18:26:52.042Z] Request status: 3 background.js:34:9 [2018-12-11T18:26:52.042Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:9 [2018-12-11T18:26:52.042Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:9 [2018-12-11T18:27:22.000Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/gb4hho3chcad4bp5um2eouhyhrmdr496/httpsscan background.js:34:9 [2018-12-11T18:27:22.013Z] Request status: 2 background.js:34:9 [2018-12-11T18:27:22.015Z] Request status: 3 background.js:34:9 [2018-12-11T18:27:22.015Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:9 [2018-12-11T18:27:22.015Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:9 [2018-12-11T18:27:52.002Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/gb4hho3chcad4bp5um2eouhyhrmdr496/httpsscan background.js:34:9 [2018-12-11T18:27:52.023Z] Request status: 2 background.js:34:9 [2018-12-11T18:27:52.024Z] Request status: 3 background.js:34:9 [2018-12-11T18:27:52.025Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:9 [2018-12-11T18:27:52.025Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:9

Stillet af Andre4 for 1 år siden

Besvaret af cor-el for 1 år siden

  • Arkiveret

Android Apk is not downloading

Hi All, We have android app that customers can download directly from WordPress website. It works perfectly fine on google chrome, but does not on Firefox, both mobile an… (læs mere)

Hi All, We have android app that customers can download directly from WordPress website. It works perfectly fine on google chrome, but does not on Firefox, both mobile and PC. When you are trying to download the file, the browser opens it instead and shows bunch of random text. https://pasteboard.co/HLKQzA4.png Any ideas how to fix it please?

Stillet af YanaQuark for 1 år siden

Seneste svar af TyDraniu for 1 år siden

  • Løst
  • Arkiveret

Developer Tools-Style Editor_change selected code text color

This is about Style Editor, which uses different code for styling. The colors used in browser toolbox (Ctrl + Shft + Alt + I) *Style Editor* uses Code Mirror selectors. … (læs mere)

This is about Style Editor, which uses different code for styling. The colors used in browser toolbox (Ctrl + Shft + Alt + I) *Style Editor* uses Code Mirror selectors. Due to less than perfect sight & the poor visibility / contrast colors of found search terms & several other things in Style Editor, I needed to change things.

I didn't have too much problem finding most of CM's CSS selectors for what I needed. In all the CSS files associated with code mirror in the dark theme, I haven't found how to change the foreground (text) color when selecting lines or sections of code.

In Linux, Style Editor's default selected background is almost the same as the body BG color (looking at the hex colors used, and just visually. This from codemirror.css in omni.ja, changes selected, unfocused background: .CodeMirror-selected {

 background: #D4E7F9 !important;

This changes the selected, focused BG color: .CodeMirror-line::selection, .CodeMirror-line > span::selection, .CodeMirror-line > span > span::selection {

  background-color: #E9ECD8 !important; }

But I've found nothing for foreground "color," to make the selected text legible through the light selected BG color I chose. Just adding "color: #0000FF !important;" - under the background property doesn't work (like many CSS styled UIs - especially text editors).

Is it possible that Code Mirror doesn't have a way to change the text color on selected areas? Most text editors I've tested usually have preference menu settings for things like selected - foreground & BG color. Or they have themes that add extra UI styling ability. The themes on code mirror's site don't seem to use selected foreground color (or just "color"). Maybe it doesn't understand that concept.

If the highlight BG color chosen for CM is fairly light with some transparency, you can read some darker syntax colors, but not all.

Using another text editor with better search, I looked & searched all files I could find that control some of Style Editor's / code mirror's colors.

The only thing I found where I could change selected text color was one rule for searching in Style Editor. It's in codemirror.css ... and it doesn't work that consistently for visibility. /chrome/devtools/content/shared/sourceeditor/codemirror/lib/codemirror.css

The default colors (someone) used for search term matches have little contrast.

LINE 330: .cm-searching {

 background-color: rgba(255, 255, 170, 0.6) !important; /* The 1st BG value listed is for focused search result highlight.*/
 color: #0808E5 !important;
 background-color: rgba(2226, 253, 251, .6) !important; }

NOTE: I added the color property in ".cm-searching" - and it worked. Same trick doesn't work for any selection rules I tried. Codemirror's online manual is fairly spartan https://codemirror.net/doc/manual.html#styling

Stillet af Joebt for for 7 måneder siden

Besvaret af Joebt for for 6 måneder siden

  • Arkiveret

How can I emulate media queries after Developer Toolbar has been removed?

The title says it all: After the Developer Toolbar has been removed in Firefox v62, how do I emulate media queries, like "print"? And how do I reset this setting? Just fo… (læs mere)

The title says it all:

After the Developer Toolbar has been removed in Firefox v62, how do I emulate media queries, like "print"? And how do I reset this setting?

Just for your information in case your are in doubt about my question: While the Developer Toolbar was active, the Developer Toolbar command for setting media emulation to print was "media emulate print". The command for resetting the media type was "media reset".

Your answer is appreciated.

Stillet af Alman for 2 år siden

Seneste svar af Alman for 1 år siden

  • Løst

New CSS styles not picked in Firefox.

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren'… (læs mere)

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren't displayed in the web page nor in the developer tools inspector.

They are visible in Chromium browser and dev tools.

I have cleared the cache and refreshed the page to no avail. It is only when I restart the browser that the new style rules take effect in the browser and show up in the dev tools.

Stillet af mt3ch for for 2 måneder siden

Besvaret af cor-el for for 2 måneder siden