Viser spørgsmål med mærkatet: Vis alle spørgsmål
  • Løst

Opening Firefox on Debian 12 stable forces the home directory to remount as read-only

I woke up this morning to my home directory having been remounted as read-only (it has its own dedicated hard drive at /dev/sdd1). I ran e2fsck and things looked good, so… (læs mere)

I woke up this morning to my home directory having been remounted as read-only (it has its own dedicated hard drive at /dev/sdd1). I ran e2fsck and things looked good, so I restarted and things were fine again.

However, whenever I open Firefox, it hangs for about 1 full minute before it goes haywire and renders the entire system essentially unusable since being able to access my home directory is vital. The following is visible in dmesg:

[ 2710.362946] Aborting journal on device sdd1-8. [ 2710.363000] EXT4-fs warning (device sdd1): ext4_end_bio:343: I/O error 5 writing to inode 10520593 starting block 44134769) [ 2710.363008] Buffer I/O error on device sdd1, logical block 44134513 [ 2710.363041] EXT4-fs error (device sdd1): ext4_journal_check_start:84: comm glean.dispatche: Detected aborted journal [ 2710.363048] EXT4-fs warning (device sdd1): ext4_dx_find_entry:1795: inode #9718667: lblock 2: comm Renderer: error -5 reading directory block [ 2710.363076] EXT4-fs warning (device sdd1): htree_dirblock_to_tree:1082: inode #9701223: lblock 1: comm Cache2 I/O: error -5 reading directory block [ 2710.800016] EXT4-fs warning (device sdd1): ext4_dirblock_csum_verify:405: inode #9976467: comm BgIOThr~ool #12: No space for directory leaf checksum. Please run e2fsck -D. [ 2710.812447] EXT4-fs warning (device sdd1): ext4_dirblock_csum_verify:405: inode #9976467: comm Backgro~Pool #1: No space for directory leaf checksum. Please run e2fsck -D. [ 2710.884557] EXT4-fs warning (device sdd1): ext4_dirblock_csum_verify:405: inode #9976467: comm Backgro~Pool #1: No space for directory leaf checksum. Please run e2fsck -D. [ 2710.980923] EXT4-fs (sdd1): Remounting filesystem read-only [ 2711.049635] EXT4-fs warning (device sdd1): ext4_dirblock_csum_verify:405: inode #9701223: comm Cache2 I/O: No space for directory leaf checksum. Please run e2fsck -D. [ 2711.152739] EXT4-fs warning (device sdd1): ext4_dirblock_csum_verify:405: inode #9701223: comm Cache2 I/O: No space for directory leaf checksum. Please run e2fsck -D. [ 2711.152757] EXT4-fs warning (device sdd1): ext4_dirblock_csum_verify:405: inode #9701223: comm Cache2 I/O: No space for directory leaf checksum. Please run e2fsck -D.

All other programs that I use daily do not cause this issue. No clue what to do here. LibreWolf works fine - that's what I'm using now that Firefox breaks everything and basically forces me to restart if I want to use my computer normally.

Stillet af noah for 5 dage siden

Besvaret af noah for 23 timer siden

  • Løst

IFRAME is not displayed

Dear friends, I have Firefox Browser 127.0 (64-bit) installed. IFRAME is not displayed on some websites. Example: https://www.rollerfreunde-untermain.de/gaeste.htm Att… (læs mere)

Dear friends,

I have Firefox Browser 127.0 (64-bit) installed. IFRAME is not displayed on some websites.

Example: https://www.rollerfreunde-untermain.de/gaeste.htm

Attached you will find a screen shot.

Can anyone say why this is the case?

Kind regards Uwe

Stillet af haller-mtl for 3 dage siden

Besvaret af TyDraniu for 3 dage siden

  • Løst

Firefox on Linux does not allow entries in forms that are called up in IFRAME.

Dear friends, Firefox on Linux does not allow entries in forms that are called up in IFRAME. It works perfectly on Android. Does anyone know why this is the case? Uwe … (læs mere)

Dear friends,

Firefox on Linux does not allow entries in forms that are called up in IFRAME. It works perfectly on Android.

Does anyone know why this is the case? Uwe

Firefox 127.0 (64-Bit)

Stillet af haller-mtl for 1 uge siden

Besvaret af jonzn4SUSE for 1 uge siden

  • Løst

Amazon loads slowly or not at all; all other sites are fine

Hi! I'm using Firefox 126.0 on Fedora 39. Pages from Amazon.co.uk load very slowly, incompletely, or not at all. All other Web sites are fine. I had a couple of certi… (læs mere)

Hi! I'm using Firefox 126.0 on Fedora 39.

Pages from Amazon.co.uk load very slowly, incompletely, or not at all. All other Web sites are fine.

I had a couple of certificate-related errors saying that the identity of the site couldn't be verified, but I can't reproduce the problem, so I can't quote the exact wording, I'm afraid.

The same Amazon pages load properly in Chrome on the same machine, and they load properly in Firefox in a VM on the same machine. That tells me network connectivity must be fine.

I've tried disabling all extensions, reverting to the default theme, running in Troubleshoot Mode, clearing cookies and site data, clearing the startup cache, disabling hardware acceleration, and creating a new profile. The new profile helps slightly, in that it loads more of the page before getting stuck. Nothing else helps at all.

I'd prefer not to refresh Firefox if I can avoid it, because I don't want to lose all my plugins and settings. This installation is five years old. Besides, a new profile didn't fix the problem.

What's the next thing to try? I'd really appreciate any ideas.

Stillet af markus.laker for 1 uge siden

Besvaret af markus.laker for 1 uge siden

  • Løst

Firefox manual update with Linux Ubuntu

I have a System 76 laptop running Ubuntu 14.04 LTS. The LTS (Long Term Support) ended years ago with Firefox 66. All of that works fine still. My problem is: 1. The worl… (læs mere)

I have a System 76 laptop running Ubuntu 14.04 LTS. The LTS (Long Term Support) ended years ago with Firefox 66. All of that works fine still. My problem is: 1. The world is telling me to upgrade my browser. 2. Mozilla tells me "Note: If you use your Linux distribution's packaged version of Firefox, you will need to wait for an updated package to be released to its package repository. This article only applies if you installed Firefox manually (without using your distribution's package manager)." 3. There will never be an updated package because LTS has ended. 4. IS THERE A WAY TO MANUALLY INSTALL A NEWER BROWSER LIKE FIREFOX 123?

Stillet af Jim for for 3 måneder siden

Besvaret af Jim for for 3 måneder siden

  • Løst

Domain uniformity no uniform

FireFox assumes that text size is the same for all pages in a domain, rferl.org for example. That is _not_ true. If I have set size to 50% and then take a link to a page … (læs mere)

FireFox assumes that text size is the same for all pages in a domain, rferl.org for example. That is _not_ true. If I have set size to 50% and then take a link to a page that's different and have to set size to 67% to read it, when I return to the original page, size is 67% and text is too large.

Stillet af Mark Filipak for 2 uger siden

Besvaret af TyDraniu for 2 uger siden

  • Løst

Bing Maps causes firefox to crash

When I open Firefox and call up bing maps , it starts to load the page , then Firefox crashes . Has been doing this for several firefox versions . Looking at the crash r… (læs mere)

When I open Firefox and call up bing maps , it starts to load the page , then Firefox crashes . Has been doing this for several firefox versions . Looking at the crash report , I always get "The debug symbols are missing for firefox. Please install firefox-dbg." but I can't find firefox-dbg to load

Stillet af jones2347 for 3 uger siden

Besvaret af jones2347 for 2 uger siden

  • Løst

Media resource could not be decoded, error: Error Code: NS_ERROR_DOM_MEDIA_METADATA_ERR (0x806e0006)

A recent set of system updates appears to have made most website videos not play in Firefox. When I inspect the Developer Tools - > Console tab the most detail Firefo… (læs mere)

A recent set of system updates appears to have made most website videos not play in Firefox.

When I inspect the Developer Tools - > Console tab the most detail Firefox gives are an error line similar to: Media resource URL could not be decoded, error: Error Code: NS_ERROR_DOM_MEDIA_METADATA_ERR (0x806e0006)

Internet searches for the error name and error hex do not appear yield any applicable troubleshooting, nor any methods of collecting additional problem data.

How can I obtain more detail on where the error is happening and how Firefox might be interacting with other packages present on my system?

Arch Linux has some older ffmpeg-compat packages, but those don't appear to match any of the web results, in that they're even older versions of ffmpeg.

yay -Ss ffmpeg-compat aur/ffmpeg-compat-55 2.3.6-4 (+24 0.00)

   Compatibility package for ffmpeg to provide versions 55 of libavcodec, libavdevice and libavformat, not anymore provided by the ffmpeg package

aur/ffmpeg-compat-54 1.2.12-4 (+87 0.00)

   Compatibility package for ffmpeg to provide versions 54 of libavcodec, libavdevice and libavformat, not anymore provided by the ffmpeg package

Stillet af mjevans for for 1 måned siden

Besvaret af mjevans for 2 uger siden

  • Løst

Establishing a WebRTC connection from the Firefox browser (VP8 inactive)

Hello, maybe someone else seen the same issue. When trying to establish a webrtc connection with the Firefox browser, my server sends a following message (video H264): ``… (læs mere)

Hello, maybe someone else seen the same issue. When trying to establish a webrtc connection with the Firefox browser, my server sends a following message (video H264): ``` 0:00:01.701967159 90 0x7fc2a0002030 LOG webrtcsrc-signaller net/webrtc/src/signaller/imp.rs:172:gstrswebrtc::signaller::imp::Signaller::connect::{{closure}}::{{closure}}: Sending websocket message Peer(PeerMessage { session_id: "56a17f8d-2585-4d4b-9f2e-3009450a19e9", peer_message: Sdp(Offer { sdp: "v=0\r\no=- 9144757257615355393 0 IN IP4 0.0.0.0\r\ns=-\r\nt=0 0\r\na=ice-options:trickle\r\na=group:BUNDLE video0 audio1 application2\r\nm=video 9 UDP/TLS/RTP/SAVPF 96 98 99 100 101\r\nc=IN IP4 0.0.0.0\r\na=setup:actpass\r\na=ice-ufrag:uOJFtPAyRCKX4NDQcU3VExzLsFcfCWYc\r\na=ice-pwd:jRots1p0FnmxmwLoVqAq7lK84rAwBk/4\r\na=rtcp-mux\r\na=rtcp-rsize\r\na=sendonly\r\na=rtpmap:96 H264/90000\r\na=rtcp-fb:96 nack\r\na=rtcp-fb:96 nack pli\r\na=rtcp-fb:96 ccm fir\r\na=rtcp-fb:96 transport-cc\r\na=fmtp:96 packetization-mode=1;profile-level-id=42001f;level-asymmetry-allowed=1\r\na=rtpmap:98 red/90000\r\na=rtpmap:99 ulpfec/90000\r\na=rtpmap:100 rtx/90000\r\na=fmtp:100 apt=96\r\na=rtpmap:101 rtx/90000\r\na=fmtp:101 apt=98\r\na=ssrc-group:FID 2834502081 1415006916\r\na=ssrc:2834502081 msid:user1488703113@host-437c139 webrtctransceiver0\r\na=ssrc:2834502081 cname:user1488703113@host-437c139\r\na=ssrc:1415006916 msid:user1488703113@host-437c139 webrtctransceiver0\r\na=ssrc:1415006916 cname:user1488703113@host-437c139\r\na=mid:video0\r\na=fingerprint:sha-256 9E:33:DF:EB:63:72:42:77:49:8D:0C:0E:FC:61:51:C1:56:53:AF:05:D9:F7:61:8F:95:DD:7D:FF:99:1A:64:E8\r\na=rtcp-mux-only\r\nm=audio 0 UDP/TLS/RTP/SAVPF 97\r\nc=IN IP4 0.0.0.0\r\na=setup:actpass\r\na=ice-ufrag:uOJFtPAyRCKX4NDQcU3VExzLsFcfCWYc\r\na=ice-pwd:jRots1p0FnmxmwLoVqAq7lK84rAwBk/4\r\na=bundle-only\r\na=rtcp-mux\r\na=rtcp-rsize\r\na=sendonly\r\na=rtpmap:97 OPUS/48000/2\r\na=rtcp-fb:97 transport-cc\r\na=fmtp:97 sprop-stereo=1;sprop-maxcapturerate=48000\r\na=ssrc:1127273264 msid:user1488703113@host-437c139 webrtctransceiver1\r\na=ssrc:1127273264 cname:user1488703113@host-437c139\r\na=mid:audio1\r\na=fingerprint:sha-256 9E:33:DF:EB:63:72:42:77:49:8D:0C:0E:FC:61:51:C1:56:53:AF:05:D9:F7:61:8F:95:DD:7D:FF:99:1A:64:E8\r\na=rtcp-mux-only\r\nm=application 0 UDP/DTLS/SCTP webrtc-datachannel\r\nc=IN IP4 0.0.0.0\r\na=setup:actpass\r\na=ice-ufrag:uOJFtPAyRCKX4NDQcU3VExzLsFcfCWYc\r\na=ice-pwd:jRots1p0FnmxmwLoVqAq7lK84rAwBk/4\r\na=bundle-only\r\na=mid:application2\r\na=sctp-port:5000\r\na=fingerprint:sha-256 9E:33:DF:EB:63:72:42:77:49:8D:0C:0E:FC:61:51:C1:56:53:AF:05:D9:F7:61:8F:95:DD:7D:FF:99:1A:64:E8\r\n" }) }) ``` and Firefox responds with VP8 inactive message: ``` 0:00:02.007638187 90 0x7fc2a0002030 TRACE webrtcsrc-signaller net/webrtc/src/signaller/imp.rs:324:gstrswebrtc::signaller::imp::Signaller::handle_message:<GstWebRTCSignaller@0x563ce91ed190> Received message {"type": "peer", "sessionId": "56a17f8d-2585-4d4b-9f2e-3009450a19e9", "sdp": {"type": "answer", "sdp": "v=0\r\no=mozilla...THIS_IS_SDPARTA-99.0 2114996636650547664 0 IN IP4 0.0.0.0\r\ns=-\r\nt=0 0\r\na=sendrecv\r\na=fingerprint:sha-256 16:EC:66:ED:36:A1:D4:E0:CB:95:24:4A:E2:40:CA:53:E5:AB:D5:FF:F5:9C:5C:81:EB:83:F8:E4:BD:89:9F:03\r\na=ice-options:trickle\r\na=msid-semantic:WMS *\r\nm=video 0 UDP/TLS/RTP/SAVPF 120\r\nc=IN IP4 0.0.0.0\r\na=inactive\r\na=mid:video0\r\na=rtpmap:120 VP8/90000\r\nm=audio 9 UDP/TLS/RTP/SAVPF 97\r\nc=IN IP4 0.0.0.0\r\na=recvonly\r\na=fmtp:97 maxplaybackrate=48000;stereo=1;useinbandfec=1\r\na=ice-pwd:d5a493a07b92e452116a851e083e1c78\r\na=ice-ufrag:721f69a3\r\na=mid:audio1\r\na=rtcp-mux\r\na=rtpmap:97 opus/48000/2\r\na=setup:active\r\na=ssrc:3561002322 cname:{bb14ec44-0966-49c0-bccb-5e6242dd83d7}\r\nm=application 9 UDP/DTLS/SCTP webrtc-datachannel\r\nc=IN IP4 0.0.0.0\r\na=sendrecv\r\na=ice-pwd:d5a493a07b92e452116a851e083e1c78\r\na=ice-ufrag:721f69a3\r\na=mid:application2\r\na=setup:active\r\na=sctp-port:5000\r\na=max-message-size:1073741823\r\n"}} ``` which leads to: ``` 0:00:02.007849785 90 0x7fc2a0002030 WARN webrtcsink net/webrtc/src/webrtcsink/imp.rs:3238:gstrswebrtc::webrtcsink::imp::BaseWebRTCSink::handle_sdp_answer: consumer from session 56a17f8d-2585-4d4b-9f2e-3009450a19e9 refused media 0: Some("m=video 0 UDP/TLS/RTP/SAVPF 120\r\nc=IN IP4 0.0.0.0\r\na=inactive\r\na=mid:video0\r\na=rtpmap:120 VP8/90000\r\n") ``` and a connection close.

Why Firefox could respond with VP8 to the H264 request?

Stillet af Robert Ayrapetyan for 3 uger siden

Besvaret af Robert Ayrapetyan for 3 uger siden

  • Løst
  • Arkiveret

Some language fonts are not rendering

Recently, I switched to Fedora 39. At first, Firefox was working fine, but after I logged into my Firefox account, the fonts of some languages stopped rendering, and this… (læs mere)

Recently, I switched to Fedora 39. At first, Firefox was working fine, but after I logged into my Firefox account, the fonts of some languages stopped rendering, and this started happening with almost every site that was using system fonts.

Stillet af Sourav Kumar Paul for for 6 måneder siden

Besvaret af cor-el for for 6 måneder siden

  • Løst

Wrong focus when right-clicking on a bookmark (126.0 for Linux Mint)

Since the latest update, when I right-click on a bookmark or an item in the history list (from the menu or the bookmarks toolbar), I still get the menu that has items lik… (læs mere)

Since the latest update, when I right-click on a bookmark or an item in the history list (from the menu or the bookmarks toolbar), I still get the menu that has items like "Open in new tab" or "Edit Bookmark".

However, the focus for the mouse stays on the previous menu, so that I can't click on anything in the "right-click menu", instead it is interpreted as a click in some random item in the previous menu.

Going into troubleshoot mode didn't help, so I don't think it's my configuration causing this.

Stillet af christinetobler for 3 uger siden

Besvaret af jonzn4SUSE for 3 uger siden

  • Løst

I am not able to import my bookmarks from HTML though I have exported them in a HTML file

Hey, I have previously exported my bookmarks in an HTML file. When reinstalling Firefox, I tried to import them using the HTML backup file. It says that 309 bookmarks ha… (læs mere)

Hey,

I have previously exported my bookmarks in an HTML file. When reinstalling Firefox, I tried to import them using the HTML backup file. It says that 309 bookmarks have been found, but nothing changes on the bookmarks bar, still showing the "Import bookmarks" bookmark. These are very important bookmarks I would really like to get back, can you help me please ?

Stillet af Daphné Lambert for 3 uger siden

Besvaret af Daphné Lambert for 3 uger siden

  • Løst

Language in menu of FF 126.0 is mixed up

Hello, I have a problem: After an automatic update of the language packs, parts of the Firefox menu (version 126.0) are displayed in EN. Parts in DE. Seems to be related… (læs mere)

Hello, I have a problem: After an automatic update of the language packs, parts of the Firefox menu (version 126.0) are displayed in EN. Parts in DE. Seems to be related to the update... how can I change this again? I have already changed the language settings. Didn't help...it appeared after an automatic update on May 28. Thanks for an idea :)

Stillet af fibroblast for 3 uger siden

Besvaret af Paul for 3 uger siden

  • Løst

drag and drop url to bookmarks bar not working with >100% default page zoom

I was in the middle of asking this question when I fixed (worked around) the problem so I'm posting more as a informative post as there is a lot of old misdirection out t… (læs mere)

I was in the middle of asking this question when I fixed (worked around) the problem so I'm posting more as a informative post as there is a lot of old misdirection out there now.

I am(was) unable to drag any URLs from the URI drop down field in the main interface to my bookmarks toolbar. Nor was any drag and drop functionality working in the "Customise Firefox" screen (right click space on url bar -> Customise Toolbar).

I have now found that resetting my zoom setting in preferences to 100% restores this functionality. The problem arose when I was using 120% zoom, NOT text only.

Stillet af 4t0m1c4 for 3 uger siden

Besvaret af TyDraniu for 3 uger siden

  • Løst

Tab dragging stops working at random times

Sometimes drag functionality stops working. I can't grab a tab to move it to another position or to a new window. (Holding left click on the tab and moving the cursor doe… (læs mere)

Sometimes drag functionality stops working. I can't grab a tab to move it to another position or to a new window. (Holding left click on the tab and moving the cursor does nothing). Also, re-merging the tab with another firefox window stops working. (Dragging a tab to a firefox window from another firefox window doesn't merge them. It does nothing) I can right click on the tab and select Move to move it to a new window but dragging stops working. I have to close Firefox and start it again (sometimes twice), then dragging starts working again. This happens multiple times a day. I am on Linux Mint and the version is 126.0 (64-bit). This problematic behavior has only recently began.

Stillet af tenkayr for 3 uger siden

Besvaret af TyDraniu for 3 uger siden

  • Løst

multi-account containers as part of "home page" tabs - open without confirmation

I've got my "homepage and new windows" setting set up with several "ext+container links so that my selected websites open in their respective containers : e.g. ext+… (læs mere)

I've got my "homepage and new windows" setting set up with several "ext+container links so that my selected websites open in their respective containers : e.g. ext+container:name=Personal&url=https%3A%2F%2Fwww.facebook.com%2F%3Fsk%3Dh_nor

I open facebook in 2 seperate containers so that I can maintain 2 seperate personalities under facebook - e.g. I am a group admin within one, just a group member in another.

I have 2 urls defined in my "homepage and new windows" setting for these :

ext+container:name=Personal&url=https%3A%2F%2Fwww.facebook.com%2F%3Fsk%3Dh_nor ext+container:name=Facebook&url=https%3A%2F%2Fwww.facebook.com%2F%3Fsk%3Dh_nor

This was working fine without any issues. My sites opened up when I started my web browser and everything.

Recently, firefox has started up but my container tabs do not load automatically, I am getting a confirmation (I will post a screen capture as a comment).

Is there a way to turn this off and just open the tabs without a confirmation?

Stillet af geolaw for for 5 måneder siden

Besvaret af zeroknight for for 5 måneder siden

  • Løst

Can no longer detach tabs in Firefox 126

Tab detachment was working fine until updating to Firefox 126. Now the tabs cannot be moved, detached or dragged to another window. In about:config, browser.tabs.allowT… (læs mere)

Tab detachment was working fine until updating to Firefox 126. Now the tabs cannot be moved, detached or dragged to another window.

In about:config, browser.tabs.allowTabDetach is set to true

Suggestions?

Stillet af Jeffery Small for for 1 måned siden

Besvaret af Jeffery Small for for 1 måned siden

  • Løst

My passwords are getting removed one by one... Why?

Sadly, I am now forced to leave firefox. My passwords are getting "forgotten" more and more each day. Did i get hacked? Few passwords like proton mail I don't actually ha… (læs mere)

Sadly, I am now forced to leave firefox. My passwords are getting "forgotten" more and more each day. Did i get hacked? Few passwords like proton mail I don't actually have anywhere else. Auto-Backup of firefox seems to be of the same day as the original??? So it loses the data then saves it twice? who designed this? I'm angry, not at firefox/mozilla. angry at myself for putting my trust in the first place. Chromium doesn't sync so it leaves me with chrome FFS. Does someone has a magic wand to recover the lost data? login.json is same day as original so not an option.

Stillet af romanash for for 1 måned siden

Besvaret af romanash for for 1 måned siden

  • Løst

Most sites will not connect due to security issues

I am running Firefox 126.0-1 on an Arch Linux system. Most websites are failing to connect for security reasons. Some sites, including google.com and nytimes.com, fail w… (læs mere)

I am running Firefox 126.0-1 on an Arch Linux system. Most websites are failing to connect for security reasons.

Some sites, including google.com and nytimes.com, fail with an "SEC_ERROR_UNKNOWN_ISSUER" error, and their certificates confirm that they are respectively issued by Google Trust Services LLC and DigiCert Inc.

The website archlinux.org errors with "MOZILLA_PKIX_ERROR_MITM_DETECTED", stating that "Software is Preventing Firefox From Safely Connecting to This Site", citing in particular ISRG Root X1 as the problem. The certificate confirms that it is issued by Let's Encrypt.

The website duckduckgo.com simply errors with "SEC_ERROR_PATH_LEN_CONSTRAINT_INVALID" and states "Secure Connection Failed"

I have confirmed in preferences that my proxy settings are set to "No proxy" and the problem persists across troubleshooting mode and making a new profile. I have also tried removing the cert9.db file in a given profile folder.

Stillet af david.carlip for for 1 måned siden

Besvaret af david.carlip for for 1 måned siden