The Firefox icon on my Task Bar only opens an ad "Get Firefox for Desktop" Need access to real start page.

I have a full current installation of Firefox, after a struggle to get Bing off my system (Win11) I briefly got back to a personalized start page which had a large text "… (læs mere)

I have a full current installation of Firefox, after a struggle to get Bing off my system (Win11) I briefly got back to a personalized start page which had a large text "Firefox" heading and allowed me to add apps in small boxes and click to start an app. That page has disappeared and all I get is the ad referred to in the title. How can I replace the ad with the page I can load with app icons?

Stillet af GregS for 22 timer siden

Ability to disable RTX HDR on selective sites?

Right now i love my HDR content in most scenarios, except on a few sites where its just bad. Is it possible to be able to block it on certain sites where you dont want to… (læs mere)

Right now i love my HDR content in most scenarios, except on a few sites where its just bad. Is it possible to be able to block it on certain sites where you dont want to apply it?

Stillet af Dajova for 1 dag siden

Seneste svar af Dajova for 1 dag siden

Lost bookmarks

Hello, Relevant system referenced below: MacBook Pro 2021 Mac OS 14.5 Firefox 126.0.1 (64-bit) Carbon Copy Cloner 6.1.11 (7673) I have a case of vanishing bookmarks. I… (læs mere)

Hello,

Relevant system referenced below:

MacBook Pro 2021 Mac OS 14.5 Firefox 126.0.1 (64-bit) Carbon Copy Cloner 6.1.11 (7673)

I have a case of vanishing bookmarks. I quit Firefox last evening with command-Q as I’ve done a thousand times before. When I launched it this morning I was greeted with Firefox with an empty Bookmarks Toolbar and “Getting started” message. I opened a Manage Bookmarks window and everything there was empty too. I found, as well, that all of my saved UIDs and passwords were gone except for three, two of which I haven’t used in months. Weird.

Next I opened Firefox Help and found information about Troubleshooting Mode; I restarted in troubleshooting mode but nothing had changed. After restarting in normal mode, I tried Restoring Bookmarks; I chose Manage Bookmarks from the dropdown and then clicked the button in the Library window. Restore showed only one file and it was created today with only 14 items. Selecting Choose File… showed Desktop with Old Firefox Data highlighted. In that folder was only w34y3u9y…628 folder. From there I selected bookmarkbackups and the only file there was bookmarks-2024-06-06_11…lz4, a file created at 3:33 today. I found the key4.db file and it was created at 3:33 today.


I have Carbon Copy Cloner and use it for a weekly backup to a remote SSD drive. There are a year's-worth or so of weekly backups on that device. I tried trashing Firefox and reinstalling it from last week’s backup. While this worked, it didn’t solve the issue; it was still like a fresh copy of Firefox with no bookmarks.

I’m hopeful that I can restore the bulk of the lost bookmarks from CCC but I have no clue as to which files/folders to restore and I don’t want to guess. If you think this is possible, please tell me which files or folders to replace. Should I delete the files to be replaced from the current system and if so where are they located? I’m comfortable using Terminal for basic purposes but need explicit directions for entering commands and navigating to locations or files.

Thanks for your time,

David

Stillet af wuzupdc for 2 uger siden

Seneste svar af wuzupdc for 22 timer siden

Development: Very specific problem with getting the caret position in a contenteditable div

Hello, I'm a web developer. I'm using the Firefox Developer Edition and currently working on a project that requires caret manipulation. I have this function right here t… (læs mere)

Hello, I'm a web developer. I'm using the Firefox Developer Edition and currently working on a project that requires caret manipulation. I have this function right here that fetches the caret's client rect: ``` function getCaretRect(): DOMRect | null {

 const sel = window.getSelection()
 if (!sel || sel.rangeCount === 0) return null
 const range = sel.getRangeAt(0)
 const rects = range.getClientRects()
 if (rects.length === 0) return null
 return rects[0]

} ``` Here is where the issue arises. Suppose I have a contenteditable div with two line breaks (no new lines), and the second line is smaller than the first one. If the caret is positioned somewhere that is further than the end of the second line, and I press the down arrow key, then left, for some reason the caret rect I get has all values set to zero, like this: `{ x: 0, y: 0, width: 0, height: 0, top: 0, right: 0, bottom: 0, left: 0 }` I will add an image to explain further.

I don't have this issue on Chromium based browsers, but cross browser support is important for me.

There is one more issue to do with caret manipulation which is how contenteditable divs are handled. On a Chromium based browser, if I have a parent div that's contenteditable, then another div that's not contenteditable (contenteditable="false" explicitly), then two children divs which are both contenteditable (or more), I can navigate through the divs freely using the arrow keys and focus is managed better alongside event handlers. This is not present on Firefox, however.

If this is not the right place to ask for help then please guide me where is more suitable.

Stillet af Rayane Benamre for 1 dag siden

Seneste svar af cor-el for 23 timer siden

Picture In Picture mode isnt sticky

Im using Ubuntu 22.04 LTS Intel cpu I7 9th gen NVIDIA gpu but i disabled it My problem is that the Picture in Picture mode isnt sticky if i press anything it vanishes fro… (læs mere)

Im using Ubuntu 22.04 LTS Intel cpu I7 9th gen NVIDIA gpu but i disabled it My problem is that the Picture in Picture mode isnt sticky if i press anything it vanishes from view.

Stillet af Mcmunhuu for 5 dage siden

Seneste svar af cor-el for 23 timer siden

Youtube videos load very slowly... if they load

For the last several weeks (can't give an exact date, but it's been more than just a couple weeks, less than a couple months), both my husband and I have had issues loadi… (læs mere)

For the last several weeks (can't give an exact date, but it's been more than just a couple weeks, less than a couple months), both my husband and I have had issues loading videos in FF. We both have the latest version of FF. I went thru "Fix common audio and video issues" and did all those things, as well as trying to load the videos in troubleshooting mode. Nothing has helped (tho now that i cleared all the cache, i'm gonna have to log back into all those websites :( ). Nothing else is problematic. Our internet connection is fine. In fact, my husband has resorted to using MS browser to watch videos--they load fine in that browser. I have no other idea what to do. Searching your database for "youtube videos load slow" only resulted in a couple hits with no resolution. Hopefully this isn't the third. thanks

Stillet af rileth1 for 2 dage siden

Seneste svar af rileth1 for 1 dag siden

Firefox opens up a second browser screen automatically when I am already in a website!

When I login to my main Firefox browser and then access a website within a short while the browser screen opens up again automatically. In other words, a second window w… (læs mere)

When I login to my main Firefox browser and then access a website within a short while the browser screen opens up again automatically. In other words, a second window which is very irritating. How can I stop this from happening?

Stillet af graemesmith300653 for for 4 måneder siden

Seneste svar af munrorod for 1 dag siden

Videos on YouTube will not load after Update

It started this morning (6/23/24) the page for a YouTube video will load but the video doesn't play. I have cleared the cookies and cache, shut the browser down, restarte… (læs mere)

It started this morning (6/23/24) the page for a YouTube video will load but the video doesn't play. I have cleared the cookies and cache, shut the browser down, restarted the computer, turned off all the extensions, and have turned off hardware acceleration. Nothing has changed, I can watch other videos on Firefox and Youtube work as normal on other browsers. Last night (6/22/26) before shutting down may computer for the night I had an update for Firefox and shut the browser so it could update. The image is of what the video section is displaying.

Stillet af Jason Worlock for 1 dag siden

audio no firefox

gente, o que aconteceu com o firefox (normal, beta e nightly) que não funciona mais áudio. já tentei de tudo para reconfigurar, baseado em tutoriais na web, porém não se … (læs mere)

gente, o que aconteceu com o firefox (normal, beta e nightly) que não funciona mais áudio. já tentei de tudo para reconfigurar, baseado em tutoriais na web, porém não se consegue mais ouvir áudio nos firefox.

Stillet af nelioj for 2 dage siden

Seneste svar af jonzn4SUSE for 1 dag siden

Bing "ate" my Firefox setup.

As a longtime user of Firefox, I had a nice setup where after the start page, clicking on the Firefox icon would take me to a page headed "Firefox" in large letters. On t… (læs mere)

As a longtime user of Firefox, I had a nice setup where after the start page, clicking on the Firefox icon would take me to a page headed "Firefox" in large letters. On that page I had placed the icons for my frequently used programs. Each of the small "icon boxes" had menus that would allow entering a URL so that when clicked, the desired app would open. I was exploring MS Bing, mostly because I like the pictures they put up each day. It looks as though a "new Improved" version of Bing brings along the new MS AI component. Together they seem to have removed my Firefox setup or hidden it where I can't retrieve it. By using Firefox settings, I was able to remove the Bing URL. Good riddance!, but can I retrieve my page of links to most-used programs? I don't know where to look for that. If I have to reconstruct it, how is that done. Or how can I start a replacement. Sincere thanks, Greg Schultz

Stillet af GregS for 1 dag siden

Seneste svar af James for 1 dag siden

SCORM modules hang on loadingn

Hi, I need to take part in a course that is delivered via moodle and that employs SCORM videos. After some modules I am experiencing an issue where firefox does not loa… (læs mere)

Hi,

I need to take part in a course that is delivered via moodle and that employs SCORM videos.

After some modules I am experiencing an issue where firefox does not load them anymore. When you try to load a module a spinner appears and stays there indefintely.

Initially, trying to reload the module could eventually unblock it. Now this is not possible anymore. Disabling the enhanced protection does not change the situation.

The modules work just fine with chromium.

Having firefox being a stopper for online learning resources is a real issue. Any help will be appreciated.

Stillet af sergio.callegari for 1 dag siden

Seneste svar af TyDraniu for 1 dag siden

YouTube playing videos super fast and/or skipping to the end

Lately YouTube playing videos have been playing super fast or skipping straight to the end. I mean, they are horribly fast. Things to know: I am posting here because… (læs mere)

Lately YouTube playing videos have been playing super fast or skipping straight to the end. I mean, they are horribly fast.

Things to know:

  • I am posting here because I can't determine whether browsers may have settings unique to them that I need to change. This also happens in Chrome, but not Edge.
  • I was recently forced to upgrade to Windows 11 - I can't say this issue happened exactly at that time, but fairly recently after the upgrade. I am running Windows 11 Pro.
  • This does NOT happen when playing in a private browser window, either Firefox or Chrome.
  • Having the Mozilla VPN on or off has no effect.
  • I am sure the playback speed is set to normal. I have tried changing the playback speed to anything but normal and then back to normal and the current video runs correctly UNTIL I play the next video.
  • This does not happen with Vimeo.
  • It does not happen in FF for Android.

Any questions, thoughts, or advice would be appreciated.

Stillet af StopTheInsanity for 1 dag siden

Seneste svar af StopTheInsanity for 1 dag siden

Separate Themes for Private Browsing

Is there a way to set a separate theme for the private browsing option? I like being able to visually distinguish between the normal browser and the private one, but enab… (læs mere)

Is there a way to set a separate theme for the private browsing option? I like being able to visually distinguish between the normal browser and the private one, but enabling a theme seems to set the same visuals for both.

If separate themes are not a thing, perhaps they could be added in a later update?

Thanks for all your time and effort.

Stillet af Manny for 3 dage siden

Seneste svar af Agent virtuel for 1 dag siden

Google Sign in's

Ive tried everything under the Sun to try to get rid of that Annoying ( Sign in with Google) out of my computer but nothing works ?? Is there a solution ?? I ca… (læs mere)

Ive tried everything under the Sun to try to get rid of that Annoying ( Sign in with Google) out of my computer but nothing works ?? Is there a solution ?? I cannot open most of my Sites with it there !! Anyone Please HELP !!

Stillet af particolor for 1 dag siden

Seneste svar af Agent virtuel for 1 dag siden

I did did buy a new PC, and i can't find my Password's and Bockmark's anymore?? They was saved in my Account but they got deleted how ?

I need a Backup from my Account because all my Passwords and Bookmarks are not there anymore. They was saved in my Account it work't allways well till yesterday ! … (læs mere)

I need a Backup from my Account because all my Passwords and Bookmarks are not there anymore. They was saved in my Account it work't allways well till yesterday !

Stillet af Musti 43 for 1 dag siden

Seneste svar af Paul for 1 dag siden

Continuity and virtual microphones not showing up

I've removed firefox and reinstalled but for some reason my IOS continuity microphone and my Loopback (Rogue amoeba) virtual devices no longer show in firefox but they sh… (læs mere)

I've removed firefox and reinstalled but for some reason my IOS continuity microphone and my Loopback (Rogue amoeba) virtual devices no longer show in firefox but they show up in firefox beta. Is there a setting that masks these devices off from the production branch?

Stillet af darren37 for 1 dag siden

Unable to process the backup file. This is what I get when I try to restore my backup bookmarks.

After uninstall and reinstall my Firefox i can't restore my bookmark. I used (CTRL+shift+b) and restore my file "JSONLZ4". But i have an error as "Unable to process the b… (læs mere)

After uninstall and reinstall my Firefox i can't restore my bookmark. I used (CTRL+shift+b) and restore my file "JSONLZ4". But i have an error as "Unable to process the backup file". I read your forum and test many things but nothing. I also used the https://www.jeffersonscher.com/ffu/bookbackreader.html,but it does not work? It prompts:failed JSON parsing: SyntaxError: Unexpected end of JSON input. I really need my bookmarks! How can I restore them?

Stillet af 万念依然 for 1 dag siden

Seneste svar af 万念依然 for 1 dag siden

Firefox not loading any webpage / crashes MozCrashReason: Shutdown hanging at step AppShutdownNetTeardown. Something is blocking the main-thread.

Hi, my firefox does not load any webpage no matter what Firefox profile I am using (created a new one for tests). I have a Win10 pc with Avast and Comodo installed, the … (læs mere)

Hi,

my firefox does not load any webpage no matter what Firefox profile I am using (created a new one for tests). I have a Win10 pc with Avast and Comodo installed, the system with the mentioned software and multiple different Firefox profiles was running since several years without problems.

A month ago I had the same issue with Firefox 126, which I guess was caused by a windows update, where I had trouble getting it installed. But after this (I had to increase the system reserved partition) Firefox was running without any problmes like before ...

Now no pages kan be load and always the crash monitor pops up.

AdapterDeviceID: 0x5916 AdapterDriverVersion: 30.0.100.9865 AdapterSubsysID: 224e17aa AdapterVendorID: 0x8086 Add-ons: formautofill%40mozilla.org:1.0.1,pictureinpicture%40mozilla.org:1.0.0,webcompat%40mozilla.org:125.1.0,default-theme%40mozilla.org:1.3,addons-search-detection%40mozilla.com:2.0.0,google%40search.mozilla.org:1.4,leo_ende_de%40search.mozilla.org:1.1,ecosia%40search.mozilla.org:1.2,wikipedia%40search.mozilla.org:1.3,bing%40search.mozilla.org:1.6,ddg%40search.mozilla.org:1.4,ebay%40search.mozilla.org:1.4 AvailablePageFile: 28210671616 AvailablePhysicalMemory: 6727372800 AvailableVirtualMemory: 138531126534144 BackgroundTaskMode: 0 BuildID: 20240606181944 CPUMicrocodeVersion: 0xf4 ContentSandboxCapable: 1 ContentSandboxLevel: 6 ContentSandboxWin32kState: Win32k Lockdown enabled -- default value is true CrashTime: 1719121467 DOMFissionEnabled: 1 DOMIPCEnabled: 1 EMCheckCompatibility: true GPUProcessLaunchCount: 1 GPUProcessStatus: Running GpuSandboxLevel: 1 HeadlessMode: 0 InstallTime: 1718671975 LastInteractionDuration: 76 LastStartupWasCrash: 0 LauncherProcessState: 0 ModuleSignatureInfo: {"Avast Software s.r.o.":["aswJsFlt.dll","snxhk.dll","aswhook.dll","AavmRpch.dll","aswCmnIS.dll","aswCmnOS.dll","dll_loader.dll","aswCmnBS.dll"],"Comodo Security Solutions, Inc.":["guard64.dll"],"Microsoft Windows":["CryptoWinRT.dll","d3d9.dll","windows.internal.shell.broker.dll","TaskFlowDataEngine.dll","linkinfo.dll","ntshrui.dll","thumbcache.dll","wpnapps.dll","Windows.StateRepositoryPS.dll","cdp.dll","explorerframe.dll","dataexchange.dll","edputil.dll","oleacc.dll","tiptsf.dll","GdiPlus.dll","cscapi.dll","twinapi.dll","ondemandconnroutehelper.dll","MSAudDecMFT.dll","mfperfhelper.dll","msmpeg2vdec.dll","winrnr.dll","pnrpnsp.dll","NapiNSP.dll","wscapi.dll","winmm.dll","wininet.dll","wsock32.dll","windows.staterepositorycore.dll","msdmo.dll","RTWorkQ.dll","mfplat.dll","ktmw32.dll","FWPUCLNT.DLL","OneCoreCommonProxyStub.dll","Windows.Security.Integrity.dll","comctl32.dll","Windows.ApplicationModel.dll","npmproxy.dll","directmanipulation.dll","Windows.Globalization.dll","DWrite.dll","srvcli.dll","urlmon.dll","Windows.UI.Immersive.dll","iertutil.dll","BCP47mrm.dll","InputHost.dll","dbgcore.dll","TextInputFramework.dll","Windows.UI.dll","MrmCoreR.dll","Bcp47Langs.dll","dhcpcsvc6.DLL","dhcpcsvc.dll","DXCore.dll","AppXDeploymentClient.dll","winnsi.dll","MP3DMOD.DLL","OneCoreUAPCommonProxyStub.dll","rasadhlp.dll","UIAnimation.dll","MMDevAPI.dll","AudioSes.dll","twinapi.appcore.dll","WindowManagementAPI.dll","ninput.dll","avrt.dll","ColorAdapterClient.dll","mscms.dll","xmllite.dll","nlaapi.dll","wshbth.dll","wtsapi32.dll","dsreg.dll","d3dcompiler_47.dll","d3d11.dll","WinTypes.dll","dcomp.dll","CoreUIComponents.dll","CoreMessaging.dll","policymanager.dll","netprofm.dll","apphelp.dll","dbghelp.dll","WindowsCodecs.dll","uxtheme.dll","resourcepolicyclient.dll","dwmapi.dll","rmclient.dll","windows.storage.dll","winhttp.dll","propsys.dll","kernel.appcore.dll","dxgi.dll","fwbase.dll","firewallapi.dll","profext.dll","rsaenh.dll","msvcp110_win.dll","ntmarta.dll","IPHLPAPI.DLL","netutils.dll","dnsapi.dll","mswsock.dll","cryptsp.dll","cryptbase.dll","wldp.dll","ntasn1.dll","ncrypt.dll","winsta.dll","msasn1.dll","fltLib.dll","version.dll","devobj.dll","umpdc.dll","powrprof.dll","sspicli.dll","userenv.dll","profapi.dll","bcrypt.dll","ucrtbase.dll","wintrust.dll","crypt32.dll","KERNELBASE.dll","cfgmgr32.dll","bcryptPrimitives.dll","msvcp_win.dll","win32u.dll","gdi32full.dll","user32.dll","imagehlp.dll","oleaut32.dll","ole32.dll","combase.dll","clbcatq.dll","nsi.dll","sechost.dll","shlwapi.dll","SHCore.dll","kernel32.dll","msvcrt.dll","gdi32.dll","rpcrt4.dll","advapi32.dll","ws2_32.dll","psapi.dll","shell32.dll","msctf.dll","setupapi.dll","imm32.dll","ntdll.dll"],"Microsoft Windows Software Compatibility Publisher":["msvcp140.dll","VCRUNTIME140.dll","VCRUNTIME140_1.dll","msvcp140.dll","VCRUNTIME140.dll","VCRUNTIME140_1.dll"],"Mozilla Corporation":["firefox.exe","xul.dll","gkcodecs.dll","libGLESv2.dll","nss3.dll","freebl3.dll","osclientcerts.dll","mozglue.dll","nssckbi.dll","softokn3.dll","lgpllibs.dll","libEGL.dll"]} MozCrashReason: Shutdown hanging at step AppShutdownNetTeardown. Something is blocking the main-thread. Notes: FP(D00-L1000-W0000100-T00) DWrite? DWrite+ WR? WR+ WebGL? EGL? EGL- GL Context? GL Context- GL Context+ WebGL+ ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox QuotaManagerStorageIsNetworkResource: 0 ReleaseChannel: release SafeMode: 0 SecondsSinceLastCrash: 1269 ShutdownProgress: profile-change-net-teardown ShutdownReason: AppClose StartupCacheValid: 1 StartupCrash: 0 StartupTime: 1719121150 SubmittedFrom: Client SystemMemoryUsePercentage: 60

Thank you so much. Best John

Stillet af fischerjohn for 1 dag siden

Seneste svar af fischerjohn for 1 dag siden