Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 29.0 opens new windows from clicking links that are in a smaller window, should open as maximized window. How to change?

  • 36 svar
  • 161 har dette problem
  • 5592 visninger
  • Seneste svar af cyberpainter

more options

How do I click a link on a web page, and not have to maximize the window every time? Firefox 29 seemed to add this additional click annoyance and I can't see how to change that. I do not want full screen mode which is what Firefox calls it when it removes an additional row of menu items. I mean maximizing the window so I don't have to do it each time! Please tell me how to change the settings and restore this normal feature.

Ændret af cyberpainter den

Alle svar (16)

more options

I know all about how to do that, but it's extra steps that I don't wanna have to deal with.

more options

Is there some place else to report this as a bug that should be fixed? I also know I can right click or shift click, and I also enlarged the window size so it's almost maximum. But it is an adjustment to something that is basically wrong which should be fixed. Thx

more options

the question was asked before here, so better use search next time.. there's also a link to a bug report, where they basically say they don't care (i.e. no priority for them)...

Ændret af Novgorod den

more options

Thanks for the link I appreciate it.

I did use search but my search terms must have been poor because I didn't see this.

more options

This Issue is been covered several times. It is an Issue that can be worked around without any discomfort or additional effort by using Tabs, or Opened in a Pre-sized window, etc. I am sure that eventually it will be addressed. So waiting is most likely the best solution for now.

more options

Alex, I have to disagree with that statement. It is discomforting.

Firefox is not like Chrome where tabbed browsing is just forced down your throat. There are a lot of people who hate tabbed browsing and want to surf with multiple windows.

I want maximized windows, so I can see the link preview when I hover my mouse over a web-link.

I need maximized windows, so my multi-row bookmarks won't jump out of alignment and look like an ugly mess with some links not visible.

The work-around that walbus posted, changing browser.link.open_newwindow value from 2 to 1, is, at best, tolerable. For years, I've been surfing using multiple windows and gotten so used to it that I now keep knocking my self off the web with walbus' solution.

As for what some have said, Mozilla does not consider this a priority and won't fix it, I find that hard to believe. Have they learned nothing from Microsoft's debacle with Windows 8.#?

more options

Alex of course we have to wait until it's addressed. But these forums are for all to inform of issues, find work arounds if possible, help others, and notify firefox of bugs.

Sometimes changes are intentional, and people grumble and learn to live with and hopefully eventually appreciate what the change might do for them. Other times, as in this case, they are minor annoyances requiring an additional couple clicks every time. I assume this was unintentional, and will be addressed.

more options

Well, if they don't fix it, I still think someone can make an add-on that forces new windows to maximize.

more options

Will this ever be fixed?

more options

Got V30 today, with the same problem, no change that I can tell.

more options

Note that you can have the Navigation Toolbar and the Tab bar visible in full screen mode:

  • Move the mouse to the top to make the toolbars appear and right-click on the Navigation Toolbar and remove the tick on "Hide Toolbars"

You can check for problems caused by a corrupted localstore.rdf file.

more options

As for the corrupt_localstore link, window size is remembered, we did determine we can drag it to become as large as possible, but it's still not maximized. So the original problem is not solved by this, it's not a corruption I don't think. It's a bug or change in the latest 2 updates.

I don't have tool bar issues on my computer.

Another problem with not having window maximized, like someone wrote above, is you don't see link previews on the bottom, or web addresses as they load. Only when maximized do you see that.

more options

Mine was fixed by following the suggestion in another thread. "To fix this issue go into Customize and toggle "Title Bar" in the lower left corner. "

This fixed the issue for me. I use vista and firefox 31, and don't use tabs. I should add you go to menu item View/Toolbars/Customize to get there.

more options

The issue didn't have anything to do with tabs or title bar. It was a bug in Australis, but it has now been fixed with the FF 31 release.

more options

WTF!

From the day FF 31 was released until this morning, I've had no problems. New windows opened fully maximized, but now, it's not working!

Did they put in a fix with a timer just to piss people off?!

more options

Well maybe when I wrote the thread I looked at my version and it had upgraded since I did the fix. But at the time I tried what I wrote above, it did immediately fix it.

For me, for now, the issue is resolved.

  1. 1
  2. 2