X
Tryk her for at gå til webstedets mobilversion.

Supportforum

I want to hide the icons in the bookmarks toolbar.

Skrevet

In Version 29 of FireFox the "folder" or "link" icons of the bookmark toolbar are stuck VISIBLE.

I simply wish to hide/delete the icon, showing only the text as I had before. The icons are basically meaningless and I don't need them to be visible.

Please suggest the correct path for adjusting this.

Thx.

--Bry.

In Version 29 of FireFox the "folder" or "link" icons of the bookmark toolbar are stuck VISIBLE. I simply wish to hide/delete the icon, showing only the text as I had before. The icons are basically meaningless and I don't need them to be visible. Please suggest the correct path for adjusting this. Thx. --Bry.

Valgt løsning

You're welcome and glad to see that the code works for you.

Læs dette svar i sammenhæng 3

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 12.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.

Program

  • Firefox 29.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0
  • Support-URL: https://support.mozilla.org/1/firefox/29.0/Darwin/en-US/

Udvidelser

  • Adblock Plus 2.5.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Hide Tab Bar With One Tab 1.3 ({e5bbc237-c99b-4ced-a061-0be27703295f})
  • NoSquint 2.1.9 (nosquint@urandom.ca)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Grafik

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 6770M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Ændrede indstillinger

  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow: 2
  • browser.places.smartBookmarksVersion: 6
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140318013849
  • browser.startup.homepage_override.buildID: 20140318013849
  • browser.startup.homepage_override.mstone: 29.0
  • browser.tabs.autoHide: True
  • browser.tabs.loadInBackground: False
  • browser.zoom.siteSpecific: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 29.0
  • font.internaluseonly.changed: False
  • font.language.group: x-western
  • mousewheel.withcontrolkey.action: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1395371663
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1394036394

Diverse

  • User JS: Nej
  • Tilgængelighed: Nej
Luk
Jithin Mathew 1 løsninger 41 svar

Try installing this add-on!!!This step is easier!!!

https://addons.mozilla.org/en-US/firefox/addon/delete-bookmark-icons/?src=search

Try installing this add-on!!!This step is easier!!! https://addons.mozilla.org/en-US/firefox/addon/delete-bookmark-icons/?src=search

Spørgsmålsstiller

The extension says you CAN hide the folder icons, but there seems to be no directions on HOW to do it.

One lousy sentence is all that is needed. Who writes the text for these things? Sad.

--B.

The extension says you CAN hide the folder icons, but there seems to be no directions on HOW to do it. One lousy sentence is all that is needed. Who writes the text for these things? Sad. --B.
Diego Victor 658 løsninger 4175 svar

Go to View >> Toolbars >> Customize >> at the bottom of the window change the option Show to text

Go to '''View''' >> '''Toolbars''' >> '''Customize''' >> at the bottom of the window change the option '''Show''' to text

Ændret af Diego Victor den

Spørgsmålsstiller

No. Using View >> Toolbars >> Customize >>, there is no Show at the bottom of the window in Firefox 29.

I know the command to change option Show to text, but I don't see it.

View >> Toolbars >> Customize >> overlays the window in OS X Mavericks with something else than a dialog box.

Thx.

--Bry.

No. Using View >> Toolbars >> Customize >>, there is no Show at the bottom of the window in Firefox 29. I know the command to change option Show to text, but I don't see it. View >> Toolbars >> Customize >> overlays the window in OS X Mavericks with something else than a dialog box. Thx. --Bry.

Ændret af bryanzth den

Spørgsmålsstiller

I see where I can give you an image...

I want to hide (not to leave a space as in TitanTV bookmark) so that the space of the folders collapses leaving only the text (Goog, Slow, etc) and the downward pointing arrows! :)

Thx!

--Bry.

I see where I can give you an image... I want to hide (not to leave a space as in TitanTV bookmark) so that the space of the folders collapses leaving only the text (Goog, Slow, etc) and the downward pointing arrows! :) Thx! --Bry.
cor-el
  • Top 10 Contributor
  • Moderator
17468 løsninger 157853 svar

You can add this code to the userChrome.css file below the default @namespace line to hide the icons on the Bookmarks Toolbar.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks .bookmark-item > .toolbarbutton-icon {display:none!important}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can add this code to the userChrome.css file below the default @namespace line to hide the icons on the Bookmarks Toolbar. *http://kb.mozillazine.org/userChrome.css <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #personal-bookmarks .bookmark-item > .toolbarbutton-icon {display:none!important} </nowiki></pre> The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration

Spørgsmålsstiller

This is TOTALLY useless to anyone but a person intimately familiar with the code. WHY would the command for hiding folder icons that edits this code be removed?

I never thought that FireFox would turn into a beta-testing free-for-all like this.

Is this a feature of FireFox or a bug?

This is TOTALLY useless to anyone but a person intimately familiar with the code. WHY would the command for hiding folder icons that edits this code be removed? I never thought that FireFox would turn into a beta-testing free-for-all like this. Is this a feature of FireFox or a bug?

Ændret af bryanzth den

cor-el
  • Top 10 Contributor
  • Moderator
17468 løsninger 157853 svar

You have never been able to hide icons on the Bookmarks Toolbar without using an extension or code in userChrome.css like I posted above.

Which links to:

You have never been able to hide icons on the Bookmarks Toolbar without using an extension or code in userChrome.css like I posted above. *Bookmarks Deiconizer: https://addons.mozilla.org/firefox/addon/bookmarks-deiconizer/ Which links to: *http://antennasoft.net/robcee/2012/04/20/bookmarks-deiconizer-userchrome-edition/

Spørgsmålsstiller

I had the choice of using a COMMAND to insert that code.

Bookmarks Deiconizer 2.3 is clearly marked not available for FireFox 29

Where's the flinking command anymore?

Ugh.

I had the choice of using a COMMAND to insert that code. Bookmarks Deiconizer 2.3 is clearly marked not available for FireFox 29 Where's the flinking command anymore? Ugh.

Ændret af bryanzth den

cor-el
  • Top 10 Contributor
  • Moderator
17468 løsninger 157853 svar

You can look at the Stylish extension to make it easier to manage such code.

You can look at the Stylish extension to make it easier to manage such code. *Stylish: https://addons.mozilla.org/firefox/addon/stylish/ *http://userstyles.org/help/stylish_firefox

Nyttigt svar

I don't want to be annoying.

What I used before this problem was a BUTTON that made the folders/icons invisible and took out the space reserved from them, leaving the folder name and the downward pointing arrow ∇.

I believe it was in View > Toolbars > Customize and now it has gone into Orwell's Memory Hole, as usual when features are taken away and no mention is made what is "missing"...

I followed the links you provides, and it's OVERKILL. I am not and I don't want to be a techie. But what I really resent is being told with laconic language to do something that clearly is beyond my desire to learn. I just want the button or check box back. That's it.

This is frustrating and makes using FireFox painful.

I don't want to be annoying. What I used before this problem was a BUTTON that made the folders/icons invisible and took out the space reserved from them, leaving the folder name and the downward pointing arrow ∇. I believe it was in View > Toolbars > Customize and now it has gone into Orwell's Memory Hole, as usual when features are taken away and no mention is made what is "missing"... I followed the links you provides, and it's OVERKILL. I am not and I don't want to be a techie. But what I really resent is being told with laconic language to do something that clearly is beyond my desire to learn. I just want the button or check box back. That's it. This is frustrating and makes using FireFox painful.

Spørgsmålsstiller

I created a userChrome.css text file with the following code in it:

scrollbox#PlacesToolbarItems > toolbarbutton.bookmark-item > .toolbarbutton-icon {

 display: none;

}

Saved, and placed it in my profile folder, named: j8uw5ge2.default

Restarted FireFox 29.

NOTHING changed.

So I removed the file and restarted FireFox. Back to square one.

I created a userChrome.css text file with the following code in it: scrollbox#PlacesToolbarItems > toolbarbutton.bookmark-item > .toolbarbutton-icon { display: none; } Saved, and placed it in my profile folder, named: j8uw5ge2.default Restarted FireFox 29. NOTHING changed. So I removed the file and restarted FireFox. Back to square one.

Ændret af bryanzth den

cor-el
  • Top 10 Contributor
  • Moderator
17468 løsninger 157853 svar

The current Firefox beta release has the Australis interface that looks different than the user interface in the Firefox 28 and lower releases.

You can look at the Classic Theme Restorer extension to restore the choice to only show text instead of text and icons on buttons via the Customize window, but this effects all toolbars.


The current Firefox beta release has the Australis interface that looks different than the user interface in the Firefox 28 and lower releases. You can look at the Classic Theme Restorer extension to restore the choice to only show text instead of text and icons on buttons via the Customize window, but this effects all toolbars. *https://addons.mozilla.org/firefox/addon/classicthemerestorer/ ---- *https://support.mozilla.org/kb/common-questions-after-updating-to-new-firefox *https://support.mozilla.org/kb/learn-more-about-the-design-of-new-firefox *https://support.mozilla.org/kb/how-to-make-new-firefox-look-like-old-firefox *https://support.mozilla.org/kb/what-happened-to-the-add-on-bar

Spørgsmålsstiller

No. That only wrecks things more.

It appears that my Find text option at the bottom goes away or is disabled. I Disabled the Classic Theme Restorer and the Find text option returns.

I realize this sounds finicky, but I can't believe that the feature which was so helpful was removed. Honestly, I don't recall how it was enabled. I mean after how many beta revisions, who can remember what was where? And I can't even reject an update because of a feature change I don't like, because it seems 'you can't go back'.

Thanks.

No. That only wrecks things more. It appears that my Find text option at the bottom goes away or is disabled. I Disabled the Classic Theme Restorer and the Find text option returns. I realize this sounds finicky, but I can't believe that the feature which was so helpful was removed. Honestly, I don't recall how it was enabled. I mean after how many beta revisions, who can remember what was where? And I can't even reject an update because of a feature change I don't like, because it seems 'you can't go back'. Thanks.

Ændret af bryanzth den

cor-el
  • Top 10 Contributor
  • Moderator
17468 løsninger 157853 svar

Yes, I was afraid that this is the case.
You can't set this per toolbar or only for the bookmarks item that contains the bookmarks AFAIK without using the above mentioned code in the userChrome.css file.

It is not that difficult to create the chrome folder in the profile folder and create a plain text file with the name userChrome.css and paste the code in this file.
Make sure that the file is a plain text file without any formatting code like rich text.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Director: Show Folder (Linux: Open Director; Mac: Show in Finder)

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks .bookmark-item > .toolbarbutton-icon {display:none!important}
Yes, I was afraid that this is the case.<br /> You can't set this per toolbar or only for the bookmarks item that contains the bookmarks AFAIK without using the above mentioned code in the userChrome.css file. It is not that difficult to create the chrome folder in the profile folder and create a <u>plain text file</u> with the name userChrome.css and paste the code in this file.<br /> Make sure that the file is a plain text file without any formatting code like rich text. *http://en.wikipedia.org/wiki/TextEdit You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Director: Show Folder (Linux: Open Director; Mac: Show in Finder) ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #personal-bookmarks .bookmark-item > .toolbarbutton-icon {display:none!important} </nowiki></pre>

Spørgsmålsstiller

UPDATE. YES. This solution below, with all the t's dotted and all the i's crossed worked. This needs to be made as a clear solution to this problem. For the most of us, we are not sure if even one character misplaced can cause havoc. We simply don't know out here. So all the steps need to be in sequence so that we are sure each step is right. Here, finally, it is.

I leave my answer as such, but the things i did finally did solve the problem. Next post shows the correct result.

I know the diff between .txt and .rtf and I can force a text file to have the .css extension. I can put the code into an empty file named userChrome.css. The the next question is this:

"to create the chrome folder in the profile folder" = A folder explicitly named "chrome", not "Chrome" in the profile folder that I have opened:

/Users/Owner/Library/Application Support/Firefox/Profiles/j8uw5ge2.default/chrome

in that folder will be a file userChrome.css with the following code:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks .bookmark-item > .toolbarbutton-icon {display:none!important}

Let me know about case of chrome/Chrome so that I can proceed. Note, the code you provided was pasted as you indicated. This window seems to convert #personal-bookmarks to a 1. personal-bookmarks... I dunno why.

Thanks!

UPDATE. YES. This solution below, with all the t's dotted and all the i's crossed worked. This needs to be made as a clear solution to this problem. For the most of us, we are not sure if even one character misplaced can cause havoc. We simply don't know out here. So all the steps need to be in sequence so that we are sure each step is right. Here, finally, it is. I leave my answer as such, but the things i did finally did solve the problem. Next post shows the correct result. I know the diff between .txt and .rtf and I can force a text file to have the .css extension. I can put the code into an empty file named userChrome.css. The the next question is this: "to create the chrome folder in the profile folder" = A folder explicitly named "chrome", not "Chrome" in the profile folder that I have opened: /Users/Owner/Library/Application Support/Firefox/Profiles/j8uw5ge2.default/chrome in that folder will be a file userChrome.css with the following code: <pre><nowiki> @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #personal-bookmarks .bookmark-item > .toolbarbutton-icon {display:none!important}</nowiki></pre> Let me know about case of chrome/Chrome so that I can proceed. Note, the code you provided was pasted as you indicated. This window seems to convert #personal-bookmarks to a 1. personal-bookmarks... I dunno why. Thanks!

Ændret af cor-el den

Nyttigt svar

In FireFox 29, I could not hide bookmark toolbar folder icons. I want to hide the bookmark toolbar folders, so that only the text shows along with the downward pointing arrows.

This is the way:

1. Create a text file in TextEdit.app. Give it the name "userChrome.css". Make sure that the file is a plain text file without any formatting code like rich text. If the current name is "Untitled.txt" change it to "userChrome.css". TextEdit will ask if you want the new filename extension. Say [Use .css]

2. In this file add the following code, as suggested above by cor-el. When I paste it here, the second line displays differently than cor-el's. Go to cor-el's post and copy the code and put it in the file. Check the second line to be sure it's right.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#personal-bookmarks .bookmark-item > .toolbarbutton-icon {display:none!important}

Save the file.

3. This file must be in a folder named "chrome" in the user's FireFox profile. The method suggested by cor-el to open the right folders is correct. Do it one of these two ways:

FIREFOX: You can use this method to go to the currently used Firefox profile folder: Click the Open menu icon in upper right corner of FireFox 29. Click the (?) icon: Follow this path: Troubleshooting Information > Profile Director: Show Folder (Linux: Open Director; Mac: Show in Finder)

FINDER: Click the Finder icon in the dock. On the menu bar, click the Go menu, hold down the option or alt key and select Library. A window will open containing your Library folder. Open the "Application Support" folder, then open the "Firefox" folder, and then the "Profiles" folder. Open the folder with “default” in the name to open your profile.

In the folder with "default" in the name, create a folder "chrome".

4. Put the text file "userChrome.css" into that "chrome" folder.

5. Close FireFox and restart.

6. After these steps the attached image shows the result.

7. I am happy.

Thanks to cor-el for finally letting me get to this solution.

Best,

--Bry.

In FireFox 29, I could not hide bookmark toolbar folder icons. I want to hide the bookmark toolbar folders, so that only the text shows along with the downward pointing arrows. This is the way: 1. Create a text file in TextEdit.app. Give it the name "userChrome.css". Make sure that the file is a plain text file without any formatting code like rich text. If the current name is "Untitled.txt" change it to "userChrome.css". TextEdit will ask if you want the new filename extension. Say [Use .css] 2. In this file add the following code, as suggested above by cor-el. When I paste it here, the second line displays differently than cor-el's. Go to cor-el's post and copy the code and put it in the file. Check the second line to be sure it's right. <pre><nowiki> @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #personal-bookmarks .bookmark-item > .toolbarbutton-icon {display:none!important}</nowiki></pre> Save the file. 3. This file must be in a folder named "chrome" in the user's FireFox profile. The method suggested by cor-el to open the right folders is correct. Do it one of these two ways: FIREFOX: You can use this method to go to the currently used Firefox profile folder: Click the Open menu icon in upper right corner of FireFox 29. Click the (?) icon: Follow this path: Troubleshooting Information > Profile Director: Show Folder (Linux: Open Director; Mac: Show in Finder) FINDER: Click the Finder icon in the dock. On the menu bar, click the Go menu, hold down the option or alt key and select Library. A window will open containing your Library folder. Open the "Application Support" folder, then open the "Firefox" folder, and then the "Profiles" folder. Open the folder with “default” in the name to open your profile. In the folder with "default" in the name, create a folder "chrome". 4. Put the text file "userChrome.css" into that "chrome" folder. 5. Close FireFox and restart. 6. After these steps the attached image shows the result. 7. I am happy. Thanks to cor-el for finally letting me get to this solution. Best, --Bry.

Ændret af cor-el den

cor-el
  • Top 10 Contributor
  • Moderator
17468 løsninger 157853 svar

Valgt løsning

You're welcome and glad to see that the code works for you.

You're welcome and glad to see that the code works for you.
jml49 0 løsninger 1 svar

"You have never been able to hide icons on the Bookmarks Toolbar without using an extension or code in userChrome.css like I posted above. "


Not at all a true statement!

"You have never been able to hide icons on the Bookmarks Toolbar without using an extension or code in userChrome.css like I posted above. " Not at all a true statement!

Ændret af jml49 den

Spørgsmålsstiller

As it stands, I DID hide them. I am very happy. Thanks to another user here, cor-el, who provided the right code (I was not happy with the code, but it worked).

As it stands, I DID hide them. I am very happy. Thanks to another user here, cor-el, who provided the right code (I was not happy with the code, but it worked).

Ændret af bryanzth den