Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not recongize plug in already on the computer.

more options

I had Adobe Flash Player 11 Active X (11.9.900.170) installed on my computer before downloading and starting to use Firefox. I went to a web site, and Firefox is telling me a plug in is needed to display the content of 2 windows on the web page. I used the "Install plugin" link, but the automatic installation failed. I then did the manual installation. I now have art of the Adobe 11 Flash Player Plugin (11.9.900.170) installed as well. When I go back to the web page, I am still getting the same error message. When I try to install, it is telling me to install the same plugin (& version) that is already on my computer. Why isn't Firefox recognizing what is already on my computer? Thank you.

Alle svar (2)

more options

Have you tried deleting the pluginreg.dat file in the profile folder.

SEE: http://kb.mozillazine.org/Flash#Testing_Flash and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

They both include instructions for deleting the file and refreshing the plugin list.

more options

Firefox doesn't use ActiveX, it needs the NPAPI version of Flash.

http://get.adobe.com/flashplayer/