Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I want to remove Firefox as my default browser. How?

  • 8 svar
  • 10 har dette problem
  • 17934 visninger
  • Seneste svar af John99

more options

I have a MAC Pro laptop -- all of the repsonses deal with PC environments. I know there is an easy solution. I just can't find it. I'd rather not delete Firefox from my computer but if I can't figure this out, I will. Thx

Valgt løsning

I was just trying to find answers from the kb articles. The one I posted actually said to use the Safari option.

From your screenshot, you are in Firefox's options, and that may help, but you are in the left most tab [General] You need to be in the right hand tab[Advanced] See Make Firefox your default browser

I do not think that actually change the default browser merely stops Firefox being the default browser all the time. You will still need to follow the other article,that says

Using your operating system
  1. From the Dock, open Safari.
  2. From the menu bar, click the Safari menu and select Preferences....
  3. Click the General icon, to display the General preferences panel.
  4. In the Default Web Browser: drop-down list, select Firefox.
  5. Quit Safari
Læs dette svar i sammenhæng 👍 1

Alle svar (8)

more options

Hello. 1.Start your Firefox . 2.Click on The Alt button of your keyboard (staying on the Firefox window). 3.Click on the Tools then Select Options (in the sub menu) 4.On the Extreme corner of the small Window click on Advanced option. 5. When you click on the Advanced option there would be sub option namely General click on that. 6.At the end you will find System Defaults (simply unchecked that).

                          You are Done
more options

See this article, that does explain how to choose & set the default browser.

Note links of the above type should redirect to the correct version of the article. (You should see https://support.mozilla.org/en-US/kb/setting-firefox-default-browser-does-not-work#firefox:mac:fx25 )

The article version may also be selected manually using the tools button on the article (Check that out in Private browsing or you may need to reset a couple of site cookies. )

more options

The way to 'undo' Firefox being the default browser is always to set another browser as the default browser.
There is usually a button in the Options/Preferences of a browser to achieve this.

more options

1. I repeat I am asking about a MAC. There is no options selection in the tools tab except as a subset of the adblock.

2. You are right in that no browser is opening automatically, but Firefox is functioning as the default browser half of the time, because I clicked when I installed it. However, I since decided to use Safari most of the time. But if I click on a link through my email it opens via Firefox. This is causing me problems if I already have FB in Safari for example.

3. If I could figure out where that was, I would do it in a heartbeat

more options

Did you look at this. As posted in my last post. It explains how yo choose the Browser from the Mac OS X Opeating System

113f7b1b820e1b71faeb5aa77e042443-1259803440-200-1.jpg

Use the arrow to select something other than Firefox.

more options

My screen does not look like yours. The " restore default" button is ambiguous and doesn't appear to do anything at all. Either restore Safari -- or reinforce Firefox. The status quo remains

more options

This is about opening the settings window in Safari because there is where you make default system settings like this on Mac and isn't not about making changes in Firefox.

In Firefox you only need to make sure that checking whether Firefox is the default browser is disabled.

  • Firefox > Preferences > Advanced > General: System Defaults:
    "Always check to see if Firefox is the default browser on startup"
more options

Valgt løsning

I was just trying to find answers from the kb articles. The one I posted actually said to use the Safari option.

From your screenshot, you are in Firefox's options, and that may help, but you are in the left most tab [General] You need to be in the right hand tab[Advanced] See Make Firefox your default browser

I do not think that actually change the default browser merely stops Firefox being the default browser all the time. You will still need to follow the other article,that says

Using your operating system
  1. From the Dock, open Safari.
  2. From the menu bar, click the Safari menu and select Preferences....
  3. Click the General icon, to display the General preferences panel.
  4. In the Default Web Browser: drop-down list, select Firefox.
  5. Quit Safari

Ændret af John99 den