X
Tryk her for at gå til webstedets mobilversion.

Supportforum

How do I stop videos from auto-playing?

Skrevet

Yahoo decided to follow the herd of those annoying advertisements and banner ads, where they now auto-play the news videos when you visit the page. I found no way to stop it. How can I prevent videos on Yahoo News from auto playing?

Yahoo decided to follow the herd of those annoying advertisements and banner ads, where they now auto-play the news videos when you visit the page. I found no way to stop it. How can I prevent videos on Yahoo News from auto playing?

Yderligere systemdetaljer

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Yderligere information

Luk
jscher2000
  • Top 10 Contributor
8794 løsninger 71950 svar

Nyttigt svar

Is this for Firefox Mobile on Android or Firefox Desktop on Windows 7? I will assume desktop.

Firefox plays some video natively (using its HTML5 player) and some using plugins, so this is a two-part answer:

(1) HTML5

Firefox has a setting to ignore "autoplay" when it is hardcoded into an HTML <video> or <audio> tag. However, if the page is using a script to virtually click the play button, then the setting does not apply. See this post for more on that: https://support.mozilla.org/en-US/que.../979671#answer-509217.

(2) Plugins

You can change individual plugins, such as Flash, from running automatically to requiring your approval; this is known as click-to-play. You make the switch on the Add-ons page, and then when you encounter Flash on a page, you use the Lego-like icon in the address bar to enable Flash.

To modify your plugin setting, either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Change from "Always Activate" to "Ask to Activate".

In addition to this built-in method, there are a variety of add-ons you can use to manage how plugins work.

Is this for Firefox Mobile on Android or Firefox Desktop on Windows 7? I will assume desktop. Firefox plays some video natively (using its HTML5 player) and some using plugins, so this is a two-part answer: (1) HTML5 Firefox has a setting to ignore "autoplay" when it is hardcoded into an HTML &lt;video> or &lt;audio> tag. However, if the page is using a script to virtually click the play button, then the setting does not apply. See this post for more on that: [https://support.mozilla.org/en-US/questions/979671#answer-509217]. (2) Plugins You can change individual plugins, such as Flash, from running automatically to requiring your approval; this is known as click-to-play. You make the switch on the Add-ons page, and then when you encounter Flash on a page, you use the Lego-like icon in the address bar to enable Flash. To modify your plugin setting, either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Plugins. Change from "Always Activate" to "Ask to Activate". In addition to this built-in method, there are a variety of add-ons you can use to manage how plugins work.

Spørgsmålsstiller

Hmm, might have been an important piece of info to put into my original question....

It's Firefox Mobile for Android.

Hmm, might have been an important piece of info to put into my original question.... It's Firefox Mobile for Android.
jscher2000
  • Top 10 Contributor
8794 løsninger 71950 svar

Nyttigt svar

Actually, to just convert one site from automatically running flash to asking, you can use the Page Info dialog. Call that up from any page on news.yahoo.com using either:

  • right-click and choose View Page Info > Permissions
  • Tools menu > Page Info > Permissions
  • click the globe or padlock icon on the address bar > More Information > Permissions

Next to Adobe Flash, change from Use default to Always Ask. Then when you reload the page, Flash won't start until you approve it from the Lego-like icon.

Screen shots attached for reference.

Actually, to just convert one site from automatically running flash to asking, you can use the Page Info dialog. Call that up from any page on news.yahoo.com using either: * right-click and choose View Page Info > Permissions * Tools menu > Page Info > Permissions * click the globe or padlock icon on the address bar > More Information > Permissions Next to Adobe Flash, change from Use default to Always Ask. Then when you reload the page, Flash won't start until you approve it from the Lego-like icon. Screen shots attached for reference.

Ændret af jscher2000 den

jscher2000
  • Top 10 Contributor
8794 løsninger 71950 svar

On Firefox for Android, click-to-play is the default for Flash and other plugins. In my case, the Flash player shows click-to-play. If you're not getting that, you might not have Flash and instead you might be viewing HTML5 video. I'm not sure what options you have there.

On Firefox for Android, click-to-play is the default for Flash and other plugins. In my case, the Flash player shows click-to-play. If you're not getting that, you might not have Flash and instead you might be viewing HTML5 video. I'm not sure what options you have there.