Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I m trying to have language pack enabled by default for any new profile in firefox 25

  • 2 svar
  • 14 har dette problem
  • 1 visning
  • Seneste svar af dveg

more options

I m working with virtual machine used in 12 different countries, we've installed firefox in english but the users want to have a localized version. I found how to add them for every new profile (by putting them in the browser directory) but they appear as deactivated for the users and therefore we cannot switch the UI language using customized .js files. Is there a way to activate them by default ?

I m working with virtual machine used in 12 different countries, we've installed firefox in english but the users want to have a localized version. I found how to add them for every new profile (by putting them in the browser directory) but they appear as deactivated for the users and therefore we cannot switch the UI language using customized .js files. Is there a way to activate them by default ?

Valgt løsning

Do they work if you create an /distribution/bundles/ folder in the Firefox program folder?

You need to create a folder with the name of the GUID of the language pack and extract the content of the XPI files to the /distribution/bundles/ folder to make it work.

I tested it on Linux and it seems to work.
They do not show in about:addons, but if I set the general.useragent.locale pref properly and restart Firefox then the language changes.

EDIT: Looks that this only works with the en-US version

Læs dette svar i sammenhæng 👍 2

Alle svar (2)

more options

Valgt løsning

Do they work if you create an /distribution/bundles/ folder in the Firefox program folder?

You need to create a folder with the name of the GUID of the language pack and extract the content of the XPI files to the /distribution/bundles/ folder to make it work.

I tested it on Linux and it seems to work.
They do not show in about:addons, but if I set the general.useragent.locale pref properly and restart Firefox then the language changes.

EDIT: Looks that this only works with the en-US version

Ændret af cor-el den

more options

Thanks for the quick answer.

I tried your solution, I created the folder :

"C:\Program Files (x86)\Mozilla Firefox\distribution\bundles\{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"

I also tried :

C:\Program Files (x86)\Mozilla Firefox\distribution\bundles\Langpack-en-GB@firefox.mozilla.org

It did not work, unzipping or not the .xpi did not seems to make much difference either. I did the test with an existing profile and a new one. Is there a parameter or a command line to automatically activate addons ?

EDIT : I stand corrected, it does work but only with the US version of mozilla. I was doing the test on my french mozilla version at home. I did a reinstallation with the US version that we uses for our VM and it worked just like you said. Thanks a lot.

Ændret af dveg den