Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Search now shows Non-USA results

  • 3 svar
  • 3 har dette problem
  • 1 visning
  • Seneste svar af mjgh06

more options

I am using Firefox 23, but don't know exactly when this issue started as I don't do many searches. I would guess it has happened within the last two months or so. Here is the issue - I have my keywordURL search feature set to http://www.google.com/search?ie=UTF-8&oe=UTF-8&q= I search from my address bar and not the search box. Recently I have noticed all my searches show up with foreign (non-USA) websites/info. Even on product searches for buying, it used to show images with a price for sale in US currency, now it shows Euros. Info searches produce mostly UK sites or some muslim sites.

How do I get it to revert back to USA searches?

I am using Firefox 23, but don't know exactly when this issue started as I don't do many searches. I would guess it has happened within the last two months or so. Here is the issue - I have my keywordURL search feature set to http://www.google.com/search?ie=UTF-8&oe=UTF-8&q= I search from my address bar and not the search box. Recently I have noticed all my searches show up with foreign (non-USA) websites/info. Even on product searches for buying, it used to show images with a price for sale in US currency, now it shows Euros. Info searches produce mostly UK sites or some muslim sites. How do I get it to revert back to USA searches?

Alle svar (3)

more options

Google may have forgotten where you are. You may need to change your location settings https://support.google.com/websearch/answer/873?rd=1.

more options

Starting with Firefox 23 the keyword.URL pref is no longer supported and it is no longer possible to specify the search engine for the location bar that way.
The search engine that is used in the location bar is the search engine that is selected in the search Bar on the Navigation Toolbar.
You can disable automatic searching via the location bar by setting keyword.enabled to false and use a (one letter) keyword search to use a specific search engine instead to search via the location bar.

Another possibility is to disable keyword search (keyword.enable = false) and use a (one letter) keyword search for searching via the location bar.
You can set a keyword for an installed search engine via Manage Search Engines (click the search engines icon on the search bar).
That also allows to switch easily between search engines when searching via the location bar and you also do not have a problem with one word searches.

See also:

more options

Okay I checked location setting and it was correctly set to USA so that is not the issue.

secondly, the address bar is still able to be used as set to Google by the keyword url or somehow because I have my search box set to Bing and have always used the address bar for Google.

I have found that if I change the keywordurl to just the web address of the Google I'm Feeling Lucky search page - it will go to that page when I enter search terms, and then if I use that search engine I get USA results. So this tells me 1. the keywordurl still functions because it can be changed; and 2. that if Google was set correctly, it does show USA results for me. So I believe somehow the keyword url for the google.com link is somehow changed to show nonUSA results which would be a reason why as cor-el stated it is no longer compatible in v.23 of Firefox.